Results 1 to 7 of 7

Thread: libQtWebkit4 version issues

  1. #1

    Default libQtWebkit4 version issues

    Hi all,
    I have opensuse 11.4 installed with KDE 4.7 repos enabled. I have a problem with the libQtWebKit4 package. In the KDE 4.7 core repo the version number is 2.1.90-2.1. But in the opensuse11.4 Update repo the version number is 4.7.1-8.15.1. Every time I update my packages I am running into package dependency errors. My current KDE version is 4.7.4. I was reading through the webkit webpage and there is a message indicating that before Qt 4.7, there was not a separate libQtWebKit4 package. Is there any way the version number can be synced between the Kde 4.7 repo and the 11.4 update repo, because it is very confusing.

    Thanks

  2. #2
    Join Date
    Jun 2008
    Location
    Stoney Stanton - England
    Posts
    1,102

    Default Re: libQtWebkit4 version issues

    Well the 4 version is the latest. This is included in:-

    Index of /repositories/KDE:/Distro:/Factory/openSUSE_11.4/x86_64

    Do you mean that you are using kde 4.7.2 as 4.7.4 has not been released yet!

    What repos are you using?

  3. #3
    Join Date
    Feb 2010
    Location
    Upstate New York, USA
    Posts
    480

    Default Re: libQtWebkit4 version issues

    I recently faced this same problem (see http://forums.opensuse.org/english/get-technicall-help-here/applications/466372-libqt4-security-update.html). The update presented as a "Security Update", "libqt4 security update" under "Security" in YAST. I have marked the update as "Taboo - never install" without subsequent issue.
    Lap: Gateway NV79, i5-430, 4GB, 2 x 500GB HD, Intel GMA HD
    openSUSE Leap 15.0 x64 + 42.3 x64, KDE 5.15.3, Ubuntu 16.04 LTS, Windows 7

    Test:: openSUSE 15.0, KDE Plasma, Windows/XP/SP3 guest.

  4. #4

    Default Re: libQtWebkit4 version issues

    On Tue, 18 Oct 2011 19:06:03 GMT dth2 wrote:

    > Well the 4 version is the latest. This is included in:-
    >
    > 'Index of /repositories/KDE:/Distro:/Factory/openSUSE_11.4/x86_64'
    > (http://tinyurl.com/3cyyfvg)


    I have the same problem that "zypper lp" show this:

    Repository | Name | Version | Kategorie | Status
    -----------+-------------------+---------+-----------+-------------
    Update | libQtWebKit-devel | 5129 | security | erforderlich

    But a "zypper patch" shows this problem

    libQtWebKit4-4.7.1-8.15.1.i586 requires libqt4-x11 = 4.7.1, but this
    requirement cannot be provided uninstallable providers:
    libqt4-x11-4.7.1-7.1.i586[oss] libqt4-x11-4.7.1-8.15.1.i586[update]

    and a "yes" in this case will deinstall the most of the packages from
    this repo:

    http://download.opensuse.org/reposit...openSUSE_11.4/

    At the moment a search for libQtWebKit-devel show this:

    S | Name | Typ | Version | Arch | Repository
    --+-------------------+-------+--------------+--------+-----------
    i | libQtWebKit-devel | Paket | 2.1.90-2.1 | i586 | KDE 4.7
    v | libQtWebKit-devel | Paket | 4.7.1-8.15.1 | i586 | Update
    v | libQtWebKit-devel | Paket | 4.7.1-7.1 | i586 | Oss
    | libQtWebKit-devel | Patch | 5129 | noarch | Update

    It seems that the patch wants to update a package which is not
    installed

  5. #5
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: libQtWebkit4 version issues

    On 2011-10-19 06:37, Ferenginar wrote:
    > It seems that the patch wants to update a package which is not
    > installed


    It appears that I was wrong in thinking that zypper patch respected vendor,
    instead it changes. I believe that is a bug, you could try reporting in
    bugzilla.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

  6. #6

    Default Re: libQtWebkit4 version issues

    On Wed, 19 Oct 2011 12:18:07 GMT "Carlos E. R." wrote:

    > It appears that I was wrong in thinking that zypper patch respected
    > vendor, instead it changes. I believe that is a bug, you could try
    > reporting in bugzilla.


    Oh, this vendor change could be come from my zypp.conf:

    solver.allowVendorChange = true

    I prefer to handle such situations with the priority of the repo and
    now i'm unsure if this is a bug or what i risk if i change this in the
    configuration. But this is not a problem for me and i can wait until
    the big work for 12.1 is over.

    Patches be seldom and if i have to do a "zypper patch" than zypper by
    itself offers to ignore the patch for libQtWebKit-devel. A "zypper up"
    don't show me this.

  7. #7

    Default Re: libQtWebkit4 version issues

    Thanks for the reply guys,
    I am using the regular KDE 4.7 repos and not the factory repos.

    Upon further researching I found that Qtwebkit was split and started having its own version number starting from Qt version 4.7. It seems that there is some version number conflict from the developers. Also when I looked into the URL line in technical data tab ( in YAST) , the libqtwebkit version 4.7.* has the url as QT software's Store | Sofware for Research & Development while the 2.1.* version has it at webkit.org. So I think I will stick to the 2.1.* version for now.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •