Results 1 to 9 of 9

Thread: Rawtherapee istall problem

  1. #1
    Join Date
    Aug 2008
    Location
    Bendigo, Australia
    Posts
    244

    Default Rawtherapee istall problem

    I have just installed OpenSuse 114 on a new laptop with KDE 4.7.2
    I am trying to install Rawtherapee but I'm having problems.
    I have tried installing through Yast & the treminal but get the same result.
    All installs ok but there is nothing in the menu and I am unable to start from the terminal.
    In the terminal, I get this,
    Code:
    # rpm -ivh Rawtherapee-3-154.1.x86_64.rpm
    Preparing...                ########################################### [100%]
            package Rawtherapee-3-154.1.x86_64 is already installed
    then
    Code:
    # rpm -qi rawtherapee -l
    package rawtherapee is not installed
    Is anyone able to help me? It has installed fine on my other computers and I'm using the same file on this one.
    Thanks

  2. #2

    Default Re: Rawtherapee istall problem

    Hello asarge,

    Quote Originally Posted by asarge
    I have just installed OpenSuse 114 on a new laptop with KDE 4.7.2
    I am trying to install Rawtherapee but I'm having problems.
    I have tried installing through Yast & the treminal but get the same result.
    All installs ok but there is nothing in the menu and I am unable to start from the terminal.
    It might sound as a silly question but have you tried logging out and in again?
    Also you say you're unable to start it from terminal, but what command are you trying and what is the output?

    Code:
    # rpm -qi rawtherapee -l
    package rawtherapee is not installed
    Note that rpm is case sensitive, so you should try the command:
    Code:
    rpm -qi Rawtherapee -l
    Best of luck!
    Where did I put my coffee cup?
    dir -R /home/* | grep "coffee cup"

  3. #3
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,136

    Default Re: Rawtherapee istall problem

    You did not tell how you tried to install (where did it come from, etc., I found it openSUSE ready on software.opensuse.org: Search Results ). But that does not involve installing using rpm, but using YaST or zypper.
    And indeeed rpm tells you, it is allready installed one way or the other (and yes, Rawtherapee is something different from rawtherapee).

    You better first confirm that you used YaST to install it from one of the openSUSE ready repositories found above (which one) so we know what you did (and maybe we could do likewise to see the same as you do). And when different please explain why you did use a different way, which one, etc.
    Henk van Velden

  4. #4
    Join Date
    Aug 2008
    Location
    Bendigo, Australia
    Posts
    244

    Default Re: Rawtherapee istall problem

    Thanks for that guys! I did spell it without the capitals. I got that it was installed, but it still would not start. I tried starting it in a terminal using the same name as it is on my other computer where it is working.
    Code:
    sarge@linux:~> rtstart %U
    If 'rtstart' is not a typo you can use command-not-found to lookup the package that contains it, like this:
        cnf rtstart
    I had tried logging in and out again.
    I had installed through the terminal with "rpm -ivh Rawtherapee" and by using Yastto install the downloaded rpm file. I cant remember where I got the file from as it was quite a while ago that I installed it on my other computer (I can't even remember how I installed then).
    I don't know why I didn't think of looking for a one click install. The version from the Package Search was a latter version than I had been using.
    So I used the one click install and it is all working.
    Thanks again for your help. I guess the couple of hours sleep I got last night was not enough

  5. #5
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,136

    Default Re: Rawtherapee istall problem

    When you do not even know where the package is from, I would uninstall it and use the one from the openSUSE repo. And then come back whgen you still can not get it running.

    Also
    Code:
    rtstart %U
    from a terminal will not do much usefull I guess. What is %U supposed to mean there?

    Installing a version of the product that is packaged for openSUSE might install an item in the main Kmenu and thus solve your problem how to start it.
    Last edited by hcvv; 15-Oct-2011 at 02:50.
    Henk van Velden

  6. #6
    Join Date
    Aug 2008
    Location
    Bendigo, Australia
    Posts
    244

    Default Re: Rawtherapee istall problem

    Quote Originally Posted by hcvv View Post
    When you do not even know where the package is from, I would uninstall it and use the one from the openSUSE repo. And then come back whgen you still can not get it running.

    Also
    Code:
    rtstart %U
    from a terminal will not do much usefull I guess. What is %U supposed to mean there?

    Installing a version of the product that is packaged for openSUSE might install an item in the main Kmenu and thus solve your problem how to start it.
    I have removed the old version now. I also have no idea what the "%U" is about, but if I use
    Code:
    rtstart %U
    in the terminal on my other computer it starts the program.

  7. #7
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,136

    Default Re: Rawtherapee istall problem

    You have removed the version where you do not know the origin. Have you now installed (by one-click or aotherwise by YaSt/zypper) an version from an openSUSE repo/ When yes, does it install an entry in you KDE Kmenu?

    BTW the
    Code:
    rtstart %U
    looks to me to be the command to execute when you click the menu entry (which you hadn't, but which I hope you will have after the correct install). In that case the %U is processed by the Kmenu handler and the %U is replaced by a real parameter (like an URL or so). It is not something that should be typed in a bash terminal session. But I guess that rtstart skips it and that it therefore is harmless in this case.
    Henk van Velden

  8. #8
    Join Date
    Aug 2008
    Location
    Bendigo, Australia
    Posts
    244

    Default Re: Rawtherapee istall problem

    I have removed the version of unknown origin and used the one click install. It is now in the menu
    Thanks for that.

  9. #9
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,136

    Default Re: Rawtherapee istall problem

    You are welcome.

    Whenever you want other software on your system the sequence should be to first try

    • find it in standard repos;
    • find it in other openSUSE repos (software.opensuse.org: Search Results);
    • find an RPM where they say it is crafted for openSUSE (and be prepared for it being for another/older version and giving depedency problems;
    • find an RPM not specialy for openSUSE and be prepared for the above problems plus the fact that files can end up in different places from what openSUSE normaly uses (and thus e.g. a menu entry could be misplaced in darkness);
    • find a tarball where you have to build the product and be prepared for all of the above problems plus that you may have to install the development pattern (to get C and make, etc.) and more unexpeccted things of a diverse kind.
    Henk van Velden

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •