Results 1 to 5 of 5

Thread: Cannot enable repository

  1. #1

    Default Cannot enable repository

    Hi,

    I hope you can help. I am using Suse 11.4, and I have tried to add a couple of repositories from the community repositories using Yast. It does add them to the list, but if they are enabled I get an error message when starting Software Management. The error just shows "There was an Error in the Repository initialization" with any other specifics. Below is the output from zypper showing the repositories. If try to enable either the Packman or openSuse BuildService - Games I get the error.

    # | Alias | Name | Enabled | Refresh | Priority | Type | URI | Service
    ---+----------------------------------+----------------------------------+---------+---------+----------+--------+-----------------------------------------------------------------------------------+--------
    1 | Education | Education | Yes | No | 99 | rpm-md | Index of /repositories/Education/openSUSE_11.4 |
    2 | Updates-for-openSUSE-11.4-11.4-0 | Updates for openSUSE 11.4 11.4-0 | Yes | No | 99 | rpm-md | Index of /update/11.4 |
    3 | devel:languageserl | devel:languageserl | Yes | No | 99 | rpm-md | Index of /repositories/devel:/languages:/perl/openSUSE_11.4 |
    4 | download.opensuse.org-games | openSUSE BuildService - Games | No | No | 99 | rpm-md | Index of /repositories/games/openSUSE_11.4 |
    5 | openSUSE-11.4-11.4-0 | openSUSE-11.4-11.4-0 | No | No | 99 | yast2 | cd:///?devices=/dev/disk/by-id/ata-HL-DT-ST_DVD-RAM_GSA-H60L_K1H77GG1154,/dev/sr0 |
    6 | packman.inode.at-suse | Packman Repository | No | No | 99 | rpm-md | Index of /suse/openSUSE_11.4/ |
    7 | repo-debug | openSUSE-11.4-Debug | No | No | 99 | yast2 | Index of /debug/distribution/11.4/repo/oss |
    8 | repo-debug-update | openSUSE-11.4-Update-Debug | No | No | 99 | rpm-md | Index of /debug/update/11.4 |
    9 | repo-non-oss | openSUSE-11.4-Non-Oss | Yes | No | 99 | yast2 | Index of /distribution/11.4/repo/non-oss |
    10 | repo-oss | openSUSE-11.4-Oss | Yes | No | 99 | yast2 | Index of /distribution/11.4/repo/oss |
    11 | repo-source | openSUSE-11.4-Source | Yes | No | 99 | yast2 | Index of /source/distribution/11.4/repo/oss |

  2. #2
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,875
    Blog Entries
    2

    Default Re: Cannot enable repository

    Your posted output looks only to be a listing of your configured repositories.

    Perhaps more useful might be if you do the following from a root CLI

    Code:
    # zypper refresh
    That command will download the most recent information for each of your configured repositories, if any experience a problem you'll get a prompt to continue, abort or skip.

    HTH,
    Tony

  3. #3
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,788

    Default Re: Cannot enable repository

    Welcome new member!

    One of the not so easy found, but very usefull features on this forums is posting between CODE tags (like tsu2 did) your computer text to conserve the column lay-out: Posting in Code Tags - A Guide
    Henk van Velden

  4. #4

    Default Re: Cannot enable repository

    Thanks guys refreshing from the command line worked. Strange, I tried using refresh all in the Software Management GUI and it didn't correct it.

    Thanks also for the editor tip, I was looking for the code tags and couldn't find them

  5. #5
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: Cannot enable repository

    On 10/12/2011 05:06 PM, GeorgeC5614 wrote:
    >
    > Hi,
    >
    > I hope you can help. I am using Suse 11.4, and I have tried to add a
    > couple of repositories from the community repositories using Yast. It
    > does add them to the list, but if they are enabled I get an error
    > message when starting Software Management. The error just shows "There
    > was an Error in the Repository initialization" with any other specifics.
    > Below is the output from zypper showing the repositories. If try to
    > enable either the Packman or openSuse BuildService - Games I get the
    > error.
    >
    > # | Alias | Name
    > | Enabled | Refresh | Priority | Type | URI
    > | Service
    > ---+----------------------------------+----------------------------------+---------+---------+----------+--------+-----------------------------------------------------------------------------------+--------
    > 1 | Education | Education
    > | Yes | No | 99 | rpm-md | 'Index of
    > /repositories/Education/openSUSE_11.4'
    > (http://download.opensuse.org/reposit...openSUSE_11.4/)
    > |
    > 2 | Updates-for-openSUSE-11.4-11.4-0 | Updates for openSUSE 11.4
    > 11.4-0 | Yes | No | 99 | rpm-md | 'Index of /update/11.4'
    > (http://download.opensuse.org/update/11.4/)
    > |
    > 3 | devel:languageserl | devel:languageserl
    > | Yes | No | 99 | rpm-md | 'Index of
    > /repositories/devel:/languages:/perl/openSUSE_11.4'
    > (http://tinyurl.com/3b45la6) |
    > 4 | download.opensuse.org-games | openSUSE BuildService - Games
    > | No | No | 99 | rpm-md | 'Index of
    > /repositories/games/openSUSE_11.4'
    > (http://download.opensuse.org/reposit...openSUSE_11.4/)
    > |
    > 5 | openSUSE-11.4-11.4-0 | openSUSE-11.4-11.4-0
    > | No | No | 99 | yast2 |
    > cd:///?devices=/dev/disk/by-id/ata-HL-DT-ST_DVD-RAM_GSA-H60L_K1H77GG1154,/dev/sr0
    > |
    > 6 | packman.inode.at-suse | Packman Repository
    > | No | No | 99 | rpm-md | 'Index of
    > /suse/openSUSE_11.4/' (http://packman.inode.at/suse/openSUSE_11.4/)
    > |
    > 7 | repo-debug | openSUSE-11.4-Debug
    > | No | No | 99 | yast2 | 'Index of
    > /debug/distribution/11.4/repo/oss'
    > (http://download.opensuse.org/debug/d...11.4/repo/oss/)
    > |
    > 8 | repo-debug-update | openSUSE-11.4-Update-Debug
    > | No | No | 99 | rpm-md | 'Index of /debug/update/11.4'
    > (http://download.opensuse.org/debug/update/11.4/)
    > |
    > 9 | repo-non-oss | openSUSE-11.4-Non-Oss
    > | Yes | No | 99 | yast2 | 'Index of
    > /distribution/11.4/repo/non-oss'
    > (http://download.opensuse.org/distrib.../repo/non-oss/)
    > |
    > 10 | repo-oss | openSUSE-11.4-Oss
    > | Yes | No | 99 | yast2 | 'Index of
    > /distribution/11.4/repo/oss'
    > (http://download.opensuse.org/distrib...11.4/repo/oss/)
    > |
    > 11 | repo-source | openSUSE-11.4-Source
    > | Yes | No | 99 | yast2 | 'Index of
    > /source/distribution/11.4/repo/oss'
    > (http://download.opensuse.org/source/...11.4/repo/oss/)
    > |
    >
    >


    though Tony got you going i want to recommend you make some changes to
    your repos..

    -first and most important you should mark your update repo (#2 on your
    list above) to automatically refresh...that way security updates will
    easily flow to your machine..

    -also mark packman (#6) as enabled and refreshing

    and following the instruction in the paragraph beginning with
    "IMPORTANT!" in this post http://tinyurl.com/33qc9vu i'd suggest you
    mark all of these both disabled and not refreshing: 1, 3, 4, and 11.

    --
    DD
    Caveat-Hardware-Software-
    openSUSE®, the "German Automobiles" of operating systems

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •