Results 1 to 7 of 7

Thread: Applications are not opening.

  1. #1
    Join Date
    Oct 2010
    Location
    Lancaster, Lancashire
    Posts
    161

    Default Applications are not opening.

    There have been few instances of this. Some applications simply won't start. I click on them, and then nothing. The main culprits at the moment are Tux Guitar and Tux Word Smith. Any ideas?

  2. #2
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: Applications are not opening.

    On 10/12/2011 02:36 PM, JudasDisciple wrote:
    > Any ideas?


    i have no idea what operating system you have there...or what
    version....or what desktop environment....or it is updated..

    or, if these stopped working right after you installed something, or
    deleted something, or changed kernels, or added tumbleweed, or switched
    to 12.1 beta or edited some configuration files or changed from SUN java
    to ice tea or 'upgraded' your KDE or moved to gnome3 or or or or or or
    or or or or or

    so, it is little difficult to offer any help.

    open a terminal, type in the executable (i don't what it is, maybe
    tuxguitar and tuxwordsmith) and see what errors come...then report back
    to here along with enough info to try to help you..

    --
    DD
    openSUSE®, the "German Automobiles" of operating systems

  3. #3
    Join Date
    Oct 2010
    Location
    Lancaster, Lancashire
    Posts
    161

    Default Re: Applications are not opening.

    Sorry. But since this is the OpenSUSE forum I would have thought that in itself was pretty obvious. But for more details. It's version 11.4, Gnome 2 and it's a Dell Latitude d600 with 1 gb Ram and 1.8Ghz Intel Celeron Nope haven't done any off those except re-install 11.4 couple of times(Relic from my Win using past) and done all the updates since. But no tumbleweed, or 12.1 or anything like that.

    This is what I got from Tuxguitar:
    no swt-gtk-3730 in java.library.path
    no swt-gtk in java.library.path
    Can't load library: /home/ingvar/.swt/lib/linux/x86/libswt-gtk-3730.so
    Can't load library: /home/ingvar/.swt/lib/linux/x86/libswt-gtk.so

    at org.eclipse.swt.internal.Library.loadLibrary(Library.java:284)
    at org.eclipse.swt.internal.Library.loadLibrary(Library.java:193)
    at org.eclipse.swt.internal.C.<clinit>(C.java:21)
    at org.eclipse.swt.internal.Converter.wcsToMbcs(Converter.java:63)
    at org.eclipse.swt.internal.Converter.wcsToMbcs(Converter.java:54)
    at org.eclipse.swt.widgets.Display.<clinit>(Display.java:132)
    at org.herac.tuxguitar.gui.TuxGuitar.displayGUI(Unknown Source)
    at org.herac.tuxguitar.gui.TGMain.main(Unknown Source)
    But with Tux Word Smith it found nothing.

  4. #4
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: Applications are not opening.

    On 10/12/2011 04:26 PM, JudasDisciple wrote:
    >
    > Sorry. But since this is the OpenSUSE forum I would have thought that in
    > itself was pretty obvious.


    may be obvious to you, but not to anyone trying to help you...we get
    folks posting here with various versions of openSUSE or often with SUSE
    Linux Enterprise, sometimes even with Ubuntu..

    > This is what I got from Tuxguitar:
    > no swt-gtk-3730 in java.library.path
    > no swt-gtk in java.library.path
    > Can't load library:
    > /home/ingvar/.swt/lib/linux/x86/libswt-gtk-3730.so
    > Can't load library: /home/ingvar/.swt/lib/linux/x86/libswt-gtk.so
    >
    > at org.eclipse.swt.internal.Library.loadLibrary(Library.java:284)
    > at org.eclipse.swt.internal.Library.loadLibrary(Library.java:193)
    > at org.eclipse.swt.internal.C.<clinit>(C.java:21)
    > at org.eclipse.swt.internal.Converter.wcsToMbcs(Converter.java:63)
    > at org.eclipse.swt.internal.Converter.wcsToMbcs(Converter.java:54)
    > at org.eclipse.swt.widgets.Display.<clinit>(Display.java:132)
    > at org.herac.tuxguitar.gui.TuxGuitar.displayGUI(Unknown Source)
    > at org.herac.tuxguitar.gui.TGMain.main(Unknown Source)


    well, i doubt if i can help because i do not understand why you don't
    have a swt-gtk-3730 in you java.library.path

    so what version of TuxGuitar do you have installed?
    and how did you instal it?

    and should i assume it to work after your last reinstall of openSUSE
    11.4 for a while and then suddenly stopped working (with you having done
    nothing)?

    or has it never worked after your last reinstall?

    which java are you running--SUN or openjdk? if the latter you might want
    to try uninstalling that and install the SUN version instead

    and did the install instructions for tuxguitar tell you to also install
    eclipse? or where/how to get swt-gtk-3730 from and how to place it where?


    > But with Tux Word Smith it found nothing.


    i doubt the executable is "Tux Word Smith"

    maybe one of these will find it:
    Code:
    which tuxwordsmith
    which TuxWordSmith
    which TuxWordmith
    --
    DD
    Caveat
    openSUSE®, the "German Automobiles" of operating systems

  5. #5
    Join Date
    Oct 2010
    Location
    Lancaster, Lancashire
    Posts
    161

    Default Re: Applications are not opening.

    Quote Originally Posted by DenverD View Post
    On 10/12/2011 04:26 PM, JudasDisciple wrote:
    >
    > Sorry. But since this is the OpenSUSE forum I would have thought that in
    > itself was pretty obvious.


    may be obvious to you, but not to anyone trying to help you...we get
    folks posting here with various versions of openSUSE or often with SUSE
    Linux Enterprise, sometimes even with Ubuntu..
    Fair enough
    Quote Originally Posted by DenverD View Post
    On 10/12/2011 04:26 PM, JudasDisciple wrote:[color=blue]

    well, i doubt if i can help because i do not understand why you don't
    have a swt-gtk-3730 in you java.library.path

    so what version of TuxGuitar do you have installed?
    and how did you instal it?
    It's 1.2 and I used the Software manager using the Education Repo from Opensuse.org

    Quote Originally Posted by DenverD View Post
    On 10/12/2011 04:26 PM, JudasDisciple wrote:[color=blue]
    and should i assume it to work after your last reinstall of openSUSE
    11.4 for a while and then suddenly stopped working (with you having done
    nothing)?

    or has it never worked after your last reinstall?
    Something worked better since, others like Tuxracer(Is it all maybe to do with Tux? Arrrgh), hasn't. First time I tried Tuxguitar
    Quote Originally Posted by DenverD View Post
    On 10/12/2011 04:26 PM, JudasDisciple wrote:[color=blue]
    which java are you running--SUN or openjdk? if the latter you might want
    to try uninstalling that and install the SUN version instead
    Looks like Java 1.6 and OpenJDK 6.
    Quote Originally Posted by DenverD View Post
    On 10/12/2011 04:26 PM, JudasDisciple wrote:[color=blue]
    and did the install instructions for tuxguitar tell you to also install
    eclipse? or where/how to get swt-gtk-3730 from and how to place it where?
    Nope
    [
    Quote Originally Posted by DenverD View Post
    On 10/12/2011 04:26 PM, JudasDisciple wrote:[color=blue]

    > But with Tux Word Smith it found nothing.


    i doubt the executable is "Tux Word Smith"

    maybe one of these will find it:
    Code:
    which tuxwordsmith
    which TuxWordSmith
    which TuxWordmith
    Now found that Tux Word Smith works when started through the Terminal.

    I do apologize, even after using OpenSuse for nearly a year I still don't seemed to be able to get proper grips with it. But really want to.

  6. #6
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: Applications are not opening.

    On 10/12/2011 08:26 PM, JudasDisciple wrote:
    >
    > It's 1.2 and I used the Software manager using the Education Repo from
    > Opensuse.org


    there is, i think, an education forum....perhaps there is a helper there
    with more experience with all of these "Tux" offerings...i did watch the
    Tux slide a few times...but, that was years ago..

    >> or has it never worked after your last reinstall?
    >>

    > Something worked better since, others like Tuxracer(Is it all maybe to
    > do with Tux? Arrrgh), hasn't.


    ok, that points to either incorrect or incomplete install and/or setup..

    suggest you use YaST Software Management, search for (for example)
    tuxguitar and then right click on the box next to the program and select
    update (BUT read below first)



    First time I tried Tuxguitar[color=blue]
    > DenverD;2393080 Wrote:
    >> On 10/12/2011 04:26 PM, JudasDisciple wrote:
    >> which java are you running--SUN or openjdk? if the latter you might
    >> want
    >> to try uninstalling that and install the SUN version instead
    >>

    > Looks like Java 1.6 and OpenJDK 6.


    suggest you use YaST Software Management and uninstall OpenJDK, leaving
    only SUN Java....THEN, do the update on tuxguitar [rational: something
    about your java *or* tux is messed up, perhaps removing the least good
    java and then updating might be magic.]


    > Now found that Tux Word Smith works when started through the Terminal.


    yipee! good for you!!


    > I do apologize, even after using OpenSuse for nearly a year I still
    > don't seemed to be able to get proper grips with it. But really want to.


    i've been using linux since about '98, and linux _only_ since about '02
    and SUSE/openSUSE exclusively since SUSE 9.2 *AND* i learn something
    every day! i hope in the next several years to get to the place i can
    say "i now seem to be able to get proper grips with it"..

    keep at it, keep reading the docs, asking questions, turning every
    mistake into a learning experience, etc etc etc..

    the more you know the more free you are....and, the more fun you will
    have!!!

    --
    DD
    openSUSE®, the "German Automobiles" of operating systems

  7. #7

    Default Re: Applications are not opening.

    Same problem with tuxguitar on openSUSE 11.4 here: it doesn't start with the following exception: ~> tuxguitar Exception in thread "main" java.lang.UnsatisfiedLinkError: Could - Pastebin.com. I have tuxguitar 1.2-14.1 and eclipse-swt 3.375-8.1 installed, both from the OBS Education repo. Folder ~/.swt/lib/linux/x86/ is present, but it's empty. Also, there is files libswt-gtk-3735.so and libswt-gtk.so in the /usr/lib/eclipse, provided by eclipse-swt package.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •