Results 1 to 8 of 8

Thread: Problem installing Aterm

  1. #1
    Join Date
    Feb 2011
    Location
    127.0.0.1
    Posts
    472

    Default Problem installing Aterm

    I went here: aterm-1.0.1-1.2.x86_64.rpm openSUSE 11.4 Download Mirrors and downloaded Aterm. When trying to install, I got the following annoying message:
    A problem that we were not expecting has occurred.
    Please report this bug with the error description. Details: [PK_TMP_DIR|dir:///var/tmp/TmpDir.BkTOin] Repository already exists.
    Why is that?
    Reliable + rider = RiDeR PlUs
    ...if you find this helpful, click on the star below...
    +-+ +-+
    |r| |+|
    +-+ +-+

  2. #2

    Default Re: Problem installing Aterm

    You don't have to download the package. You should install the Contrib repo, then aterm:

    Code:
    $ su -l
    # zypper ar http://download.opensuse.org/repositories/openSUSE:/11.4:/Contrib/standard/   openSUSE:Contrib
    # zypper refresh
    # zypper in aterm
    Code:
    $ zypper info aterm
    
    Loading repository data...
    Reading installed packages...
    
    Information for package aterm:
    
    Repository: @System
    Name: aterm
    Version: 1.0.1-1.2
    Arch: x86_64
    Vendor: obs://build.opensuse.org/openSUSE:11.4:Contrib
    Installed: Yes
    Status: up-to-date
    Installed Size: 256.0 KiB
    Summary: A terminal emulator with transparency support
    Description: 
    aterm is the X Terminal Emulator. Originated from rxvt 2.4.8 it
    strives to provide user with complete control over its look. Features
    include fast transparency with shading and tinting, NeXTish scrollbar,
    fading when unfocused and more.

    I use aterm a lot. Unfortunately it doesn't work with ncurses applications (such as yast in console mode, alsamixer, updategrub, etc).

  3. #3
    Join Date
    Feb 2011
    Location
    127.0.0.1
    Posts
    472

    Default Re: Problem installing Aterm

    Thanks!
    No, it doesn't
    Reliable + rider = RiDeR PlUs
    ...if you find this helpful, click on the star below...
    +-+ +-+
    |r| |+|
    +-+ +-+

  4. #4

    Default Re: Problem installing Aterm

    Quote Originally Posted by riderplus View Post
    No, it doesn't
    May I suggest rxvt-unicode? It supports UTF8, transparency and works with ncurses. It is in the standard repo, so you would just have to type:

    Code:
    sudo zypper in rxvt-unicode
    This is probably a better choice of terminal nowadays, although I'm still using aterm too (mostly for historical reasons).

  5. #5
    Join Date
    Feb 2011
    Location
    127.0.0.1
    Posts
    472

    Default Re: Problem installing Aterm

    I see this one works smoothly with ncurses.

    Do I have to keep desktop effects enabled for the rxvt transparency to work? 'Cause I've set transparency for rxvt in .Xdefaults, but it doesn't seem to work...I guess I'll have to enable the desktop effects, it seems logical.
    Reliable + rider = RiDeR PlUs
    ...if you find this helpful, click on the star below...
    +-+ +-+
    |r| |+|
    +-+ +-+

  6. #6

    Default Re: Problem installing Aterm

    Quote Originally Posted by riderplus View Post
    Do I have to keep desktop effects enabled for the rxvt transparency to work? Cause I've set transparency for rxvt in .Xdefaults, but it doesn't seem to work...
    I use this:
    Code:
    URxvt*transparent:true
    Quote Originally Posted by riderplus View Post
    I guess I'll have to enable the desktop effects, it seems logical.
    Not necessary desktop effetcts but compositing (with comes to the same under KDE but not under Gnome). I have a script to enable/disable compositing in any situation and under each environment. It's posted here: compositor: quickly sets/unsets compositing (helps with fullscreen Flash on ATI). Whether compositing is needed or not for terminal transparency depends on the DE. Kde sucks because it doesn't use a true background. Let me check! ...

  7. #7

    Default Re: Problem installing Aterm

    That's what I suspected: transparency doesn't work in KDE. It works otherwise (sometimes with or without compositing), even under twm!
    I use a transparent borderless terminal in the background of all wms, except KDE, because it doesn't work. You need something like semi-transparency. I had a similar problem with conky - finally got it fixed, but it wasn't fun.

    Notice that parsing X resources in KDE is not obvious. I would double check whit xrdb -merge. I don't know about user resources, but for the system-wide, I have to use a script in ~/.kde4/Autostart and I never got it to work for applications which are restarted by the session manager.

    Xfce terminal works with transparency when compositing is enable under KDE. I believe Gnome Terminal and konsole would work too, but I haven't tried.

  8. #8
    Join Date
    Feb 2011
    Location
    127.0.0.1
    Posts
    472

    Default Re: Problem installing Aterm

    Then I'll switch to Gnome
    Reliable + rider = RiDeR PlUs
    ...if you find this helpful, click on the star below...
    +-+ +-+
    |r| |+|
    +-+ +-+

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •