Results 1 to 6 of 6

Thread: openSUSE 11.4 KDE_64 kernel 3.1: cannot install proprietary NVIDIA driver

  1. #1

    Default openSUSE 11.4 KDE_64 kernel 3.1: cannot install proprietary NVIDIA driver

    Hi,

    (Moderator: Pls. place my thread in appropriate sub-forum if possible, thanks!)

    I am running openSUSE 11.4 KDE 64 bit, kernel 3.1.rc7-5.3-desktop. Upgraded to this latest kernel in order for wireless to work, because RT2860 was phased out and RT2800PCI phased in for my Trendnet TEW643PI wireless n card.

    In the process of upgrading to a new kernel, graphic driver was automatically switched from Nvidia to nv and screen resolution reverted from 1280x760 to 800x600. I then installed nouveau but screen resolution remains at 800x600. Tried installing Nvidia driver "The Hard Way" but I got the following error message:

    Cc version check failed: The compiler used to compile the kernel (gcc4.6) does not exactly match the current compiler (gcc4.5)
    Other than the above, my system has all the prerequite packages such as make, kernel-source, kernel-devel, etc. for installing proprietary Nvidia from source, i.e. The Hard Way.

    Any suggestions? Thanks in advance for your help.


  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,734
    Blog Entries
    20

    Default Re: openSUSE 11.4 KDE_64 kernel 3.1: cannot install proprietary NVIDIA driver

    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,574
    Blog Entries
    38

    Default Re: openSUSE 11.4 KDE_64 kernel 3.1: cannot install proprietary NVIDIA driver

    Quote Originally Posted by taytong888 View Post
    I am running openSUSE 11.4 KDE 64 bit, kernel 3.1.rc7-5.3-desktop. Upgraded to this latest kernel in order for wireless to work, because RT2860 was phased out and RT2800PCI phased in for my Trendnet TEW643PI wireless n card.

    In the process of upgrading to a new kernel, graphic driver was automatically switched from Nvidia to nv and screen resolution reverted from 1280x760 to 800x600. I then installed nouveau but screen resolution remains at 800x600. Tried installing Nvidia driver "The Hard Way" but I got the following error message:



    Other than the above, my system has all the prerequite packages such as make, kernel-source, kernel-devel, etc. for installing proprietary Nvidia from source, i.e. The Hard Way.

    Any suggestions? Thanks in advance for your help.

    You need to use the BETA version of the proprietary nvidia driver. NOT the nominal version.

  4. #4

    Default Re: openSUSE 11.4 KDE_64 kernel 3.1: cannot install proprietary NVIDIA driver

    Hello oldcpu,

    Previously I tried Nvidia (Beta?) version 280.13. Then when I tried version 285.03 I got the same error message. This time instead of aborting I selected "NO" to continue on and followed onscreen prompts to successfully install the proprietary driver. I got 1024x768 resolution back, after blacklisting nouveau and rebooting. The strange thing is that a search for "nvidia" in YAST still shows older versions of nvidia.

    Thanks a lot for your helpful suggestion/hint.

  5. #5
    Join Date
    Jun 2008
    Location
    Stoney Stanton - England
    Posts
    1,108

    Default Re: openSUSE 11.4 KDE_64 kernel 3.1: cannot install proprietary NVIDIA driver

    What the error message is saying is that the kernel version expects gcc version 4.6 when the version on your system is gcc 4.5. But as you have found out the nvidia driver installs fine if you ignore the error message and proceed.

    If you wanted to update to gcc 4.6 you could add:-

    Index of /repositories/Base:/build/standard

    to your repo list. Then update gcc using yast to version 4.6

  6. #6
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,574
    Blog Entries
    38

    Default Re: openSUSE 11.4 KDE_64 kernel 3.1: cannot install proprietary NVIDIA driver

    Quote Originally Posted by taytong888 View Post
    The strange thing is that a search for "nvidia" in YAST still shows older versions of nvidia.
    Likely YaST software management has a record of the last rpm version you installed. YaST will have no record of any manual .run method install.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •