Results 1 to 3 of 3

Thread: YaST Remote Administration module causing system freeze

  1. #1
    Join Date
    Jan 2010
    Location
    Missoula, Montana, USA
    Posts
    6

    Default YaST Remote Administration module causing system freeze

    Hello all, I've got a problem here and I'm wondering if anyone else has had a similar experience. I'm trying to enable VNC using the YaST Remote Administration module. I enable remote access (the machine in question is on a LAN behind a firewall/router so there is no enabled local firewall), and when I click on finish, YaST begins making the requested changes but then totally freezes (not just yast, but the entire system) when it gets to the service activation phase. I have no choice at this point but to reboot. I've not been able to recover any crashdumps, so I'm kind of in the dark here. My system is running Leap 42.1, Plasma5/KDE and has 8GB of RAM, onboard AMD Radeon 7000 series graphics and I am using the Catylist dirvers and software found in the AMD/ATI Graphics drivers repo (http://geeko.ioda.net/mirror/amd-fgl...USE_Leap_42.1/). The only kind of unusual thing about my system is that my wireless adapter wasn't supported out of the box (Linksys WUSB6300) so I had to compile and install a realtec driver I found on github and install it with dkms. I don't think that has any bearing on my problem, but there it is in case anyone knows something there that I don't. I've not noticed any other unusual crashes, errors, behavior, etc... Anyone have any thoughts on this?

  2. #2
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,133
    Blog Entries
    2

    Default Re: YaST Remote Administration module causing system freeze

    You can try looking at the last 100 or so lines of your system log from the previous boot with something like this(untested but should work). The following returns log entries from the previous boot. If you have rebooted more than once since your system freeze, you can increment the boot log number (eg -2)
    Code:
     journalctl --boot=-1 | tail -n 100
    I doubt your driver is relevant although nowadays I'd possibly re-evaluate whether a working driver should already exist in your current kernel (that should be addressed in a different Forum post).

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  3. #3
    Join Date
    Jan 2010
    Location
    Missoula, Montana, USA
    Posts
    6

    Default Re: YaST Remote Administration module causing system freeze

    Thank you tsu2 for your suggestion. I reviewed the systemd journal as you suggested, unfortunately there were no entries in the logs suggesting any kind of failure, warning, error or crash. I suspect that since the system froze instead of crashing, the system never had a chance to log the cause of the problem before everything ground to a halt. I have another system running Leap 42.1 and YaST has no problem configuring VNC on that system. The two systems are not identical however, the first system on which YaST freezes has ATI graphics, The other system has Intel graphics. I'm beginning to wonder if this may have something to do with driver incompatibility. It's a shot in the dark, but right now it's about the only thing I can come up with. I'm going to try the open source ATI drivers and see what happens.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •