Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: NTFS permissions

  1. #1
    Join Date
    Jun 2010
    Location
    Croatia
    Posts
    80

    Angry NTFS permissions

    Not sure where to post this, but since it affects applications not being able to write to NTFS partition such as Ktorrent and any for that matter, i'll post here...

    I can't seem to get NTFS write permissions to work. I can read fine off it, but i can't write to it.

    I followed guides what to install and how to configure but nothing works...

    I get this when i run sudo ntfs-config:


    Code:
    /usr/lib64/python2.7/site-packages/gtk-2.0/gtk/__init__.py:57: GtkWarning: could not open display
      warnings.warn(str(e), _gtk.Warning)
    /usr/lib64/python2.7/site-packages/NtfsConfig/Fstab/SimpleGladeApp.py:335: Warning: invalid (NULL) pointer instance
      return gtk.glade.XML(self.glade_path, root, domain)
    /usr/lib64/python2.7/site-packages/NtfsConfig/Fstab/SimpleGladeApp.py:335: Warning: g_signal_connect_data: assertion `G_TYPE_CHECK_INSTANCE (instance)' failed
      return gtk.glade.XML(self.glade_path, root, domain)
    /usr/lib64/python2.7/site-packages/NtfsConfig/Fstab/SimpleGladeApp.py:335: GtkWarning: IA__gtk_settings_get_for_screen: assertion `GDK_IS_SCREEN (screen)' failed
      return gtk.glade.XML(self.glade_path, root, domain)
    /usr/lib64/python2.7/site-packages/NtfsConfig/Fstab/SimpleGladeApp.py:335: Warning: g_object_get: assertion `G_IS_OBJECT (object)' failed
      return gtk.glade.XML(self.glade_path, root, domain)
    /usr/lib64/python2.7/site-packages/NtfsConfig/Fstab/SimpleGladeApp.py:335: Warning: value "TRUE" of type `gboolean' is invalid or out of range for property `visible' of type `gboolean'
      return gtk.glade.XML(self.glade_path, root, domain)
    Traceback (most recent call last):
      File "/usr/bin/ntfs-config", line 102, in <module>
        main(args, opts)
      File "/usr/bin/ntfs-config", line 75, in main
        app = NtfsConfig()
      File "/usr/lib64/python2.7/site-packages/NtfsConfig/NtfsConfig.py", line 56, in __init__
        os.mkdir(HAL_CONFIG_DIR)
    OSError: [Errno 2] No such file or directory: '/etc/hal/fdi/policy'
    and right click on drive properties, and setting permissions from there doesn't do anything either, it just resets itself to default after i close properties then nothing happens, still can't write. I dual boot Windows7 so i need those NTFS partitions since they're the storage for both Win7 and SUSE...

    uname -a
    Code:
    Linux linux-u8ku 2.6.37.6-0.7-desktop #1 SMP PREEMPT 2011-07-21 02:17:24 +0200 x86_64 x86_64 x86_64 GNU/Linux
    Using openSUSE 11.4 x64 (also, what terminal command to list that? i only remember uname -a, but less important i can google it)

    I don't know what info you may need, so please, if you need anything more, just write what i need to do.

    In YaST2 i have ntfs3g, ntfs-config and ntfsprogs installed, as guides said i should...
    Doesn't work though...

    What am i missing? Why can't i write to NTFS? Please, any help would be appretiated.

  2. #2
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: NTFS permissions

    It is my suggestion and recommendation that NTFS drives are setup as follows in your fstab file using only the defaults setting:

    Code:
    /dev/disk/by-id/ata-WDC_WD3000GLFS-01F8U0_WD-WXL408720641-part2        /Windows    ntfs-3g    defaults            0    0
    Further, I use NTFS partitions as a partition that is used by both Windows & Linux. Often multimedia and document files are to be shared. Linux user files should normally remain in EXT4 partitions with the normal Linux permission setup. But if a file or type of file must be useable by both Linux and Windows users, then consider the setup I use above. I have no write problems what so ever for ANY Linux user writing to an NTFS partition. If this is not your intent for Linux users, then don't use NTFS would be my suggestion. You must have root permissions to modify the /etc/fstab file and should restart your PC after making such a change to go into effect.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  3. #3
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: NTFS permissions

    On 2011-09-30 00:46, Vepar wrote:

    > I get this when i run sudo ntfs-config:


    You get most of those errors because you are using sudo. Use "su -" instead.

    > Using openSUSE 11.4 x64 (also, what terminal command to list that?


    cat /etc/SuSE-release

    > I don't know what info you may need, so please, if you need anything
    > more, just write what i need to do.


    The content of fstab, the lines referring to the Windows drives. And the
    output of the "mount" command re the same.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

  4. #4
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: NTFS permissions

    On 2011-09-30 01:56, jdmcdaniel3 wrote:
    > and should restart your PC after making
    > such a change to go into effect


    Umounting and mounting again is enough.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

  5. #5

    Default Re: NTFS permissions

    it is also very unadvisable to let a torrent save to a ntfs partition
    there are WAY to many ms windows viruses out there that once a torrent is clicked on or ran or on some a "mouse over " is all that is required to install the virus
    if you MUST then have ktorrent save to a ext4 partition temp folder
    run clamAV on it
    if clean then copy it to the ntfs folder .

    normally you will want users to have READ ONLY access to ntfs partitions and only allow root to write to it

    ntfs-3g defaults 0 0
    is a good choice
    a better is
    Code:
    /dev/sda1       /mymnt/win   ntfs-3g  ro,umask=0222,defaults 0 0
    but if you want to take ALL of the security out of it and have a "free for all"
    use
    ---- ntfs-3g rw,umask=0000,defaults 0 0 ----
    but i would not .



  6. #6
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: NTFS permissions

    On 2011-09-30 03:36, JohnVV wrote:
    > a better is
    >
    > Code:
    > --------------------
    >
    > /dev/sda1 /mymnt/win ntfs-3g ro,umask=0222,defaults 0 0
    > --------------------


    Thats RO, and he wants to write.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

  7. #7
    Join Date
    Jun 2010
    Location
    Croatia
    Posts
    80

    Default Re: NTFS permissions

    Thanks everyone for replies!

    Ok...

    Quote Originally Posted by jdmcdaniel3
    Further, I use NTFS partitions as a partition that is used by both Windows & Linux. Often multimedia and document files are to be shared.
    Yes, that's kinda what i'm trying to do. I have one large partition with all kinds of stuff and i want to be able to use it with both Linux and Windows. I need windows for some programs so i can't just discard it completely.

    Quote Originally Posted by robin_listas
    You get most of those errors because you are using sudo. Use "su -" instead.
    This is what i get when i use "su", then ntfs-config...


    Code:
    Traceback (most recent call last):
      File "/usr/bin/ntfs-config", line 102, in <module>
        main(args, opts)
      File "/usr/bin/ntfs-config", line 75, in main
        app = NtfsConfig()
      File "/usr/lib64/python2.7/site-packages/NtfsConfig/NtfsConfig.py", line 56, in __init__
        os.mkdir(HAL_CONFIG_DIR)
    OSError: [Errno 2] No such file or directory: '/etc/hal/fdi/policy'
    Still won't let me do anything.

    This is my fstab:

    Code:
    /dev/disk/by-id/ata-WDC_WD1002FAEX-00Z3A0_WD-WCATR5835895-part7 swap                 swap       defaults              0 0
    /dev/disk/by-id/ata-WDC_WD1002FAEX-00Z3A0_WD-WCATR5835895-part3 /                    ext4       acl,user_xattr        1 1
    /dev/disk/by-id/ata-WDC_WD1002FAEX-00Z3A0_WD-WCATR5835895-part8 /home                ext4       acl,user_xattr        1 2
    /dev/disk/by-id/ata-WDC_WD1002FAEX-00Z3A0_WD-WCATR5835895-part1 /windows/Boot        ntfs-3g    users,gid=users,fmask=133,dmask=022,locale=en_US.UTF-8 0 0
    /dev/disk/by-id/ata-WDC_WD1002FAEX-00Z3A0_WD-WCATR5835895-part2 /windows/C           ntfs-3g    users,gid=users,fmask=133,dmask=022,locale=en_US.UTF-8 0 0
    /dev/disk/by-id/ata-WDC_WD1002FAEX-00Z3A0_WD-WCATR5835895-part5 /windows/D           ntfs-3g    users,gid=users,fmask=133,dmask=022,locale=en_US.UTF-8 0 0
    /dev/disk/by-id/ata-WDC_WD1002FAEX-00Z3A0_WD-WCATR5835895-part6 /windows/E           ntfs-3g    users,gid=users,fmask=133,dmask=022,locale=en_US.UTF-8 0 0
    proc                 /proc                proc       defaults              0 0
    sysfs                /sys                 sysfs      noauto                0 0
    debugfs              /sys/kernel/debug    debugfs    noauto                0 0
    usbfs                /proc/bus/usb        usbfs      noauto                0 0
    devpts               /dev/pts             devpts     mode=0620,gid=5       0 0
    Windows/C is my windows partition, this doesn't need to be writeable. Even better if it's read only actually.
    Windows/D partition is for games and game related storage.
    Windows/E partition is where i keep all my documents, my work and other, so i need this to be writeable.

    So basically i can make windows/E writable by editing it in fstab?
    I don't need ntfs-config?
    So what values do i need to change in this entry then?
    Code:
    /dev/disk/by-id/ata-WDC_WD1002FAEX-00Z3A0_WD-WCATR5835895-part6 /windows/E           ntfs-3g    users,gid=users,fmask=133,dmask=022,locale=en_US.UTF-8 0 0
    Quote Originally Posted by JohnVV
    if you MUST then have ktorrent save to a ext4 partition temp folder
    run clamAV on it
    if clean then copy it to the ntfs folder .
    Thank you! This is good advice. I was trying to accomplish among other stuff, that i can have the same torrent loaded in both Windows and Linux, so whatever system i use the torrent continues to download. And i'm not that worried about viruses, i have 3 months left of Norton Internet Security 2011 installed on Windows so most eventual threats go away quickly.

  8. #8
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    10,942
    Blog Entries
    2

    Default Re: NTFS permissions

    You'll find in some other threads what I've personally observed...

    I've only been able to write to an NTFS partition as root, and this is even if after I open up NTFS permissions to "Everyone - Write"
    Also, in my experimentation it looks like it has to be CLI root, not logged into a Desktop as root which suggests to me that KDE applies a security layer on top of system file security, sometimes it makes a difference and others not.

    Bottom line is that after you've saved anything to your native Linux partitions, you can use CLI root to copy or move to an NTFS partition.

    HTH,
    Tony

  9. #9
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: NTFS permissions

    On 2011-09-30 14:46, Vepar wrote:

    > robin_listas Wrote:
    >> You get most of those errors because you are using sudo. Use "su -"
    >> instead.

    >
    > This is what i get when i use "su", then ntfs-config...


    Not "su", but "su -". Anyway, that program appears to have errors.


    > This is my fstab:

    ....
    > Windows/E partition is where i keep all my documents, my work and
    > other, so i need this to be writeable.


    Change fmask=0117,dmask=0007


    > So basically i can make windows/E writable by editing it in fstab?


    Yes

    > I don't need ntfs-config?


    I've never used it.


    > JohnVV Wrote:
    >> if you MUST then have ktorrent save to a ext4 partition temp folder
    >> run clamAV on it if clean then copy it to the ntfs folder .

    >
    > Thank you! This is good advice. I was trying to accomplish among other


    It is typical for this kind of Linux apps to use a feature called "sparse
    files". It means that the space in disk is only reserved for the chunks
    that have been already downloaded, and the "holes" do not exist in the
    disk, they do not use space. An NTFS partition doesn't allow this, AFAIK,
    the files have to be created entirely at the initial moment.

    > stuff, that i can have the same torrent loaded in both Windows and
    > Linux, so whatever system i use the torrent continues to download.


    That's an interesting point.

    > And
    > i'm not that worried about viruses, i have 3 months left of Norton
    > Internet Security 2011 installed on Windows so most eventual threats go
    > away quickly.


    Only those that are already known to the antivirus, not new ones if you are
    amongst the first people to see them. I get stuff in my mail that I know is
    bad but neither clamav nor antivir detect it.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

  10. #10
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: NTFS permissions

    I would make the modifications as shown below. Matching spacing is unimportant. Only the change to using the option defaults, as suggested in my first message matters.

    Code:
    /dev/disk/by-id/ata-WDC_WD1002FAEX-00Z3A0_WD-WCATR5835895-part7 swap                 swap       defaults              0 0
    /dev/disk/by-id/ata-WDC_WD1002FAEX-00Z3A0_WD-WCATR5835895-part3 /                    ext4       acl,user_xattr        1 1
    /dev/disk/by-id/ata-WDC_WD1002FAEX-00Z3A0_WD-WCATR5835895-part8 /home                ext4       acl,user_xattr        1 2
    /dev/disk/by-id/ata-WDC_WD1002FAEX-00Z3A0_WD-WCATR5835895-part1 /windows/Boot        ntfs-3g    defaults              0 0
    /dev/disk/by-id/ata-WDC_WD1002FAEX-00Z3A0_WD-WCATR5835895-part2 /windows/C           ntfs-3g    defaults              0 0
    /dev/disk/by-id/ata-WDC_WD1002FAEX-00Z3A0_WD-WCATR5835895-part5 /windows/D           ntfs-3g    defaults              0 0
    /dev/disk/by-id/ata-WDC_WD1002FAEX-00Z3A0_WD-WCATR5835895-part6 /windows/E           ntfs-3g    defaults              0 0
    proc                 /proc                proc       defaults              0 0
    sysfs                /sys                 sysfs      noauto                0 0
    debugfs              /sys/kernel/debug    debugfs    noauto                0 0
    usbfs                /proc/bus/usb        usbfs      noauto                0 0
    devpts               /dev/pts             devpts     mode=0620,gid=5       0 0
    Make the suggested changes and reboot. I actually use NTFS partitions on MY PC and so using the defaults option works like a champ.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •