Results 1 to 3 of 3

Thread: heartbeat package on openSUSE 11.4

  1. #1

    Default heartbeat package on openSUSE 11.4

    I've been trying to get heartbeat to work properly (for redundancy purposes) on openSUSE 11.4 and I'm convinced the latest package is broken. It installs fine but heartbeat requires the scripts installed in /usr/lib/ocf, which are also installed correctly, but do not seem to function correctly.

    I've tested the exact same config on Ubuntu and it works off the bat. The issue is that it cannot seem to find any of the resource scripts (e.g. IPaddr) that it requires, although they are in /usr/lib/ocf/resource.d/heartbeat/. On other installs it puts resource.d into /etc/ha.d/ which usually has the scripts but openSUSE is not doing that.

    If I copy that directory in it just leads to more problems and more complications.

    Has anyone got a successfully running package?

  2. #2
    Join Date
    Mar 2010
    Location
    paris
    Posts
    43

    Default Re: heartbeat package on openSUSE 11.4

    hi

    same pronlem for me whith heartbeat and opensuse 11.4

    it worked fine in 11.3 but after update in 11.4 it can't find Ipaddr script......

    is there a solution ????

    bye
    Je plussoie et je paie ma tournée ! comme on dit chez alionet http://www.alionet.org

  3. #3
    Join Date
    Mar 2010
    Location
    paris
    Posts
    43

    Default Re: heartbeat package on openSUSE 11.4

    ok i find the soluce

    install heartbeat and heartbeat-common in 3.0.4-28.4 from this repos

    Index of /repositories/network:/ha-clustering/openSUSE_11.4

    and it works fine if you use this syntax in haresources

    nod1 192.168.x.x/24/ethx service

    regards
    Je plussoie et je paie ma tournée ! comme on dit chez alionet http://www.alionet.org

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •