Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Kwrite is not starting under KDE 4.7.1

  1. #1
    Join Date
    Aug 2008
    Location
    Pitesti, Arges County, Romania
    Posts
    595

    Default Kwrite is not starting under KDE 4.7.1

    I was away for a few days and i did not noticed the issue until now. I`m using kde 4.7.1 and this morning when starting kwrite i get the following message:
    "A kde text editor component could not be found. Please check you kde installation".
    The weird part is that i have kwrite installed
    creatura@creation:~> whereis kwrite
    kwrite: /usr/bin/kwrite /usr/bin/X11/kwrite

    After this the crash handler from KDE shows and here is the output i get from backtrace:
    PHP Code:
    ApplicationKWrite (kdeinit4), signalSegmentation fault
    [KCrash Handler]
    #6  0x00007fd48ee935e0 in KTextEditor::Editor::setSimpleMode(bool) () from /usr/lib64/libktexteditor.so.4
    #7  0x00007fd48f1039e0 in KWriteApp::KWriteApp(KCmdLineArgs*) () from /usr/lib64/libkdeinit4_kwrite.so
    #8  0x00007fd48f1003c9 in kdemain () from /usr/lib64/libkdeinit4_kwrite.so
    #9  0x0000000000407279 in launch(int, char const*, char const*, char const*, int, char const*, bool, char const*, bool, char const*) ()
    #10 0x0000000000407dfd in handle_launcher_request(int, char const*) ()
    #11 0x000000000040859a in handle_requests(int) ()
    #12 0x00000000004091f0 in main () 
    Try to downgrade to version 4.6.5 still the issue is present. What can i do to solve it ?
    openSUSE Community Member: -> en.opensuse.org/User:Creatura85
    Connect Profile:
    -> connect.opensuse.org/pg/profile/creatura85
    openSUSE Romania Member: -> suseromania.ro

  2. #2
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: Kwrite is not starting under KDE 4.7.1

    On 09/25/2011 10:26 AM, creatura85 wrote:
    >
    > Try to downgrade to version 4.6.5 still the issue is present. What can
    > i do to solve it ?


    though i do not recommend running bleeding edge KDE, i would begin
    trying to fix my kwrite by just using YaST > Software Management to

    -search on kwrite

    -right click on the checked box, and pick "update"

    -click the "Accept" button

    if that does not work then you know why i don't recommend installing
    every new little version that comes out..

    --
    DD
    Caveat-Hardware-Software-
    openSUSE®, the "German Automobiles" of operating systems

  3. #3
    Join Date
    Aug 2008
    Location
    Pitesti, Arges County, Romania
    Posts
    595

    Default Re: Kwrite is not starting under KDE 4.7.1

    Quote Originally Posted by DenverD View Post
    ...
    I did try that too, same result. I don`t think that KDE 4.7.1 from the repo`s are so "bleeding edge" as you call them.
    openSUSE Community Member: -> en.opensuse.org/User:Creatura85
    Connect Profile:
    -> connect.opensuse.org/pg/profile/creatura85
    openSUSE Romania Member: -> suseromania.ro

  4. #4
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: Kwrite is not starting under KDE 4.7.1

    On 09/25/2011 12:36 PM, creatura85 wrote:
    >
    > I did try that too, same result. I don`t think that KDE 4.7.1 from the
    > repo`s are so "bleeding edge" as you call them.


    openSUSE 11.4 shipped with KDE4.6.0 and so far nothing newer has flowed
    out to users through the oss, non-oss or update repos..

    it is those three (all of which have "11.4" in the repo address) which
    is from where software "released" for 11.4 flows..

    imHo, everything else is pre-release, and therefore "bleeding edge" by
    definition..

    --
    DD
    openSUSE®, the "German Automobiles" of operating systems

  5. #5
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,363
    Blog Entries
    3

    Default Re: Kwrite is not starting under KDE 4.7.1

    Quote Originally Posted by DenverD View Post
    imHo, everything else is pre-release, and therefore "bleeding edge" by
    definition..
    Yes, I agree. Personally, I stick to the actual release. I can wait for the next release for a new version. That results in a more stable system.

    However, I do participate in testing. I currently have 12.1 M5 installed on a test system. That's bleeding edge too, but it is only a test install where I expect stuff to break.

    So I booted up 12.1 M5, and checked kwrite. It seems to work just fine. It is KDE 4.7.1. So should be good to go when 12.1 is officially released.

    I'll add that there is other broken stuff in 12.1 M5.
    openSUSE Leap 15.1; KDE Plasma 5;

  6. #6
    Join Date
    Aug 2008
    Location
    Pitesti, Arges County, Romania
    Posts
    595

    Default Re: Kwrite is not starting under KDE 4.7.1

    Well i did take some steps back to kde 4.6.5 and kwrite is working again...
    Maybe you are right nrickert; well no harm done to my OS by using KDE from a non-Tumbleweed repo. I belive i will follow your model nrickert and use vbox for testing new versions of apps. Do you think that 11.2 M5 is a good point to start or should i just wait for the Beta ?
    openSUSE Community Member: -> en.opensuse.org/User:Creatura85
    Connect Profile:
    -> connect.opensuse.org/pg/profile/creatura85
    openSUSE Romania Member: -> suseromania.ro

  7. #7
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: Kwrite is not starting under KDE 4.7.1

    On 09/25/2011 04:26 PM, creatura85 wrote:
    >
    > Well i did take some steps back to kde 4.6.5 and kwrite is working
    > again...


    please log the bug you found: http://tinyurl.com/nzhq7j

    it is, after all, testing software..

    --
    DD
    openSUSE®, the "German Automobiles" of operating systems

  8. #8
    Join Date
    Mar 2009
    Location
    sri mayapur, west bengal, india
    Posts
    958

    Default Re: Kwrite is not starting under KDE 4.7.1

    On Sun, 25 Sep 2011 20:10:45 +0530, DenverD
    <DenverD@no-mx.forums.opensuse.org> wrote:

    > On 09/25/2011 04:26 PM, creatura85 wrote:
    >>
    >> Well i did take some steps back to kde 4.6.5 and kwrite is working
    >> again...

    >
    > please log the bug you found: http://tinyurl.com/nzhq7j
    >
    > it is, after all, testing software..
    >


    i'm not sure it's a bug really. he (OP) is the only one who's encountered
    this behavior, and there's up- and downgrading between repos involved.
    moreover, in one of his latest posts the word "tumbleweed" was mentioned.
    no point filing a bug if if different / incompatible repos are involved.

    --
    phani.

  9. #9
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: Kwrite is not starting under KDE 4.7.1

    On 09/25/2011 05:12 PM, phanisvara das wrote:

    > i'm not sure it's a bug really. he (OP) is the only one who's
    > encountered this behavior, and there's up- and downgrading between repos
    > involved. moreover, in one of his latest posts the word "tumbleweed" was
    > mentioned. no point filing a bug if if different / incompatible repos
    > are involved.


    good point..

    --
    DD
    openSUSE®, the "German Automobiles" of operating systems

  10. #10
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,363
    Blog Entries
    3

    Default Re: Kwrite is not starting under KDE 4.7.1

    Quote Originally Posted by creatura85 View Post
    ... or should i just wait for the Beta ?
    That's something you will have to decide for yourself.

    I'm hoping that the wait won't be too long.
    openSUSE Leap 15.1; KDE Plasma 5;

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •