Page 2 of 2 FirstFirst 12
Results 11 to 13 of 13

Thread: MySQL Community Server 5.1.54 on openSUSE 11.1 (SLES 11 sp1) Error 2003 /var/lib/mysql.sock

  1. #11
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: MySQL Community Server 5.1.54 on openSUSE 11.1 (SLES 11 sp1)Error 2003 /var/lib/mysql.sock

    I hate to give you bad news but you've gone about the wrong way. You should have asked before attempting the upgrade.

    1. You should have made a dump of the database before starting.

    2. openSUSE and SLES are different products. You would get into trouble using packages for another product.

    3. openSUSE 11.1 and 11.4 differ sufficiently that they should be regarded as different products where packages are concerned.

    4. Locations of files have moved in MySQL versions giving you the missing socket problem.

    The safest way to update is to make a dump of the database and restore on a more recent release. Can you restore the system back to the way it was before the upgrade and start over again, or have you burnt your bridges?

  2. #12
    Join Date
    Jan 2009
    Location
    Switzerland
    Posts
    1,529

    Default Re: MySQL Community Server 5.1.54 on openSUSE 11.1 (SLES 11 sp1)Error 2003 /var/lib/mysql.sock

    Some unsorted ideas what you can try:

    1. Backup your database files. Provided they are intact someone with a working 11.1 can make dumps from them.

    2. Uninstall any incompatible MySQL packages you have installed.

    3. Look here: openSUSE:Evergreen - openSUSE
    11.1 is still maintained in the Evergreen project. Install MySQL from the Evergreen repos.
    Technology is 'stuff that doesn't work yet.' -- Bran Ferren

  3. #13
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: MySQL Community Server 5.1.54 on openSUSE 11.1 (SLES 11 sp1)Error 2003 /var/lib/mysql.sock

    On 2011-09-23 19:36, jsw1130 wrote:
    > This started after I updated the broken repo
    > *http://tinyurl.com/3lnazgx* to *'Index of
    > /repositories/server:/database:/UNSTABLE/SLE_11_SP1'
    > (http://tinyurl.com/439agyg)*


    You said elsewhere that you are using openSUSE, not SLES, thus you used the
    wrong repo to update it. Actually, being openSUSE 11.1 an out of cycle
    version, you can not update it at all, because the repos were removed. You
    may switch to evergreen, perhaps. The 11.1 repos that survive should have
    been renamed to evergreen.

    You can upgrade the entire distro, though - but you lack experience if you
    hit problems during the procedure. And same thing for installing fresh,
    because you do not know how the old machine is set up... This is one of the
    circumstances where an upgrade is recommended over a fresh install.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •