Results 1 to 5 of 5

Thread: Trying to install Digikam 2.0.0

  1. #1

    Default Trying to install Digikam 2.0.0

    Hello Everyone,

    I'm trying to do my first installation from source. I'm trying to install Digikam 2 in the hopes that it will run better than the current version I have installed. I'm using this guide here: He mentions that you may not have everything you need so expect to have to install things. This has been true for me. I've read the error messages and installed a few more packages. But there's one I can't figure out. Here's the error message:

    Code:
    usr/src/packages/SOURCES/digikam-2.0.0>  cmake -DCMAKE_BUILD_TYPE=debugfull -DCMAKE_INSTALL_PREFIX=`kde4-config --prefix`
    If 'cmake' is not a typo you can use command-not-found to lookup the package that contains it, like this:
        cnf cmake
    johan@linux-w6om:/usr/src/packages/SOURCES/digikam-2.0.0>  cmake -DCMAKE_BUILD_TYPE=debugfull -DCMAKE_INSTALL_PREFIX=`kde4-config --prefix`
    -- The C compiler identification is GNU
    -- The CXX compiler identification is GNU
    -- Check for working C compiler: /usr/bin/gcc
    -- Check for working C compiler: /usr/bin/gcc -- works
    -- Detecting C compiler ABI info
    -- Detecting C compiler ABI info - done
    -- Check for working CXX compiler: /usr/bin/c++
    -- Check for working CXX compiler: /usr/bin/c++ -- works
    -- Detecting CXX compiler ABI info
    -- Detecting CXX compiler ABI info - done
    CMake Error at /usr/share/cmake/Modules/FindKDE4.cmake:98 (MESSAGE):
      ERROR: cmake/modules/FindKDE4Internal.cmake not found in
      /home/johan/.kde4/share/apps;/usr/share/kde4/apps;/etc/kde4/share/apps
    Call Stack (most recent call first):
      CMakeLists.txt:33 (FIND_PACKAGE)
    
    
    -- Configuring incomplete, errors occurred!
    johan@linux-w6om:/usr/src/packages/SOURCES/digikam-2.0.0>  cmake -DCMAKE_BUILD_TYPE=debugfull -DCMAKE_INSTALL_PREFIX=`kde4-config --prefix`
    -- Looking for Q_WS_X11
    -- Looking for Q_WS_X11 - found
    -- Looking for Q_WS_WIN
    -- Looking for Q_WS_WIN - not found.
    -- Looking for Q_WS_QWS
    -- Looking for Q_WS_QWS - not found.
    -- Looking for Q_WS_MAC
    -- Looking for Q_WS_MAC - not found.
    -- Found Qt-Version 4.7.1 (using /usr/bin/qmake)
    -- Looking for XOpenDisplay in /usr/lib64/libX11.so;/usr/lib64/libXext.so;/usr/lib64/libXft.so;/usr/lib64/libXau.so;/usr/lib64/libXdmcp.so;/usr/lib64/libXpm.so
    -- Looking for XOpenDisplay in /usr/lib64/libX11.so;/usr/lib64/libXext.so;/usr/lib64/libXft.so;/usr/lib64/libXau.so;/usr/lib64/libXdmcp.so;/usr/lib64/libXpm.so - found
    -- Looking for gethostbyname
    -- Looking for gethostbyname - found
    -- Looking for connect
    -- Looking for connect - found
    -- Looking for remove
    -- Looking for remove - found
    -- Looking for shmat
    -- Looking for shmat - found
    -- Looking for IceConnectionNumber in ICE
    -- Looking for IceConnectionNumber in ICE - found
    -- Found X11: /usr/lib64/libX11.so
    -- Looking for include files CMAKE_HAVE_PTHREAD_H
    -- Looking for include files CMAKE_HAVE_PTHREAD_H - found
    -- Looking for pthread_create in pthreads
    -- Looking for pthread_create in pthreads - not found
    -- Looking for pthread_create in pthread
    -- Looking for pthread_create in pthread - found
    -- Found Threads: TRUE 
    -- Looking for _POSIX_TIMERS
    -- Looking for _POSIX_TIMERS - found
    -- Found Automoc4: /usr/bin/automoc4 
    -- Found Perl: /usr/bin/perl 
    -- Found Phonon: /usr/include 
    -- Performing Test _OFFT_IS_64BIT
    -- Performing Test _OFFT_IS_64BIT - Success
    -- Performing Test HAVE_FPIE_SUPPORT
    -- Performing Test HAVE_FPIE_SUPPORT - Success
    -- Performing Test __KDE_HAVE_W_OVERLOADED_VIRTUAL
    -- Performing Test __KDE_HAVE_W_OVERLOADED_VIRTUAL - Success
    -- Performing Test __KDE_HAVE_GCC_VISIBILITY
    -- Performing Test __KDE_HAVE_GCC_VISIBILITY - Success
    -- Found KDE 4.6 include dir: /usr/include
    -- Found KDE 4.6 library dir: /usr/lib64
    -- Found the KDE4 kconfig_compiler preprocessor: /usr/bin/kconfig_compiler
    -- Found automoc4: /usr/bin/automoc4
    -- ----------------------------------------------------------------------------------
    -- Starting CMake configuration for: libksane
    CMake Error at /usr/share/kde4/apps/cmake/modules/FindPackageHandleStandardArgs.cmake:198 (MESSAGE):
      Could NOT find Sane (missing: SANE_LIBRARY SANE_INCLUDE_DIR)
    Call Stack (most recent call first):
      /usr/share/kde4/apps/cmake/modules/FindSane.cmake:19 (FIND_PACKAGE_HANDLE_STANDARD_ARGS)
      extra/libksane/CMakeLists.txt:13 (FIND_PACKAGE)
    
    
    -- Configuring incomplete, errors occurred!
    johan@linux-w6om:/usr/src/packages/SOURCES/digikam-2.0.0>  cmake -DCMAKE_BUILD_TYPE=debugfull -DCMAKE_INSTALL_PREFIX=`kde4-config --prefix`
    -- Found Qt-Version 4.7.1 (using /usr/bin/qmake)
    -- Found X11: /usr/lib64/libX11.so
    -- Found KDE 4.6 include dir: /usr/include
    -- Found KDE 4.6 library dir: /usr/lib64
    -- Found the KDE4 kconfig_compiler preprocessor: /usr/bin/kconfig_compiler
    -- Found automoc4: /usr/bin/automoc4
    -- ----------------------------------------------------------------------------------
    -- Starting CMake configuration for: libksane
    CMake Error at /usr/share/kde4/apps/cmake/modules/FindPackageHandleStandardArgs.cmake:198 (MESSAGE):
      Could NOT find Sane (missing: SANE_LIBRARY SANE_INCLUDE_DIR)
    Call Stack (most recent call first):
      /usr/share/kde4/apps/cmake/modules/FindSane.cmake:19 (FIND_PACKAGE_HANDLE_STANDARD_ARGS)
      extra/libksane/CMakeLists.txt:13 (FIND_PACKAGE)
    
    
    -- Configuring incomplete, errors occurred!
    johan@linux-w6om:/usr/src/packages/SOURCES/digikam-2.0.0>
    I did a search in YaST for sane and got some results, a few of which I installed since they seemed appropriate. There are others that don't seem so, like sane-backends. But it still won't run. What is the error message trying to tell me? Thanks in advance.

  2. #2
    Join Date
    Jun 2008
    Location
    Florida, USA
    Posts
    970

    Default Re: Trying to install Digikam 2.0.0

    In the past I have followed this 'How-to-compile" and successfully compiled Digikam 2.

    It is looking for the environment variables

    SANE_LIBRARY and SANE_INCLUDE_DIR

    Are you sure you have the devel (development) packages loaded for the sane dependencies?
    For example: sane-backends-devel and libksane-devel

    Once all the error messages for configuration are cleared, expect a lengthy compile.

    You might also consider moving up to KDE 4.7.1 in the 11.4/KDE47 repo.
    Digikam 2 is being actively maintained (updated) there.
    This makes it must easier to stay up-to-date.

  3. #3

    Default Re: Trying to install Digikam 2.0.0

    Thanks for the reply. I tried to upgrade to 4.7.1 but I don't seem to have succeeded despite a lot of downloading. I'll have to check it out later and find where things went wrong. Thanks again.

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: Trying to install Digikam 2.0.0

    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5

    Default Re: Trying to install Digikam 2.0.0

    Quote Originally Posted by caf4926 View Post
    Thank you very much. It seems to have worked. I ran into some upgrade problems (dependency conflicts, but I'm hoping I've solved them now). Thanks again.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •