Results 1 to 9 of 9

Thread: npviewer.bin cpu percentage

  1. #1

    Default npviewer.bin cpu percentage

    Hi,
    i have just installed the opensuse 11.4 (the 64bit version)
    I have updated all the applications. The only messages I'm facing on the /var/log/warn and /var/log/messages are for the configuration of the bluetooth interface.
    But, when I started to watch a flash video, the npviewer.bin process goes up to about 80% CPU.
    Does anyone face the same issue?
    Any idea on how limit the CPU usage of that process? if not, do you know if a bug is opened and tracked for this issue?

    Thanks a lot for your answers.

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: npviewer.bin cpu percentage

    You could look at switching to this
    Fix your flash in 11.4 _64 with flash square
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3

    Default Re: npviewer.bin cpu percentage

    Hi caf4926,
    I was looking at it at the same time.
    yes, it's better. I 'm saying better because I'm not facing the 80% CPU usage. But, the browser takes about 50% CPU usage when I'm viewing a flash video.
    Do you experience the same behavior?

  4. #4

    Default Re: npviewer.bin cpu percentage

    I had the same issue with ATI graphics cards (at some point since 11.3) and finally fixed it - after a couple months (!) - by simply enabling compositing under Gnome (not enabled by default AFAIK) and on KDE (enabled by default but which I had disabled in my local default). Installing the 64bit version didn't help (as long as compositing was disabled). See this thread: compositor: quickly sets/unsets compositing (helps with fullscreen Flash on ATI)

    It's quite possible that the issue doesnt affect all models of ATI cards.

    I didn't have problems on nvidia systems - and therefore didn't install the 64bit version (or maybe I did for testing but didn't notice a difference).

  5. #5

    Default Re: npviewer.bin cpu percentage

    Quote Originally Posted by hayawan View Post
    yes, it's better. I 'm saying better because I'm not facing the 80% CPU usage. But, the browser takes about 50% CPU usage when I'm viewing a flash video.
    Do you experience the same behavior?
    50% is not unusal. I reach 75% in fullscreen and it varies from 30% and 50% otherwise. Flash eats a lot of CPU resources anyway (That's why you don't find it on the iPad).

  6. #6

    Default Re: npviewer.bin cpu percentage

    hi please_try_again,
    I have a nvidia card. I looked at the kwinrc file and i didn't find any "Enabled" entry for the compositing group. so, I tried : kwriteconfig --file kwinrc --group Compositing --key Enabled --type bool true
    I disconnect/reconnect and nothing have changed when I'm viewing a flash video.
    I think that I leave as it is!

    Thanks for your help guys!

  7. #7

    Default Re: npviewer.bin cpu percentage

    Quote Originally Posted by please_try_again View Post
    50% is not unusal. I reach 75% in fullscreen and it varies from 30% and 50% otherwise. Flash eats a lot of CPU resources anyway (That's why you don't find it on the iPad).
    Yep, you're right, I just tried and HTML5 video and it didn't take that much!
    thanks.

  8. #8

    Default Re: npviewer.bin cpu percentage

    Quote Originally Posted by hayawan View Post
    hi please_try_again,
    I have a nvidia card. I looked at the kwinrc file and i didn't find any "Enabled" entry for the compositing group. so, I tried : kwriteconfig --file kwinrc --group Compositing --key Enabled --type bool true
    I disconnect/reconnect and nothing have changed when I'm viewing a flash video.
    I think that I leave as it is!
    This is not enough. You have to enable compositing for full screen videos as this is disabled by default - assuming it's a fullscreen issue. Here are the commands I use for KDE:

    Code:
    #! /bin/sh
    kwriteconfig --file kwinrc --group Compositing --key Enabled --type bool true
    kwriteconfig --file kwinrc --group Compositing --key UnredirectFullscreen --type bool false
    qdbus org.kde.kwin /KWin reconfigure
    The compositor script switches these boolean values and reloads the configuration, so there is no need to log out and re-log in.

    But again, I doesn't make a difference on Nvidia (on ATI a huge difference though).

  9. #9

    Default Re: npviewer.bin cpu percentage

    Quote Originally Posted by please_try_again View Post
    But again, I doesn't make a difference on Nvidia (on ATI a huge difference though).
    Yep, I didn't notice any diff!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •