Page 1 of 3 123 LastLast
Results 1 to 10 of 28

Thread: Linux changed case of everything when copying off DVD.

  1. #1

    Default Linux changed case of everything when copying off DVD.

    Coming from a Mac OSX environment, I have directory/folder names with the first character of each word
    in upper-case, as well as their content, i.e., artists/songs. This is how things were copied to DVD. However,
    when I copied everything off DVD to my Linux disk, everything was changed to lower-case, which is really
    irritating. WHY DOES LINUX DO THIS?

    I'm running openSUSE 11.4 32-bit.

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,519
    Blog Entries
    15

    Default Re: Linux changed case of everything when copying off DVD.

    Quote Originally Posted by rderosier
    Coming from a Mac OSX environment, I have directory/folder names with
    the first character of each word
    in upper-case, as well as their content, i.e., artists/songs. This is
    how things were copied to DVD. However,
    when I copied everything off DVD to my Linux disk, everything was
    changed to lower-case, which is really
    irritating. WHY DOES LINUX DO THIS?
    Hi
    Because it's the default.... you can turn it off by using the map=off
    option when mounting (see man mount).

    --
    Cheers Malcolm °¿° (Linux Counter #276890)
    openSUSE 11.4 (x86_64) Kernel 2.6.37.6-0.7-desktop
    up 7 days 4:47, 3 users, load average: 0.38, 0.21, 0.22
    GPU GeForce 8600 GTS Silent - Driver Version: 280.13


  3. #3
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: Linux changed case of everything when copying off DVD.

    I should also add that most people do not experience case conversion because their Linux CDs have Rock Ridge extension enabled which allows the original filename to be seen. It's not clear how the OP made his DVD, perhaps with a mastering program that didn't put RR extension on the DVD or perhaps using HFS extensions instead.

  4. #4
    Chris Maaskant NNTP User

    Default Re: Linux changed case of everything when copying off DVD.

    malcolmlewis wrote:

    > Hi
    > Because it's the default


    Why is it default to alter files when copying from one media to another?
    I'm sure there is a reason but it seems very strange to me.

    I'm just curious.
    --
    Chris Maaskant

  5. #5
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: Linux changed case of everything when copying off DVD.

    Actually it's a bit more subtle than that. Here's what the man 8 mount says about iso9660 options:

    map={n[ormal]|o[ff]|a[corn]}
    For non-Rock Ridge volumes, normal name translation maps upper to lower case ASCII,
    drops a trailing `;1', and converts `;' to `.'. With map=off no name translation is
    done. See norock. (Default: map=normal.)
    So if the OP's DVD has no RR extensions, map=off might not be much better, instead of getting

    myfavouritesong.mp3

    he might get

    MYFAVOURITESONG.MP3;1

    In other words the mixed case information might have been lost if he didn't burn with RR or HFS extensions enabled.

  6. #6

    Default Re: Linux changed case of everything when copying off DVD.

    Quote Originally Posted by malcolmlewis View Post
    Hi
    Because it's the default.... you can turn it off by using the map=off
    option when mounting (see man mount).

    --
    Cheers Malcolm °¿° (Linux Counter #276890)
    openSUSE 11.4 (x86_64) Kernel 2.6.37.6-0.7-desktop
    up 7 days 4:47, 3 users, load average: 0.38, 0.21, 0.22
    GPU GeForce 8600 GTS Silent - Driver Version: 280.13

    mount -o man=o /dev/cdrom
    mount: only root can do that

    sudo mount -o man=o /dev/cdrom
    mount: wrong fs type, bad option, bad superblock on /dev/sr0,
    missing codepage or helper program, or other error
    In some cases useful info is found in syslog - try
    dmesg | tail or so

    After the above, the contents of the cdrom were still all lower-case.

    When I first got on Linux, I added the following line to /ect/fstab so I could mount the drive:
    /dev/cdrom /media/cdrom iso9660 ro,user,noauto,unhide 0 0

    Any further suggestions?

    Oh, BTW, on Mac OSX (which is NFS extended) I just inserted a blank DVD in the drive
    and dragged and dropped on it what I wanted copied, and then clicked BURN.

  7. #7

    Default Re: Linux changed case of everything when copying off DVD.

    Quote Originally Posted by rderosier View Post

    Oh, BTW, on Mac OSX (which is NFS extended) I just inserted a blank DVD in the drive
    and dragged and dropped on it what I wanted copied, and then clicked BURN.
    I should have said HFS+ extended. I'm not an expert on Mac OSX, nor Linux, for that matter.

  8. #8
    Join Date
    Oct 2008
    Location
    Glasgow, Scotland
    Posts
    1,131

    Default Re: Linux changed case of everything when copying off DVD.

    maps upper to lower case ASCII
    converts
    MYFAVOURITESONG.MP3;1
    to
    myfavouritesong.mp3

    not vice-versa

  9. #9

    Default Re: Linux changed case of everything when copying off DVD.

    Quote Originally Posted by rderosier View Post

    sudo mount -o man=o /dev/cdrom
    I just noticed I typed man instead of map in the above line.

    I just redid it using map this time and I got no error. However,
    the contents of the cdrom were still all lower-case.

  10. #10
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: Linux changed case of everything when copying off DVD.

    Quote Originally Posted by eng-int View Post
    converts
    MYFAVOURITESONG.MP3;1
    to
    myfavouritesong.mp3

    not vice-versa
    Yes but when you turn mapping off (it's on by default), you get the original name which is MYFAVOURITESONG.MP3;1

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •