Results 1 to 10 of 10

Thread: Help with Gnome/X11 issue for beginner

  1. #1

    Default Help with Gnome/X11 issue for beginner

    I am a beginner with linux and seem to have done something to my user account, as the issue describe below only occurs with my account.
    If i run startx from root or from another account i created everything is working fine.

    I thought the issue was being caused by the nvidia drivers, but have installed different versions and have the same issue, but per above the other accounts work fine.
    etc
    The issue i have is; certain applications i.e. virtualbox, kdiff3, etc when started only show on the status bar as being opened. but when i click on maximise, resize, etc they don't open - but per above the same applications work fine on another account.

    I also had the problem that each time i logged into the said account, it would be forced into 800x600 even though i kept resettings nvidia-settings. I discovered a file .profile (i think) that i deleted which fixed that problem.

    i guess i need to reset the x11 settings to default for the user, but haven't found clear advice on how to do it. although, i then have the question why my other apps such as office and most gnome apps are fine.

    cheers for any help

  2. #2
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Help with Gnome/X11 issue for beginner

    On 2011-09-18 10:26, StevenJRees wrote:
    > but per above the same
    > applications work fine on another account.


    Crate a new account and use it instead.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

  3. #3

    Default Re: Help with Gnome/X11 issue for beginner

    @robin_listas, doesn't really help me learn though does it?

    As it happens, i re-enable KDE repository and it then want to update and install a bunch of KDE files. After that, it was working. Don't understand why, as i am using gnome.

    Only problem i have still, is the icons from the virtualbox main menu are missing. but i think i have an issue with gtk as a few programs bring up object errors if run from terminal.

  4. #4
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Help with Gnome/X11 issue for beginner

    On 2011-09-20 08:06, StevenJRees wrote:
    >
    > @robin_listas, doesn't really help me learn though does it?


    Being a new user you will not have a lot of data, and I have no idea what
    you may have broken.

    You may, however, compare all the config files between both working user
    and not working user, and learn the cause - if possible.

    The other possibility is to copy over the config files from a new user
    replacing yours. Or simply to delete them.


    > Only problem i have still, is the icons from the virtualbox main menu
    > are missing. but i think i have an issue with gtk as a few programs
    > bring up object errors if run from terminal.


    In the new user?

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

  5. #5

    Default Re: Help with Gnome/X11 issue for beginner

    @robin_listas, "Being a new user you will not have a lot of data" - how i wish that was the case. i migrated my win7 laptop to opensuse 11.4 and retained the win7 partition which i access via virtualbox. i moved all my data from win7 to my user and access the data via linux apps or via win apps using shared folders. hence, i have a significant amount of data.

    "In the new user?" - existing user. virtualbox works fine and i can run my sessions, but the main menu icons are missing. On new user or root, the icons are there.

    appreciate the input

  6. #6
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,056
    Blog Entries
    14

    Default Re: Help with Gnome/X11 issue for beginner

    Hi, welcome here..

    One of the things you should not have done is logging onto a desktop environment as root. Numerous posts in the forums for this.

    From what you tell us, I get that you're running KDE, though the post title mentions GNOME.....Well, this is for KDE. If you follow this, the only thing you would have to do, is reapplying any appearance changes you made to KDE. Login as the new user, open a terminal window, and become your "problematic user":
    Code:
    su "problematic username"
    (enter your user's password)
    cd ~/
    (this moves you to the "problematic user"s homedir
    mkdir OLDPLASMAFILES
    mv ~/.kde4/share/config/plasm* OLDPLASMAFILES
    Now logout, login as the "problematic user". You should see the default KDE desktop, yet with all your data available, ditto for application settings
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  7. #7
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Help with Gnome/X11 issue for beginner

    On 2011-09-20 22:06, StevenJRees wrote:
    >
    > @robin_listas, "Being a new user you will not have a lot of data" - how
    > i wish that was the case. i migrated my win7 laptop to opensuse 11.4 and
    > retained the win7 partition which i access via virtualbox. i moved all
    > my data from win7 to my user and access the data via linux apps or via
    > win apps using shared folders. hence, i have a significant amount of
    > data.


    Mmmm.

    > "In the new user?" - existing user. virtualbox works fine and i can run
    > my sessions, but the main menu icons are missing. On new user or root,
    > the icons are there.
    >
    > appreciate the input


    Then I would work with the new user, moving there the data files from the
    old user. You can change the name later.

    Alternatively, copy all files of new user, which should be only config
    files, to the old user. Do this as the old user logged in text mode, so
    that the ownership is correct. The graphic session must be closed. Use 'mc'.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

  8. #8
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Help with Gnome/X11 issue for beginner

    On 2011-09-20 22:28, Carlos E. R. wrote:
    > Alternatively, copy all files of new user, which should be only config
    > files, to the old user. Do this as the old user logged in text mode, so
    > that the ownership is correct. The graphic session must be closed. Use 'mc'.


    Forgot to say: as a previous step, delete, or better, move to a temporary
    directory, all files and folders that will be replaced, of the old user.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

  9. #9
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Help with Gnome/X11 issue for beginner

    On 2011-09-20 22:26, Knurpht wrote:

    > Code:
    > --------------------
    >
    > su "problematic username"


    That would be "su -", or the "cd ~/" op later will fail :-)

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

  10. #10
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,056
    Blog Entries
    14

    Default Re: Help with Gnome/X11 issue for beginner

    Quote Originally Posted by robin_listas View Post
    On 2011-09-20 22:26, Knurpht wrote:

    > Code:
    > --------------------
    >
    > su "problematic username"


    That would be "su -", or the "cd ~/" op later will fail :-)

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)
    Sharp as ever. And I'm the one using 'su -' only. Shame on me.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •