Results 1 to 10 of 10

Thread: Skype no video

  1. #1

    Default Skype no video

    Hi,
    I have a logitech usb webcam on Opensuse 11.4/Gnome, and problems with skype. I managed to put the sound, but the video is not working. It is working although on Kopete (I installed it for the test).
    Any ideas what I should do ?
    Thanx

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,673
    Blog Entries
    1

    Default Re: Skype no video

    This may work for you: Open a terminal window and start skype like this

    Code:
    LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so skype
    See how that goes.

  3. #3
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,673
    Blog Entries
    1

    Default Re: Skype no video

    There is a similar tip for 64-bit users here:

    SDB:Skype - openSUSE

    How To Fix Webcam Problem In Skype | Ubuntu Root

  4. #4

    Default Re: Skype no video

    Quote Originally Posted by deano_ferrari View Post
    This may work for you: Open a terminal window and start skype like this

    Code:
    LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so skype
    See how that goes.
    Thank you Deano, it seemed to work fine with this command !
    I forgot to tell you I have 32 bits...
    Now do you know how I can make it permanently, without using the terminal ?

  5. #5
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,574
    Blog Entries
    38

    Default Re: Skype no video

    Quote Originally Posted by franck210883 View Post
    ... it seemed to work fine with this command !
    I forgot to tell you I have 32 bits...
    Now do you know how I can make it permanently, without using the terminal ?
    If the "LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so skype" works for you, it suggests your webcam is a webcam that uses the 'gspca' kernel module/driver.

    There is general guidance for openSUSE and webcams here: HCL:Web cameras - openSUSE where you can note that
    .... if this works for you, you can add the LD_PRELOAD-command to the startup command of your menu entry/desktop shortcut via menu editor or with right-clicking the desktop icon => properties => application => command respectively.

  6. #6

    Default Re: Skype no video

    Thank you very much for you help.
    Just I had to add env in the beginning : env LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so skype
    Otherwise it doesn't work.

  7. #7

    Default Re: Skype no video

    You have to install a computer program called "Cheese". Run that program and you will see your logitech camera actually being detected by your computer. Once you have done that, go to Skype options, video devices and then check mark "Enable Skype Video"

    It should work then!

    ---Stan

  8. #8
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,574
    Blog Entries
    38

    Default Re: Skype no video

    Quote Originally Posted by savezov View Post
    You have to install a computer program called "Cheese". Run that program and you will see your logitech camera actually being detected by your computer. Once you have done that, go to Skype options, video devices and then check mark "Enable Skype Video"

    It should work then!

    ---Stan
    The application Cheese is not a pre-requisite for using Skype.

  9. #9

    Default Re: Skype no video

    Quote Originally Posted by franck210883 View Post
    Now do you know how I can make it permanently, without using the terminal ?
    I have an executable script in my ~\bin directory called "skype2" that has the contents:

    Code:
    export LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so
    skype
    I then autostart skype2.

  10. #10

    Default Re: Skype no video

    Thank you for your help, guys, but I've already solved the problem :

    Controle center/appearance/main menu/Internet/Skype (sorry, my translation from french is quite unprecise...)

    I enter that code (to launch the application through that command) :env LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so skype

    And everything works perfectly !

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •