Results 1 to 9 of 9

Thread: No window' decorations on Compiz (Gnome 2) after installing 11.4 64bit

  1. #1

    Default No window' decorations on Compiz (Gnome 2) after installing 11.4 64bit

    After installing opensuse 11.4 (64bit- gnome 2), enabling compiz effects makes windows' decorations disappear.
    I can solve this by doing

    gtk-window-manager --replace

    but I have to do this every log in.
    Any suggestion ?

    Thanks
    Saluti
    R

  2. #2

    Default Re: No window' decorations on Compiz (Gnome 2) after installing 11.4 64bit

    Quote Originally Posted by roberto60 View Post
    .....

    gtk-window-manager --replace

    ...
    sorry the command is

    Code:
    gtk-window-decorator --replace&
    but it works without the option too
    Saluti
    R

  3. #3

    Default Re: No window' decorations on Compiz (Gnome 2) after installing 11.4 64bit

    I got some more information from the file ~/.xsession-errors where the following

    Code:
    gnome-session[9616]: WARNING: Could not parse desktop file /etc/xdg/autostart/ksmolt-autostart.desktop: Nome chiave non valido: X-KDE-autostart-condition[$e]
    gnome-session[9616]: WARNING: could not read /etc/xdg/autostart/ksmolt-autostart.desktop
    gnome-session[9616]: WARNING: Unable to find provider 'gtk-window-decorator' of required component 'windowmanager'
    ** (gnome-settings-daemon:9722): WARNING **: Can not run apport-checkreports
    (applet.py:9791): libnotify-WARNING **: Missing symbol 'gdk_screen_make_display_name'
    (applet.py:9791): libnotify-WARNING **: Missing symbol 'gdk_screen_make_display_name'
    ** (nm-applet:9798): WARNING **: get_all_cb: couldn't retrieve system settings properties: (2) The name org.freedesktop.NetworkManagerSystemSettings was not provided by any .service files.
    ** (nm-applet:9798): WARNING **: fetch_connections_done: error fetching system connections: (2) The name org.freedesktop.NetworkManagerSystemSettings was not provided by any .service files.
    *** NSPlugin Wrapper *** WARNING:(/usr/src/packages/BUILD/nspluginwrapper-1.3.0/src/npw-wrapper.c:3160):invoke_NP_Initialize: assertion failed: (rpc_method_invoke_possible(g_rpc_connection))
    some hints on how to solve the warning how to find the windowmanager and the NSPlugin?

    Then issuing compiz --replace ccp & emerald --replace &

    Code:
    emerald: command not found
    Backend     : ini
    Integration : true
    Profile     : default
    Adding plugins
    Initializing core options...done
    Initializing composite options...done
    Initializing opengl options...done
    Initializing imgjpeg options...done
    Initializing decor options...done
    Initializing place options...done
    Initializing mousepoll options...done
    compiz (core) - Error: Plugin 'text' not loaded.
    
    Initializing thumbnail options...done
    compiz (core) - Error: Plugin 'text' not loaded.
    
    compiz (shift) - Warn: No compatible text plugin loaded
    I updated to the repository X11:Compiz packages with no results
    Saluti
    R

  4. #4
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,868
    Blog Entries
    14

    Default Re: No window' decorations on Compiz (Gnome 2) after installing 11.4 64bit

    Use the compiz settings manager to set the window decoration. The log just shows WARNINGS , not errors.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  5. #5

    Default Re: No window' decorations on Compiz (Gnome 2) after installing 11.4 64bit

    compiz wasn't able to load the text plugin it shouldn't be so.

    Then using the fusion-icon package I was able to set the window decorator. I suspect that it is a bug because on my laptop I experienced the same problem same version of opensuse but different hardware.
    Saluti
    R

  6. #6

    Default Re: No window' decorations on Compiz (Gnome 2) after installing 11.4 64bit

    reading this post

    Troubleshooting - Compiz Wiki

    I discovered that is due to the fact that at the login compiz is unable to start. The effect of the fusion-icon is to restart compiz.
    I have an intel card.

    Is a log to look into to know why compiz doesn't start?
    Saluti
    R

  7. #7

    Default Re: No window' decorations on Compiz (Gnome 2) after installing 11.4 64bit

    Ciao Roberto,
    I use Compiz 9.5 by kde 4.7. For now I show you how to start compiz manually, if works just put a script in your autostart.
    Supported window decorators by compiz:
    gtk and kde. Emerald doesn't work anymore, BUT you can install Smaragt as kde window decorator under kde4 and load it in compiz with kde4-window-decorator --replace, what I do also. Smaragt uses as decoration the skin in ~/.emerald/theme.
    Loading compiz:
    if there is already some window manager loaded use compiz-manager --replace
    if there is no window manager at all use just compiz-manager.
    Laptop: MSI 60 2PC | OpenSUSE 13.1 (x86_64) | KDE Current| Compiz 8.8 | Intel(R) Core(TM) i7-4700HQ CPU 3.2GHz | GTX850M | 8GB RAM

  8. #8
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,868
    Blog Entries
    14

    Default Re: No window' decorations on Compiz (Gnome 2) after installing 11.4 64bit

    Quote Originally Posted by roberto60 View Post
    Is a log to look into to know why compiz doesn't start?
    I'd take a look in:
    Code:
    /home/YOURUSERNAME/.xsessionerrors
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  9. #9

    Default Re: No window' decorations on Compiz (Gnome 2) after installing 11.4 64bit

    In my first post in this thread I attached the results of a grep to the file you pointed to.

    Grep to "error" give no results I got something meaningful only for warning.

    Upgrading to 0.9.5 of compiz from the build repository X11:Compiz solved the problem.
    Saluti
    R

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •