Results 1 to 9 of 9

Thread: New user to Amarok and I have some issues with it

  1. #1

    Default New user to Amarok and I have some issues with it

    I come from a Mac world using iTunes that I love, and now I'm
    trying to get my music collection (as mp3s) running on Linux.
    I've read a lot where people really like Amarok, so I thought
    I'd try it out, but it's a real pain. I hope it's just my not
    having used it much that's at fault and someone more familiar
    with it can guide me in getting it set up the way I want to
    use it.

    I'm running openSUSE 11.4 32-bit with the Gnome desktop, but
    I also have KDE installed (I find setting it up the way I want
    much more difficult than Gnome, which is why I'm running it).
    I'm running Amarok 2.4.0 which came with the installed system.

    Since I'm coming to Linux from Mac with iTunes, the easiest
    way to get my music to Linux was to convert my Mac m4a files
    to mp3 files, burn them to DVDs and then install them on Linux.
    This was done, and now all my files are organized as follows:

    Music
    |
    ---------------------------
    | | |
    Artist1 Artist2 Compilations
    | | | |
    Albums Albums Album1 Album2
    | | | |
    Tracks Tracks Tracks Tracks

    My issues with Amarok are as follows:

    1. Dragging all albums for an artist in Media Sources to the
    Pop-Up Dropper (PUD) to add them to a playlist adds more
    than what I tell it to. By this I mean, if the artist also
    has individual tracks under the Compilations header above,
    then these get added to the playlist along with all those
    from the artist's albums. I DO NOT WANT THE COMPILATION
    TRACKS ADDED AND DON'T UNDERSTAND WHY THEY ARE ADDED SINCE
    I DID NOT DRAG AND DROP THEM. I observe the same behavior
    when not using the PUD and drag and drop straight to the
    playlist side itself. Why is this occurring and can I stop
    it from doing so?

    2. Adding anything to a playlist automatically starts the 1st
    track playing. I DO NOT WANT ANYTHING PLAYING UNTIL I TELL
    IT TO START PLAYING. Can this be changed?

    3. When a track is playing and I adjust the slider of where it's
    at in the song (i.e., move it closer to the finish) and the
    song finishes, Amarok will stop instead of starting the next
    track in the playlist. IT SHOULD JUST MOVE TO THE NEXT TRACK.
    Why is this happening and can it be changed?

    4. Using the Automated Playlist Generator (APG) to create a
    playlist that consists of all my 5-star rated tracks (which
    happens to be over 900 tracks). I used "Match tag: rating
    equals 5 stars and "Match All" group and moved the match
    slider to the "exact" position. Then I went through all my
    tracks setting my favorites to 5-stars. When I clicked the
    blue arrow for "Run the APG with selected preset", I got the
    surprise of my life. It would only do 30 random tracks, which
    was set under "Playlist duration". THIS ALONE SEEMS ODD TO ME!
    It's only settings are </=/> some number, so I tried = to all
    my 5-star tracks, and ran it again with the selected preset.
    THIS CREATED A PLAYLIST OF VARYING SIZES EACH TIME I RAN IT,
    AND IT ADDED TRACKS THAT DID NOT HAVE 5-STARS AND ADDED MANY
    DUPLICATES OF THE SAME TRACKS. I then tried the > number with
    basically the same outcome. Why does this occur and can it be
    told to just do what I want and do it reliably? Since I could
    not get this to work anywhere close to what I wanted, I game
    up and created a static playlist with only my 5-star tracks.

    5. I cannot determine where my Amarok settings/playlists/etc. are
    saved so I can copy this information to a backup CD/DVD so I
    don't have to manually create everything from scratch again,
    if the need arises. Where is this stuff saved on disk, and can
    I accomplish what I want?

    6. FOR EXTRA CREDIT: It would be nice to not have to convert my
    Mac m4a files to mp3 just to play them on Linux, so if there's a
    way to play the m4a files on Linux, I'd love to hear about it.
    I've already added the Packman repository to my repository list,
    but really haven't done anything regarding it (really not sure
    what to do with it yet).

    Everything I complained about above can be accomplished with iTunes
    on the Mac, so if anybody sees a better music player for my needs
    I'd be interested in hearing about it. Otherwise, if all my issues
    can be fixed to my liking, then I might be happy staying with Amarok.

    Thanks

    Ron

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,728
    Blog Entries
    20

    Default Re: New user to Amarok and I have some issues with it

    One thing you might want to do is update amarok by adding the updated apps for kde
    Index of /repositories/KDE:/UpdatedApps/openSUSE_11.4

    Then switch to that repo, with the switcher in software management.

    I can't answer your playlist issues, it's not something I do.

    Converting is necessary. iTunes music is often DRM
    You may be able to convert the music with pacpl (it's in packman) add the dolphin context menu part and use dolphin, right click on your .m4a file/s and convert to>
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3

    Default Re: New user to Amarok and I have some issues with it

    None of my music has DRM - everything is off of CDs I've bought. Nothing is downloaded from the iTunes store.
    When I talked about iTunes, I only meant that I loved using the iTunes music player.

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,728
    Blog Entries
    20

    Default Re: New user to Amarok and I have some issues with it

    I never bought a cd yet with .m4a files on it

    Ripping them is easy with k3b
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5
    Join Date
    Jun 2008
    Location
    UK
    Posts
    5,500

    Default Re: New user to Amarok and I have some issues with it

    Quote Originally Posted by rderosier View Post
    ...
    6. FOR EXTRA CREDIT: It would be nice to not have to convert my
    Mac m4a files to mp3 just to play them on Linux, so if there's a
    way to play the m4a files on Linux, I'd love to hear about it.
    I've already added the Packman repository to my repository list,
    but really haven't done anything regarding it (really not sure
    what to do with it yet).
    Running Amarok 2.4.0 and .m4a files play well here. Have you not read the stickies at the head of the Multimedia forum? For example: Multimedia in One Click including its link to the multimedia guide. You will need gstreamer plugins e.g. I have the "good", the "bad", but manage without the "ugly".

  6. #6
    Join Date
    Jun 2008
    Location
    UK
    Posts
    5,500

    Default Re: New user to Amarok and I have some issues with it

    I forgot to mention you probably also need the appropriate gstreamer-ffmpeg package.

  7. #7
    Join Date
    Jun 2008
    Location
    Sogndal, Noreg
    Posts
    1,103

    Default Re: New user to Amarok and I have some issues with it

    .m4a files play fine in AmaroK here as well. I use the xine backend, not the gstreamer, just to sort that out. These files were downloaded from an iPod long ago.

    Adding anything to a playlist automatically starts the 1st
    track playing. I DO NOT WANT ANYTHING PLAYING UNTIL I TELL
    IT TO START PLAYING. Can this be changed?
    This behaviour does not occur here. I can drag and drop from the local files library to the 'playlist' without it starting to play. I may also drag and drop from e.g. Dolphin onto the 'playlist' whithout AmaroK starting. I suppose you add them a bit differently though.


    Music
    |
    ---------------------------
    | | |
    Artist1 Artist2 Compilations
    | | | |
    Albums Albums Album1 Album2
    | | | |
    Tracks Tracks Tracks Tracks

    My issues with Amarok are as follows:

    1. Dragging all albums for an artist in Media Sources to the
    Pop-Up Dropper (PUD) to add them to a playlist adds more
    than what I tell it to. By this I mean, if the artist also
    has individual tracks under the Compilations header above,
    then these get added to the playlist along with all those
    from the artist's albums. I DO NOT WANT THE COMPILATION
    TRACKS ADDED AND DON'T UNDERSTAND WHY THEY ARE ADDED SINCE
    I DID NOT DRAG AND DROP THEM. I observe the same behavior
    when not using the PUD and drag and drop straight to the
    playlist side itself. Why is this occurring and can I stop
    it from doing so?
    If you get used to the way amarok organises the files I think you could manage to do that with labelling the files in quiestion under 'various artists', and use drag and drop from within the AmaroK library 'Local Collections' onto the 'playlist'.

    3. When a track is playing and I adjust the slider of where it's
    at in the song (i.e., move it closer to the finish) and the
    song finishes, Amarok will stop instead of starting the next
    track in the playlist. IT SHOULD JUST MOVE TO THE NEXT TRACK.
    Why is this happening and can it be changed?
    Nor is this happening with my player. NB, if you do play your music from the dvd itself this might happen? AmaroK (KDE) has one great weakness which is playback of CD/DVD media.

    5. I cannot determine where my Amarok settings/playlists/etc. are
    saved so I can copy this information to a backup CD/DVD so I
    don't have to manually create everything from scratch again,
    if the need arises. Where is this stuff saved on disk, and can
    I accomplish what I want?
    /home/olav/.kde4/share/apps/amarok/
    /home/olav/.kde4/share/config/amarokrc/
    /home/olav/.kde4/share/config/amarok_homerc/
    /home/olav/.kde4/share/config/amarok-appletsrc/

    Playlists (if not chosen to be saved within the database, AmarokDB):
    /home/olav/.kde4/share/apps/amarok/playlists

    Cheers
    OpenSuSE 13.1, KDE 4.11.5, 64bit
    Gigabyte 990FXA-UD3, AMD FX8350, MSI GeForce GTX 760, RME HDSP9632, 16GB HyperX Kingston DDR3, Samsung 840-Pro SSD 128GB, WD Desktop Black 1TB, Hitachi Deskstar 7K1000 750GB

  8. #8
    Join Date
    Jun 2008
    Location
    Sogndal, Noreg
    Posts
    1,103

    Default Re: New user to Amarok and I have some issues with it

    You might also play around with the layout of your 'Local Collection': Artist-Album-Genre, Album-Artist-Genre, Album-Album-Album etc. It might make you comfortable with a way of adding files to your 'playlist'.
    OpenSuSE 13.1, KDE 4.11.5, 64bit
    Gigabyte 990FXA-UD3, AMD FX8350, MSI GeForce GTX 760, RME HDSP9632, 16GB HyperX Kingston DDR3, Samsung 840-Pro SSD 128GB, WD Desktop Black 1TB, Hitachi Deskstar 7K1000 750GB

  9. #9
    josephkk NNTP User

    Default Re: New user to Amarok and I have some issues with it

    On Thu, 08 Sep 2011 21:06:02 GMT, caf4926
    <caf4926@no-mx.forums.opensuse.org> wrote:

    >
    >I never bought a cd yet with .m4a files on it
    >
    >Ripping them is easy with k3b


    Even i would balk at re-ripping a thousand or so CDs. pacpl should get
    the conversion job done in a day or two.

    ?-)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •