Results 1 to 2 of 2

Thread: OpenSuSE 11.4 Printing problems

  1. #1
    Join Date
    Jun 2008
    Delta Quadrant

    Default OpenSuSE 11.4 Printing problems

    Strangest thing happened today. I tried to print
    a simple text document from Kwrite and noticed it would
    not print. I tried it again selecting a different printer.
    No result. I tried copying the contents and pasting into
    Libre Office, then printers to select...Odd.
    I decided to check on cupsd status from CLI. It was up.
    Here's where things get stranger. I open CUPS web manager and select
    printers...'No printers found' Okay, that's odd since I should have about
    12, and they are showing up in Kwrite but not in LibreOffice nor CUPS
    manager. Assuming Kwrite used some sort of cache I decided to check out
    /etc/cups/printers.conf....Hmmm zero byte file with but in the same
    directory a file printers.conf.O dated about 7 days ago. So I did an
    /etc/init.d/cups stop, did a cat printers.conf.O > printers.conf and
    /etc/init.d/cups start...all is back to normal. WTH?! What waxed all of my

  2. #2
    Join Date
    Jun 2008
    Auckland, NZ
    Blog Entries

    Default Re: OpenSuSE 11.4 Printing problems

    Maybe cupsd crashed (while writing to it). AFAIU, everytime it starts, /etc/cups/printers.conf is updated. Anyway, at least you got it working from the backup file (printers.conf.O). I'd treat it as a 'one off' event for now, until you can replicate the problem...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts