Results 1 to 2 of 2

Thread: Possible bug in OpenBox autostart.sh script

  1. #1

    Default Possible bug in OpenBox autostart.sh script

    I'm not absolutely positive, but I think the following is a bug in /etc/xdg/openbox/autostart.sh

    24# Make GTK apps look and behave how they were set up in the gnome config tools
    25if test -x /usr/lib/gnome-settings-daemon >/dev/null; then
    26 /usr/lib/gnome-settings-daemon &
    27elif which gnome-settings-daemon >/dev/null; then
    28 gnome-settings-daemon &


    I think it should be

    24# Make GTK apps look and behave how they were set up in the gnome config tools
    25if test -x /usr/lib/gnome-settings-daemon/gnome-settings-daemon >/dev/null; then
    26 /usr/lib/gnome-settings-daemon/gnome-settings-daemon &
    27elif which gnome-settings-daemon >/dev/null; then
    28 gnome-settings-daemon &


    because on my install, gnome-settings-daemon is in a directory called gnome-settings-daemon, and it isn't in my $PATH

    -frotzen

  2. #2

    Default Re: Possible bug in OpenBox autostart.sh script

    That's right. Actually I've seen similar bugs (wrong paths) in /etc/xdg/openbox/autostart.sh on other distros as well. If you create the file ~/.config/openbox/autostart.sh, the one in /etc/xdg/openbox is ignored. That's what I do. You may try to submit a bugreport though.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •