Results 1 to 7 of 7

Thread: Black screen/Plasma/Activities issues

  1. #1
    Join Date
    Sep 2011
    Location
    Serbia
    Posts
    4

    Default Black screen/Plasma/Activities issues

    Hi, this is my first post on opensuse forum. I had had a lot of problems with opensuse from the very beginning, but i managed to solve most of them. I am not very experienced and i know the basic stuff for now. But the series of crashes i had today have almost convinced me to quit on opensuse and if i dont solve this, i will quit
    I played a bit with plasma widgets and every once in a while everything crashes, i see only black screen and have to restart. After restarting everything worked normal. I found some tutorials for opensuse, and started with some basic shortcuts, such as showing active windows and activities. Then i had black screen again (which i've come accustomed to) and restarted pc expecting everything will be just fine like it was after previous reboots. But then i saw that all activities are identical and everything i worked on has been deleted. I found in activities window that i have 20 or more activities and i didnt know where they had come from. I am stuck and i didnt see any activity that will restore my desktops to original state, and in my searching through activities i also had a lot of black screens.
    I use opensuse 11.4 x64 and kde 4.6. I am grateful for any help you give me. And sorry for any mistakes, english is not my first language.
    Marko

  2. #2
    Join Date
    Jun 2008
    Location
    Sogndal, Noreg
    Posts
    1,103

    Default Re: Black screen/Plasma/Activities issues

    Have you updated your system? I am on 64 bit as well, more or less same system as you I suppose, but have not got those issues.
    Those activities you mention, is that something you collect from the 'System Activity' manager?
    OpenSuSE 13.1, KDE 4.11.5, 64bit
    Gigabyte 990FXA-UD3, AMD FX8350, MSI GeForce GTX 760, RME HDSP9632, 16GB HyperX Kingston DDR3, Samsung 840-Pro SSD 128GB, WD Desktop Black 1TB, Hitachi Deskstar 7K1000 750GB

  3. #3
    Join Date
    Sep 2011
    Location
    Serbia
    Posts
    4

    Default Re: Black screen/Plasma/Activities issues

    I have AMD Phenom II x3 720 2.8GHz, 2GB DDR2 1066MHz, 1.5TB HDD, ATI Radeon 4850 1GB DDR3. Only downside is ram, but it shouldnt crash because of that, it barely uses half of my total amount of ram. Not sure about activities, I tried turning them on and off, and most of them make no difference, i found one that looked like one of my previous desktops. I dont want to continue using opensuse only to find errors like these to make me start from scratch.

  4. #4
    Join Date
    Jun 2008
    Location
    Sogndal, Noreg
    Posts
    1,103

    Default Re: Black screen/Plasma/Activities issues

    Try add a new user for the purpose of testing. Try using it without playing with widgets right-away, and see if it runs without crashes (and let the system activities run as well if they are started by default). OpenSuSE does not behave as you described by default, at least not in my experience, but it may be that you have changed something accidentally which has had some implications on your system.

    Your memory is sufficient.

    Cheers
    OpenSuSE 13.1, KDE 4.11.5, 64bit
    Gigabyte 990FXA-UD3, AMD FX8350, MSI GeForce GTX 760, RME HDSP9632, 16GB HyperX Kingston DDR3, Samsung 840-Pro SSD 128GB, WD Desktop Black 1TB, Hitachi Deskstar 7K1000 750GB

  5. #5
    Join Date
    Sep 2011
    Location
    Serbia
    Posts
    4

    Default Re: Black screen/Plasma/Activities issues

    I created new user, and as far as I can tell everything looks normal, there is only one activity and widgets are working normally, but when i use widgets in my first account they have transparent background and no borders. Also folder view widget shows one huge icon. At the time my desktops got messed up I had crashes and black screens so I was forced to restart and now when crashes occur (they mostly occur when I add a widget or resize it) it just restarts widgets automatically and I can continue using openSUSE. I don't know what i could've done to cause this situation, because I didn't change a lot of settings, most of the changes I've made so far refer to visual appearance.
    Thanks for helping

  6. #6
    Join Date
    Jun 2008
    Location
    Sogndal, Noreg
    Posts
    1,103

    Default Re: Black screen/Plasma/Activities issues

    It may be your graphical driver, I suppose. It seems like you have the desktop effects enabled (I believe they are turned on by default), however, if you haven't installed a proper driver for your ATI card that might be the cause of these 'blackscreens'. You could try, as your 'normal' user, turn off the desktop effects and see how that goes: System Settings > Workspace, Appearance and Behaviour > Desktop Effects

    Cheers
    OpenSuSE 13.1, KDE 4.11.5, 64bit
    Gigabyte 990FXA-UD3, AMD FX8350, MSI GeForce GTX 760, RME HDSP9632, 16GB HyperX Kingston DDR3, Samsung 840-Pro SSD 128GB, WD Desktop Black 1TB, Hitachi Deskstar 7K1000 750GB

  7. #7
    Join Date
    Sep 2011
    Location
    Serbia
    Posts
    4

    Default Re: Black screen/Plasma/Activities issues

    I installed new ati driver, and disabled desktop effects in my second account, only difference was that after restart task manager was black, but widgets and everything else looks the same. Widgets on my main account are still looking the same, without background and border. I tried changing themes but the widgets aren't different.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •