Results 1 to 8 of 8

Thread: No sound from Headphones

  1. #1

    Default No sound from Headphones

    Hi,

    My desktop computer is installed OPENSUSE 11.3. It can play audio CD, but no headphone and front mic, which are necessary for Skype. I have tried alsamixer, which cannot make front mic and headphone work. I find the following link:

    SDB:Intel-HDA sound problems - openSUSE

    But, I cannot follow it at all.
    1. At Yast/sound, there is no advanced configuration option.
    2. It means the following is the results of Yast/sound/Advance Configuration?

    options snd-hda-intel model=z71v position_fix=1
    # u1Nb.Iok8MET6hsF:82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller
    alias snd-card-0 snd-hda-intel


    I have checked alsamixer. There is no mic and headphone.


    At the restarting sound server section, it says to save "/etc/modprobe.d/50-sound.conf" (openSUSE >= 11.2). I do not understand who changes the file's content?

    Could you explain it to me?



    Thanks a lot.





    .........................

    No sound from Headphones

    If you have an Intel sound card which requires snd-hda-intel driver but do not have any sound when plugging in headphones, you are in the correct section. YaST2 should have created the /etc/modprobe.d/sound (openSUSE <= 11.1) or /etc/modprobe.d/50-sound.conf (openSUSE >= 11.2) file and it should contain the following (or something very similar):

    options snd slots=snd-hda-intel
    # u1Nb.Iok8MET6hsF:82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller
    alias snd-card-0 snd-hda-intel

    The driver problem occurs with every distribution so it is normal. Anyways, you are going to have to modify the options line either by directly editing the file, or using Yast's Sound Module - Advanced Configuration. The new file should look like the following (lines staring with a pound sign # are comments):

    options snd-hda-intel model=z71v position_fix=1
    # u1Nb.Iok8MET6hsF:82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller
    alias snd-card-0 snd-hda-intel

    That should do the trick. Now go to the "Restarting the sound server" section below.

    If after restarting the sound you still don't have any output from your headphones, make sure you un-muted the headphones using alsamixer (in command line) or your favorite graphical mixer (such as KMix).

    Note! On Sony Vaio FZ21M, you have to insert the following options:

    options snd-hda-intel model=vaio enable=1 index=0 position_fix=1




    [edit] Restarting the sound server

    Before restarting make sure to change ALSA settings such that Microphone channels are muted to prevent sound loopback and squealing sound. Not doing this might cause high and continuous beep sounds. One can do this using alsamixer.

    alsamixer

    Save the file /etc/modprobe.d/sound (openSUSE <= 11.1) or /etc/modprobe.d/50-sound.conf (openSUSE >= 11.2) after the changes and restart the soundsystem as root.

    rcalsasound restart

    You have to restart the mixer you use, so start as user kmix or gmix, depending on what windowmanager you use. Open the mixer and set all channels to medium and check if you can hear sound now.

  2. #2

    Default Re: No sound from Headphones

    Hi,
    Further information is added here.
    The content of 50-sound.conf is:

    options snd slots=snd-hda-intel
    # u1Nb.1iKcnAwVcq9ufferM-UL8E
    alias snd-card-0 snd-hda-intel

    The above mentioned example shows:

    options snd-hda-intel model=z71v position_fix=1
    # u1Nb.Iok8MET6hsF:82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller
    alias snd-card-0 snd-hda-intel

    Question here is: How can I know the 'model'? What is the meaning of 'position_fix=1'?

    The speaker (not the headphone) can play CD audio, the sound configuration of Yast can pass the "Test". How can I turn on headphone and front mic?

    Thanks again.

  3. #3
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: No sound from Headphones

    Use the mixer

    Are you using kde or gnome?
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  4. #4
    Join Date
    Jun 2008
    Location
    UK
    Posts
    5,500

    Default Re: No sound from Headphones

    Quote Originally Posted by freerjw View Post
    Hi,
    Further information is added here.
    The content of 50-sound.conf is:

    options snd slots=snd-hda-intel
    # u1Nb.1iKcnAwVcq9ufferM-UL8E
    alias snd-card-0 snd-hda-intel



    Question here is: How can I know the 'model'?
    First you need to know what Codec is required by your Intel device. If you don't know it already, open a terminal as root and enter the following command at the commandline:
    Code:
    head -n 1 /proc/asound/card0/codec*
    Look for the Codec name(s) in the output from that command, and post back here with it.

  5. #5

    Default Re: No sound from Headphones

    Hi,
    The codec is:

    ................
    g@linux-61xo:~> head -n 1 /proc/asound/card0/codec*
    Codec: Realtek ALC880
    ...............

    From the info:

    Module for Intel HD Audio (ICH6, ICH6M, ESB2, ICH7, ICH8),
    ATI SB450, SB600, RS600,
    VIA VT8251/VT8237A,
    SIS966, ULI M5461

    model - force the model name
    position_fix - Fix DMA pointer (0 = auto, 1 = none, 2 = POSBUF, 3 = FIFO size)
    probe_mask - Bitmask to probe codecs (default = -1, meaning all slots)
    single_cmd - Use single immediate commands to communicate with
    codecs (for debugging only)
    enable_msi - Enable Message Signaled Interrupt (MSI) (default = off)
    power_save - Automatic power-saving timtout (in second, 0 =
    disable)
    power_save_controller - Reset HD-audio controller in power-saving mode
    (default = on)

    This module supports one card and autoprobe.

    Each codec may have a model table for different configurations.
    If your machine isn't listed there, the default (usually minimal)
    configuration is set up. You can pass "model=<name>" option to
    specify a certain model in such a case. There are different
    models depending on the codec chip.

    Model name Description
    ---------- -----------
    ALC880
    3stack 3-jack in back and a headphone out
    3stack-digout 3-jack in back, a HP out and a SPDIF out
    5stack 5-jack in back, 2-jack in front
    5stack-digout 5-jack in back, 2-jack in front, a SPDIF out
    6stack 6-jack in back, 2-jack in front
    6stack-digout 6-jack with a SPDIF out
    w810 3-jack
    z71v 3-jack (HP shared SPDIF)
    asus 3-jack (ASUS Mobo)
    asus-w1v ASUS W1V
    asus-dig ASUS with SPDIF out
    asus-dig2 ASUS with SPDIF out (using GPIO2)
    ..................

    Can I insert the "model=5stack-digout" to:
    50-sound.conf?

    I have tried two times. Every time after reboot OPENSUSE, it says the audio driver is removed.

    I forget something else beside the model definition? or, I can continue try with other option, such as 6stack, etc..


    Thanks.

  6. #6
    Join Date
    Jun 2008
    Location
    UK
    Posts
    5,500

    Default Re: No sound from Headphones

    Quote Originally Posted by freerjw View Post
    Hi,
    The codec is:

    ................
    g@linux-61xo:~> head -n 1 /proc/asound/card0/codec*
    Codec: Realtek ALC880
    ...............

    ...

    Can I insert the "model=5stack-digout" to:
    50-sound.conf?
    When adding the "model=", do NOT change the existing lines! Add this additional line to the beginning of /etc/modprobe.d/50-sound.conf, exactly as for this example:
    Code:
    options snd-hda-intel model=5stack-digout
    You may have to try several (or all) model names to find the appropriate one for your hardware config, rebooting after each attempt. Try the most likely looking ones first. On your system, the available model options for ALC880 are probably documented in /usr/src/your-kernel-version/Documentation/sound/alsa/HD-Audio-Models.txt, if not found in /usr/src/your-kernel-version/Documentation/sound/alsa/ALSA-Configuration.txt

  7. #7

    Default Re: No sound from Headphones

    Hi,

    Thanks for all of you. The headphone works now, but the mic does not yet. The output of 'amixer' is at the below.
    What is wrong with the mic? I try several times without changing value '0' at the end of the first line beneath. Could you help me out the mic problem?

    Simple mixer control 'Front Mic',0
    Capabilities: pvolume pswitch penum
    Playback channels: Front Left - Front Right
    Limits: Playback 0 - 65









    ...............
    Simple mixer control 'Master',0
    Capabilities: pvolume pvolume-joined pswitch pswitch-joined penum
    Playback channels: Mono
    Limits: Playback 0 - 64
    Mono: Playback 64 [100%] [0.00dB] [on]
    Simple mixer control 'PCM',0
    Capabilities: pvolume penum
    Playback channels: Front Left - Front Right
    Limits: Playback 0 - 255
    Mono:
    Front Left: Playback 210 [82%] [-9.00dB]
    Front Right: Playback 210 [82%] [-9.00dB]
    Simple mixer control 'Front',0
    Capabilities: pvolume pswitch penum
    Playback channels: Front Left - Front Right
    Limits: Playback 0 - 64
    Mono:
    Front Left: Playback 59 [92%] [-5.00dB] [on]
    Front Right: Playback 59 [92%] [-5.00dB] [on]
    Simple mixer control 'Front Mic',0
    Capabilities: pvolume pswitch penum
    Playback channels: Front Left - Front Right
    Limits: Playback 0 - 65
    Mono:
    Front Left: Playback 62 [95%] [27.00dB] [on]
    Front Right: Playback 62 [95%] [27.00dB] [on]

  8. #8
    Join Date
    Jun 2008
    Location
    UK
    Posts
    5,500

    Default Re: No sound from Headphones

    Please answer the question raised by @caf4926 i.e. KDE or Gnome? or perhaps some other DE?

    Please post the exact contents of your /etc/modprobe.d/50-sound.conf showing the model that made the headphones work and currently in use for Front Mic.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •