Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: kdem defaults

  1. #1
    jdd NNTP User

    Default kdem defaults

    Hello,

    I just installed 11.4 on an old hard drive, probably with 11.3.

    All works well, but I can't get the nice icons for user login in kdm.

    Of course, I tried to change this in kde system config, but with no result. In fact what I do there do not change anything.

    I suspect some sort of permission problem, but how can I simply reset all the global kde settings (The problem arise before login)

    thanks
    jdd

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,973

    Default Re: kdem defaults

    I have no icons (nice or not) at all in my kdm login screen. You may elaborate bit on what you mean.
    Henk van Velden

  3. #3
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,763
    Blog Entries
    14

    Default Re: kdem defaults

    Quote Originally Posted by jdd View Post
    Hello,

    I just installed 11.4 on an old hard drive, probably with 11.3.

    All works well, but I can't get the nice icons for user login in kdm.

    Of course, I tried to change this in kde system config, but with no result. In fact what I do there do not change anything.

    I suspect some sort of permission problem, but how can I simply reset all the global kde settings (The problem arise before login)

    thanks
    jdd
    Open a terminal window and do:
    Code:
    kdesu systemsettings
    The parts that are greyed out for the user, now are accessible. On the tab "Users" you'll find what you need.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  4. #4
    jdd NNTP User

    Default Re : Re: kdem defaults

    Quote Originally Posted by hcvv View Post
    I have no icons (nice or not) at all in my kdm login screen. You may elaborate bit on what you mean.
    You should have :-) - it's default.

    A column in the left part of the screen with avatars for the authorized users. Clicking on then allow to enter the login and push the cursor on the passwd field.

    This is managed in kde, system config, connect screen, users

    On this computer this do not work. In fact, I can make no change to the login screen (not even changing theme)

  5. #5
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,973

    Default Re: Re : Re: kdem defaults

    You may be right. It might be one of those things I switch off instantly and then remove the existance of such humbug from my mind. I do need no users on my system who can not type their username because they cannot remember it, or can not type at all. But do not listen to me, I am one of those who find desktop effects disgusting.
    Henk van Velden

  6. #6
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,763
    Blog Entries
    14

    Default Re: Re : Re: kdem defaults

    Quote Originally Posted by hcvv View Post
    But do not listen to me, I am one of those who find desktop effects disgusting.
    Then, Henk, GNOME 3. Nice, slick, except for some very small thingies no desktop effects.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  7. #7
    jdd NNTP User

    Default Re : Re: kdem defaults

    Quote Originally Posted by Knurpht View Post
    Open a terminal window and do:
    Code:
    kdesu systemsettings
    The parts that are greyed out for the user, now are accessible. On the tab "Users" you'll find what you need.
    Of course not, it don't works. It's not necessary to use kdesu (in fact this do not work at all), only to launch control center and give the root passwd when asked.

    But it's precisely what do not work on this computer. I tried to remove /root/.kde4 but this didn't change anything. In fact settings *are* kept like they have to be, simply the system do not use them.

    I can just chage some settings in /etc/sysconfig/displaymanager

  8. #8
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,973

    Default Re: Re : Re: kdem defaults

    Apart from your problem: it is of no use to move /root/.kde4. That will only be used when you login in the GUI as root, which one should never do.
    Henk van Velden

  9. #9
    jdd NNTP User

    Default Re : Re: Re : Re: kdem defaults

    Quote Originally Posted by hcvv View Post
    Apart from your problem: it is of no use to move /root/.kde4. That will only be used when you login in the GUI as root, which one should never do.
    well... when trying "kdesu systemsettings" from an user terminal, I got a message "impossible to write to /root/.kde4/...", so I wonder if the globals where stored there. I could verify than no.

    Notice also that trying kdesu systemsettings from this computer did not work well, I couldn't get the sub-menu login manager, when I can have it on my usual computer, so may be there is more broken than just the login screen.

    I remember an old bug about control settings not working, I may have to search old bugzilla

    thanks

  10. #10
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,973

    Default Re: kdem defaults

    It is a bit about using words IMHO. The KDE systemsettings are basicaly no system settings at all. They are the Desktop settings of the user. Thus when you run it as root, it wants to change the system (read: Destop) settings of root and that is not what you want (I hope).

    But when you are in those settings (as normal user) you will findd that some of them are no user settings at all (like changing kdm or managiing system wide fonts or using YaST) and then the root password will be asked. The problem here is that these settings are mixed and it is only after the root password is asked for that you realise (I hope) that you asked for something that is indeed out of range for a normal user).
    Henk van Velden

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •