Results 1 to 8 of 8

Thread: setting samba with YaST then authentication fails 11.4

  1. #1

    Default setting samba with YaST then authentication fails 11.4

    I am able to see my samba shares on a windows xp machine, but the username/password combination fails.
    I setup samba with YaST.
    firewall is disabled.

  2. #2
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,727
    Blog Entries
    2

    Default Re: setting samba with YaST then authentication fails 11.4

    Let's have a quick look under the hood, please post here the contents of the config file (smb.conf) located at /etc/samba/smb.conf
    Leap 42.3 & 15.1(Beta) &KDE
    FYIs from the days of yore

  3. #3
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,727
    Blog Entries
    2

    Default Re: setting samba with YaST then authentication fails 11.4

    PS just to be thorough, what do you get when you issue these two commands in a terminal window:
    su -c "rcnmb status;rcsmb status"
    su -c "pdbedit -L"
    Last edited by swerdna; 03-Sep-2011 at 06:04.
    Leap 42.3 & 15.1(Beta) &KDE
    FYIs from the days of yore

  4. #4
    Join Date
    May 2011
    Location
    Lublin, Poland
    Posts
    224

    Default Re: setting samba with YaST then authentication fails 11.4

    Remember to delete smbd and nmbd (or something like that ) profiles in AppArmor (using YaST)
    Otherwise samba won't work properly.
    Desktop: Intel Q8300@3,3Ghz, 4GB RAM, Foxconn P35A, Sapphire HD5670, OpenSUSE x64
    Server: Via C3@1.4Ghz, 768MB RAM, 8GB Microdrive + OpenSuSE x86
    and other boxes running Windoze

  5. #5

    Default Re: setting samba with YaST then authentication fails 11.4

    Code:
    # smb.conf is the main Samba configuration file. You find a full commented
    # version at /usr/share/doc/packages/samba/examples/smb.conf.SUSE if the
    # samba-doc package is installed.
    # Date: 2011-03-01
    [global]
    	workgroup = WORKGROUP
    	passdb backend = tdbsam
    	printing = cups
    	printcap name = cups
    	printcap cache time = 750
    	cups options = raw
    	map to guest = Bad User
    	include = /etc/samba/dhcp.conf
    	logon path = \\%L\profiles\.msprofile
    	logon home = \\%L\%U\.9xprofile
    	logon drive = P:
    	usershare allow guests = Yes
    	add machine script = /usr/sbin/useradd  -c Machine -d /var/lib/nobody -s /bin/false %m$
    	domain logons = No
    	domain master = No
    	security = user
    	usershare max shares = 100
    	wins support = No
    	ldap suffix = 
    	wins server = 
    
    ## Share disabled by YaST
    # [homes]
    #	comment = Home Directories
    #	valid users = %S, %D%w%S
    #	browseable = No
    #	read only = No
    #	inherit acls = Yes
    [profiles]
    	comment = Network Profiles Service
    	path = %H
    	read only = No
    	store dos attributes = Yes
    	create mask = 0600
    	directory mask = 0700
    
    [users]
    	comment = All users
    	path = /home
    	read only = No
    	inherit acls = Yes
    	veto files = /aquota.user/groups/shares/
    [groups]
    	comment = All groups
    	path = /home/groups
    	read only = No
    	inherit acls = Yes
    [printers]
    	comment = All Printers
    	path = /var/tmp
    	printable = Yes
    	create mask = 0600
    	browseable = No
    [print$]
    	comment = Printer Drivers
    	path = /var/lib/samba/drivers
    	write list = @ntadmin root
    	force group = ntadmin
    	create mask = 0664
    	directory mask = 0775
    
    ## Share disabled by YaST
    # [netlogon]
    both daemons a running but this command :su -c "pdbedit -L": yields no output.

  6. #6
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,727
    Blog Entries
    2

    Default Re: setting samba with YaST then authentication fails 11.4

    The [groups] share directs to a directory (/home/groups) that simply doesn't exist, so can ignore it.
    The [homes] share exists and is accessible provided the various users have their credentials added to the Samba password database, run this command to add a user e.g. william to the database: sudo smbpasswd -a william
    This is for existing Linux users. Each user who is in the database can then access his/her home directories on addresses like this from windows: \\servername\william

    The [users] share also needs names to be first added to the samba user database
    Last edited by swerdna; 03-Sep-2011 at 15:56.
    Leap 42.3 & 15.1(Beta) &KDE
    FYIs from the days of yore

  7. #7
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,727
    Blog Entries
    2

    Default Re: setting samba with YaST then authentication fails 11.4

    Leap 42.3 & 15.1(Beta) &KDE
    FYIs from the days of yore

  8. #8

    Default Re: setting samba with YaST then authentication fails 11.4

    'sudo smbpasswd -a username' worked for me.
    thank you.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •