Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: Java 6u27 and Firefox 6

  1. #1

    Default Java 6u27 and Firefox 6

    Hi!

    I have openSuse11.4 x64 and FireFox 6.0.

    Is there a way to update Java to latest version. Guides given on Java web site doesn't work, tutorials foun on Google also don't work.

    I updated to 6u22 but thats it.

    Firefox founds only 6u22.

    Help.

  2. #2
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: Java 6u27 and Firefox 6

    kojo1984 wrote:

    >
    > Hi!
    >
    > I have openSuse11.4 x64 and FireFox 6.0.
    >
    > Is there a way to update Java to latest version. Guides given on Java
    > web site doesn't work, tutorials foun on Google also don't work.
    >
    > I updated to 6u22 but thats it.
    >
    > Firefox founds only 6u22.
    >
    > Help.
    >

    Simply install the java-1_6_0-sun packages with zypper or yast and uninstall
    openjdk, then you will have it (the version numbering for openjdk is
    slightly different by the way).

    --
    PC: oS 11.4 64 bit | Intel Core i7-2600@3.40GHz | KDE 4.6.0 | GeForce GT 420
    | 16GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.6.5 | nVidia
    ION | 3GB Ram

  3. #3
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: Java 6u27 and Firefox 6

    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  4. #4

    Default Re: Java 6u27 and Firefox 6

    Done as told, and yes, I do get Java-sun 6u26 when checking in Firefox on java.com: Java + You.

    But I want to download and install latest version 6u27 from Java web site and include it in Firefox...

  5. #5
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: Java 6u27 and Firefox 6

    On 08/31/2011 08:46 AM, kojo1984 wrote:
    >
    > Done as told, and yes, I do get Java-sun 6u26 when checking in Firefox
    > on 'java.com: Java + You' (http://www.java.com).


    in firefox location type aboutlugins and hit enter...scroll down to
    the Java Plugin, you should see "Java(TM) Plug-in 1.6.0_26" which is the
    latest available from the openSUSE repos for openSUSE 11.4, what do you see?

    if, as you say, you see only "Java(TM) Plug-in 1.6.0_22" then something
    is wrong with your selection of repos, so please show us the output of
    entering the following into a terminal

    Code:
    zypper lr -d
    and copy/paste the output back to this thread using the instructions
    here: http://goo.gl/i3wnr

    > But I want to download and install latest version 6u27 from Java web
    > site and include it in Firefox...


    but, if you see "Java(TM) Plug-in 1.6.0_26" like i do, then why do you
    want to install the tiny step difference from 1.6.0_26-0.2.1 to
    1.6.0_27? what features are you missing in 26 that you must have?

    --
    DD
    openSUSE®, the "German Engineered Automobile" of operating systems!

  6. #6

    Default Re: Java 6u27 and Firefox 6

    Quote Originally Posted by DenverD View Post
    On 08/31/2011 08:46 AM, kojo1984 wrote:
    >
    > Done as told, and yes, I do get Java-sun 6u26 when checking in Firefox
    > on 'java.com: Java + You' (java.com: Java + You).


    in firefox location type aboutlugins and hit enter...scroll down to
    the Java Plugin, you should see "Java(TM) Plug-in 1.6.0_26" which is the
    latest available from the openSUSE repos for openSUSE 11.4, what do you see?

    if, as you say, you see only "Java(TM) Plug-in 1.6.0_22" then something
    is wrong with your selection of repos, so please show us the output of
    entering the following into a terminal

    Code:
    zypper lr -d
    and copy/paste the output back to this thread using the instructions
    here: Posting in Code Tags - A Guide

    > But I want to download and install latest version 6u27 from Java web
    > site and include it in Firefox...


    but, if you see "Java(TM) Plug-in 1.6.0_26" like i do, then why do you
    want to install the tiny step difference from 1.6.0_26-0.2.1 to
    1.6.0_27? what features are you missing in 26 that you must have?

    --
    DD
    openSUSE®, the "German Engineered Automobile" of operating systems!
    In Firefox "aboutlugins" says "Java(TM) Plug-in 1.6.0_26".

    There is no feature that I'm missing. I want to know how to install it manually.

  7. #7
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: Java 6u27 and Firefox 6

    kojo1984 wrote:
    > In Firefox "aboutlugins" says "Java(TM) Plug-in 1.6.0_26".
    >
    > There is no feature that I'm missing. I want to know how to install it
    > manually.
    >

    There are two simple options. Wait for the update (the java updates will be
    in the openSUSE repositories for java sooner or later) or follow the
    description from oracle:
    http://www.java.com/en/download/linu....jsp?locale=en
    What's the problem with it, a rpm is provided by them?
    Or is your question how to install a rpm?

    --
    PC: oS 11.4 64 bit | Intel Core i7-2600@3.40GHz | KDE 4.6.0 | GeForce GT 420
    | 16GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.6.5 | nVidia
    ION | 3GB Ram

  8. #8

    Default Re: Java 6u27 and Firefox 6

    Quote Originally Posted by martin_helm View Post
    kojo1984 wrote:
    > In Firefox "aboutlugins" says "Java(TM) Plug-in 1.6.0_26".
    >
    > There is no feature that I'm missing. I want to know how to install it
    > manually.
    >

    There are two simple options. Wait for the update (the java updates will be
    in the openSUSE repositories for java sooner or later) or follow the
    description from oracle:
    Download Java software for Linux
    What's the problem with it, a rpm is provided by them?
    Or is your question how to install a rpm?

    --
    PC: oS 11.4 64 bit | Intel Core i7-2600@3.40GHz | KDE 4.6.0 | GeForce GT 420
    | 16GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.6.5 | nVidia
    ION | 3GB Ram
    I install everything... I get "Package jre-1.**** is already installed".

    But part "Enable and Configure" is making problems. Can't find files and folders where it states they should be. That is part when enablin Java for firefox

  9. #9
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: Java 6u27 and Firefox 6

    I simply downloaded and installed now the bin installer for java from oracle
    as it is described in the link I sent before.

    The jre does not conflict with the existing one since it is installed into a
    separate directory (on my machine I can see it is in /usr/java/jre1.6.0_27).
    Checked with
    Code:
    martinh@ganymed:~> rpm -qa 'jre*'
    jre-1.6.0_27-fcs.x86_64
    martinh@ganymed:~> rpm -ql jre-1.6.0_27-fcs.x86_64
    /etc
    /etc/.java
    /etc/.java/.systemPrefs
    /etc/.java/.systemPrefs/.system.lock
    /etc/.java/.systemPrefs/.systemRootModFile
    /etc/init.d/jexec
    /usr
    /usr/java
    /usr/java/jre1.6.0_27
    /usr/java/jre1.6.0_27/COPYRIGHT
    /usr/java/jre1.6.0_27/LICENSE
    /usr/java/jre1.6.0_27/README
    /usr/java/jre1.6.0_27/THIRDPARTYLICENSEREADME.txt
    /usr/java/jre1.6.0_27/Welcome.html
    /usr/java/jre1.6.0_27/bin
    <snip much more>
    To check if the java works at all I tested with to show the version
    Code:
    martinh@ganymed:~> /usr/java/jre1.6.0_27/bin/java -version
    java version "1.6.0_27"
    Java(TM) SE Runtime Environment (build 1.6.0_27-b07)
    Java HotSpot(TM) 64-Bit Server VM (build 20.2-b06, mixed mode)
    After that I went to the browser plugins directory (/usr/lib64/browser-
    plugins) and removed the existing javaplugin.so (as root) and created a new
    symbolic link for the new luibnpjp2.so
    Code:
    cd /usr/lib64/browser-plugins
    sudo rm javaplugin.so
    sudo cp -s /usr/java/jre1.6.0_27/lib/amd64/libnpjp2.so javaplugin.so
    restarted firefox and went to the testpage which shows now (Version 6 Update
    27).
    No idea if thats the best way to do it, it's just a quick and dirty way to
    check if it works and it does.

    --
    PC: oS 11.4 64 bit | Intel Core i7-2600@3.40GHz | KDE 4.6.0 | GeForce GT 420
    | 16GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.6.5 | nVidia
    ION | 3GB Ram

  10. #10
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: Java 6u27 and Firefox 6

    On 08/31/2011 10:46 AM, kojo1984 wrote:
    > I install everything... I get "Package jre-1.**** is already
    > installed".


    did you follow the part of the instructions which said in *red* letters:
    "We highly recommend users remove all older versions of Java from your
    system." <http://www.java.com/en/download/faq/remove_olderversions.xml>

    but, do NOT try to remove your existing by following the later
    underlined "the instructions on Java uninstallation instructions for
    Windows page."

    but, i'd advise you to use _26 and follow the rule: If it ain't broke,
    don't fix it. (you said you don't miss any features with _26, so ??)

    of course, it IS your machine and you can fix it as often as you
    wish...anyway, some folks say: If it ain't broke you ain't trying hard
    enough.

    --
    DD Caveat
    openSUSE®, the "German Engineered Automobile" of operating systems!

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •