Results 1 to 3 of 3

Thread: Kmail linking to firefox

  1. #1

    Default Kmail linking to firefox

    I' m sure there's a simple solution to this.

    I'm using Opensuse11.4 and have kmail and Firefox. When I click a url: link in kmail it opens a new tab in Firefox. The problem is that the url is linked to my temp cache files as this

    file:///var/tmp/kdecache-terry/krun/1589.0.ctt

    The tab this opens has most of the link icons stripped out and the links to other parts of the website don't work and I get a "file not found" error and the link is to a file which doesn't exist

    file:///contribute.php3

    This is only a minor annoyance as I can right click > copy the url and paste it to the address bar in Firefox then it works ok. I don't think it anything in either programme that's broken because this happened after an update to Opensuse 11.4 on my previous laptop and has happened again on my new laptop with a fresh install.

    Thanks for any suggestions.

  2. #2
    Join Date
    Oct 2008
    Location
    Glasgow, Scotland
    Posts
    1,131

    Default Re: Kmail linking to firefox

    I do not see this annoyance when I change my default browser to Firefox. (System Settings > Default Applications)
    But this installation is non-standard.

    Do you have "mozilla-kde4-integration" installed?


    openSuSE-11.4
    kernel-desktop-3.03
    Kmail/Korg/Kontact/Kdepim4 &c. from KDE-4.6.5
    KDE-4.7.0
    MozillaFirefox-3.6.20

  3. #3

    Default Re: Kmail linking to firefox

    Hello eng-int thanks for the reply. your mentioning System Settings > Default Applications gave me the clue. some time ago I dumped the original Opensuse version of Firefox and installed a downloaded Firefox 6 I think one interfered with the other in this case.

    I changed the Default app from "firefox" to "open in application based on content of URL" which opened it correctly in konqueror. I then changed back to "in the following browser" and changed "firefox" to the full path to /home/terry/.mozilla/firefox/firefox this seems to have worked.

    Thanks again.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •