Results 1 to 7 of 7

Thread: Gnome 3 is in fallback mode

  1. #1
    Join Date
    Jun 2008
    Location
    Bay Area, California
    Posts
    339

    Default Gnome 3 is in fallback mode

    Using the Nvidia driver from the repo on a Geforce 6800gs. In Kde4 all 3d applications seem to be working properly so I don't know why Gnome 3 is doing that myself. It wasn't working at all at one point and I am assuming that some update or another got it going. Perhaps a repo switch. Unfortunately I am not sure of what those changes may be. I just know that it does run now but only in fallback.

    Any help? What else would you like to know?

  2. #2

    Default Re: Gnome 3 is in fallback mode

    Can you try compositor? - btw it would tell me if it's working for Gnome3 under openSUSE (it works on ArchLinux and Fedora).
    When you type compositor in Gnome3, it toggles between gnome-fallback and gnome-shell (you have to log out/log in). Under Kde or Gnome2, it switchs compositiong on/off immediately. It won't probably solve your problem. But it might tell you if its a gnome configuration or driver issue. For me, gnome-shell doesn't work on a dual screen system with nvidia (but kde desktop effects don't work either on this machine).

  3. #3
    Join Date
    Nov 2008
    Location
    Farpoint Station
    Posts
    77

    Default Re: Gnome 3 is in fallback mode

    Quote Originally Posted by Scott_Swinyard View Post
    Using the Nvidia driver from the repo on a Geforce 6800gs. In Kde4 all 3d applications seem to be working properly so I don't know why Gnome 3 is doing that myself. It wasn't working at all at one point and I am assuming that some update or another got it going. Perhaps a repo switch. Unfortunately I am not sure of what those changes may be. I just know that it does run now but only in fallback.

    Any help? What else would you like to know?
    I had a similar problem and fixed it by installing the latest nVidia driver from nVidia's site. Here's link to the thread on the subject:

    11.4 - Cannot install nvidia driver

    HTH

  4. #4
    Join Date
    Jun 2008
    Location
    Bay Area, California
    Posts
    339

    Default Re: Gnome 3 is in fallback mode

    O.K. I'll run compositor, but I need to install it first? I had some repo of yours installed at one point but removed it to clean up a crazy mess in there. You have a link to the repo with compositor in it so I can use Yast to install it?

  5. #5

    Default Re: Gnome 3 is in fallback mode

    Quote Originally Posted by Scott_Swinyard View Post
    O.K. I'll run compositor, but I need to install it first? I had some repo of yours installed at one point but removed it to clean up a crazy mess in there. You have a link to the repo with compositor in it so I can use Yast to install it?
    Yes, compositor is included in conkyconf. Installing conkyconf from my repo will put compositor in /usr/bin.

    Code:
    su -l
    zypper ar http://download.opensuse.org/repositories/home:/please_try_again/openSUSE_11.4/ PTA
    zypper refresh -r PTA
    zypper in conkyconf
    But if you're not using conky you should rather remove /etx/xdg/autostart/conky.desktop (Actually, I'm not sure this file is a good idea, I might remove it in the next release).

    If you want to disable my repo afterwards - without deinstalling it - just do:
    Code:
    zypper mr -d PTA

  6. #6

    Default Re: Gnome 3 is in fallback mode

    But to just use compositor, it seems more reasonable to copy/paste the code posted here compositor: quickly sets/unsets compositing (helps with fullscreen Flash on ATI) in a file that you would call 'compositor' and put in /usr/bin. Then make this file executable with this command:

    Code:
    su -c '/bin/chmod 755 /usr/bin/compositor'
    I can imagine that installing the latest nvidia driver might solve the problem.

  7. #7
    Join Date
    Jun 2008
    Location
    Bay Area, California
    Posts
    339

    Default Re: Gnome 3 is in fallback mode

    I want to say thank you for the help and tell you that I found out that somehow Gnome shell wasn't installed and putting it in fixed it.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •