Results 1 to 4 of 4

Thread: Pitivi doesn't start

  1. #1

    Default Pitivi doesn't start

    Hi,

    I get an error message when I run pitivi 0.14.2 from the command line:

    ("PyGTK couldn't be found !", 'could not import gobject (could not find _PyGObject_API object)')
    Running it from the application window it of course doesn't start at all nor gives any error messages.

    How can I get it to run?


    Thanks.

  2. #2
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,517
    Blog Entries
    37

    Default Re: Pitivi doesn't start

    Quote Originally Posted by linux500suse View Post

    I get an error message when I run pitivi 0.14.2 from the command line:
    Code:
    ("PyGTK couldn't be found !", 'could not import gobject (could not find _PyGObject_API object)')

    Running it from the application window it of course doesn't start at all nor gives any error messages.

    How can I get it to run?
    Where did you get the rpm from ? Its not in the standard repositories (OSS, non-OSS, Update). Nor is it in packman. Possibly from some Gnome repos ? Beware of packages whose spec files are incomplete for pulling in all required dependencies. You could contact the rpm packager !

    Also, my apologies for asking the obvious (so no flames please), but I think it needs to be asked. ... Since the error is telling you it can not find "PyGTK", did you look to see if that was installed ? "Py" stands for python.

    ... so look for a package called 'python-gtk' and see if that is installed. .... Again, I don't use piviti, I'm simply reading the error message you posted.

  3. #3
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,644
    Blog Entries
    14

    Default Re: Pitivi doesn't start

    To add to @oldcpu's info: on messages like that, open Software Management, search for "pygtk" with the option "RPM provides" checked. That indeed brings up the package "python-gtk" in this case.

  4. #4

    Default Re: Pitivi doesn't start

    I added all community repos. Most likely it got it from the Pacman repo.

    Yes I have python-gtk installed. And pygtk which is within one of the installed python packages.

    I installed in addition some the devel packages that the search "pygtk" with "RPM provides" has. But no luck.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •