Results 1 to 8 of 8

Thread: KDE: apps that not start with alt+f2

  1. #1

    Default KDE: apps that not start with alt+f2

    Dear all,
    I have noticed that are a few applications (non part of the kde apps) that do not launch with alt + f2 (command name). Instead I have to use konsole first and write the command name, then the apps appears successfully.

    The same problem I have of course with the same apps if I make a desktop shorcut. These apps never show up!
    Thus I would like to ask you what should I do to make these shortcuts and alt+f2 launches to work.

    I would like to thank you in advance for your help

    B.R
    Alex

  2. #2
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,438
    Blog Entries
    14

    Default Re: KDE: apps that not start with alt+f2

    Could you give an example, so others can test this? Tell us your openSUSE version, KDE version?

    The PATH variable should be the same for both options, i.e. Alt-F2 or konsole.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  3. #3
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: KDE: apps that not start with alt+f2

    On 08/22/2011 11:36 AM, Knurpht wrote:

    > Could you give an example, so others can test this? Tell us your
    > openSUSE version, KDE version?


    in addition, lets say the example you give in response to the above is
    'example', then please show us the output of

    Code:
    which example

    > The PATH variable should be the same for both options, i.e. Alt-F2 or
    > konsole.


    have you made any changes to
    /etc/bash.bashrc
    /etc/bash.bashrc.local
    ~/.bashrc

    and, last: are you logged into KDE as root when you see this behavior?

    --
    DD
    openSUSE®, the "German Engineered Automobile" of operating systems!

  4. #4

    Default Re: KDE: apps that not start with alt+f2

    which matlab
    /usr/bin/matlab


    I have not change any of these files

  5. #5
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: KDE: apps that not start with alt+f2

    On 08/23/2011 03:26 PM, alaios wrote:
    >
    > which matlab
    > /usr/bin/matlab
    >
    >
    > I have not change any of these files


    i have just seen your enabled repos in
    http://forums.opensuse.org/showthread.php?t=464432
    and suggest your problem in this thread is NOT your biggest
    problem...solve the other, and get your repos under control...and, maybe
    this little problem might go away!


    --
    DD
    openSUSE®, the "German Engineered Automobile" of operating systems!

  6. #6

    Default Re: KDE: apps that not start with alt+f2

    Thanks a lot.
    I will check it and post back

  7. #7

    Default Re: KDE: apps that not start with alt+f2

    Quote Originally Posted by DenverD View Post
    On 08/22/2011 11:36 AM, Knurpht wrote:

    > Could you give an example, so others can test this? Tell us your
    > openSUSE version, KDE version?


    in addition, lets say the example you give in response to the above is
    'example', then please show us the output of

    Code:
    which example

    > The PATH variable should be the same for both options, i.e. Alt-F2 or
    > konsole.


    have you made any changes to
    /etc/bash.bashrc
    /etc/bash.bashrc.local
    ~/.bashrc

    and, last: are you logged into KDE as root when you see this behavior?

    --
    DD
    openSUSE®, the "German Engineered Automobile" of operating systems!
    I have not changed any of these files ever. I am not logged as root I have also fixed my repositories.
    also ls -l /usr/bin/matlab
    lrwxrwxrwx 1 root root 29 Jan 28 2011 /usr/bin/matlab -> /opt/MATLAB/R2010b/bin/matlab

    the matlab screen appears (loading screen) but after that it dissapears and I can not see the main window.
    If I run it through console everything works fine.
    B.R
    Alex

  8. #8
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: KDE: apps that not start with alt+f2

    On 09/28/2011 02:36 PM, alaios wrote:
    >
    > DenverD;2377089 Wrote:
    >> On 08/22/2011 11:36 AM, Knurpht wrote:
    >>
    >>> Could you give an example, so others can test this? Tell us your
    >>> openSUSE version, KDE version?

    >>
    >> in addition, lets say the example you give in response to the above is
    >> 'example', then please show us the output of
    >>
    >>>

    > Code:
    > --------------------
    > > >

    > > which example
    > >

    > --------------------
    >>>

    >>
    >>
    >>> The PATH variable should be the same for both options, i.e. Alt-F2

    >> or
    >>> konsole.

    >>
    >> have you made any changes to
    >> /etc/bash.bashrc
    >> /etc/bash.bashrc.local
    >> ~/.bashrc
    >>
    >> and, last: are you logged into KDE as root when you see this
    >> behavior?
    >>
    >> --
    >> DD
    >> openSUSE®, the "German Engineered Automobile" of operating systems!

    > I have not changed any of these files ever. I am not logged as root I
    > have also fixed my repositories.
    > also ls -l /usr/bin/matlab
    > lrwxrwxrwx 1 root root 29 Jan 28 2011 /usr/bin/matlab ->
    > /opt/MATLAB/R2010b/bin/matlab


    please show the input and output of
    Code:
    ls -l /opt/MATLAB/R2010b/bin/matlab

    >
    > the matlab screen appears (loading screen) but after that it dissapears
    > and I can not see the main window.


    > If I run it through console everything works fine.


    then how about a simple script that you can attach an icon/link to and
    click your matlab to life? something like:

    [/code]
    #!/bin/sh
    # hack to launch matlab from a script
    /usr/bin/matlab
    exit
    [/code]

    put that in a file name something, maybe math, make it executable and
    then figure out how to put it on your desktop, or in your menu
    system....or, if it is in the PATH you should be able to use Alt+F2 and
    you should be able to launch it with math

    --
    DD
    Caveat
    openSUSE®, the "German Automobiles" of operating systems

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •