Results 1 to 9 of 9

Thread: Where can I find Clementine or Amarok 1.4 RPM ?

  1. #1
    Join Date
    Nov 2008
    Location
    Ladysmith, BC, Canada
    Posts
    324

    Talking Where can I find Clementine or Amarok 1.4 RPM ?

    Title says it all. I have an OpenSuse 11.2 KDE 4 64 bit system. I'd like to run Clementine as an audio player but can't find an RPM that will install on my system. Please don't suggest I update to 11.4 since KDEPIM is still unusable in that version. (11.2 is the latest version with a fully functional KDEPIM including distribution lists) I'd gladly install Amarok 1.4 but then I'd need to add KDE3 to this system. I think.

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,121
    Blog Entries
    15

    Default Re: Where can I find Clementine or Amarok 1.4 RPM ?

    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,453

    Default Re: Where can I find Clementine or Amarok 1.4 RPM ?


  4. #4

    Default Re: Where can I find Clementine or Amarok 1.4 RPM ?

    in 11.2 packages i have 32bit rpms of them only.....

  5. #5
    Join Date
    Nov 2008
    Location
    Ladysmith, BC, Canada
    Posts
    324

    Default Re: Where can I find Clementine or Amarok 1.4 RPM ?

    I tried to do that but the instructions are kind of vague. Where do I actually extract the source files to ? I'm not accustomed to doing this, as you may realize.

  6. #6
    Join Date
    Nov 2008
    Location
    Ladysmith, BC, Canada
    Posts
    324

    Default Re: Where can I find Clementine or Amarok 1.4 RPM ?

    Quote Originally Posted by john_hudson View Post
    Doesn't exist for 11.2. When I try an 11.4 or 11.3 version, if fails with missed dependencies.

  7. #7
    Join Date
    Nov 2008
    Location
    Ladysmith, BC, Canada
    Posts
    324

    Default Re: Where can I find Clementine or Amarok 1.4 RPM ?

    I tried to compile but I keep getting errors and it doesn't complete.

    Can you tell what I need to change? Here is the printout from the last time:

    rsmits@linux-9pjy:~> cd clementine-0.7.1
    rsmits@linux-9pjy:~/clementine-0.7.1> cmake ../
    -- The C compiler identification is GNU
    -- The CXX compiler identification is GNU
    -- Check for working C compiler: /usr/bin/gcc
    -- Check for working C compiler: /usr/bin/gcc -- works
    -- Detecting C compiler ABI info
    -- Detecting C compiler ABI info - done
    -- Check for working CXX compiler: /usr/bin/c++
    -- Check for working CXX compiler: /usr/bin/c++ -- works
    -- Detecting CXX compiler ABI info
    -- Detecting CXX compiler ABI info - done
    -- Looking for Q_WS_X11
    -- Looking for Q_WS_X11 - found
    -- Looking for Q_WS_WIN
    -- Looking for Q_WS_WIN - not found.
    -- Looking for Q_WS_QWS
    -- Looking for Q_WS_QWS - not found.
    -- Looking for Q_WS_MAC
    -- Looking for Q_WS_MAC - not found.
    -- Found Qt-Version 4.5.3
    -- Found OpenSSL: /usr/lib64/libssl.so
    -- Looking for _POSIX_TIMERS
    -- Looking for _POSIX_TIMERS - found
    -- Looking for XOpenDisplay in /usr/lib64/libX11.so;/usr/lib64/libXext.so
    -- Looking for XOpenDisplay in /usr/lib64/libX11.so;/usr/lib64/libXext.so - found
    -- Looking for gethostbyname
    -- Looking for gethostbyname - found
    -- Looking for connect
    -- Looking for connect - found
    -- Looking for remove
    -- Looking for remove - found
    -- Looking for shmat
    -- Looking for shmat - found
    -- Looking for IceConnectionNumber in ICE
    -- Looking for IceConnectionNumber in ICE - found
    -- Found X11: /usr/lib64/libX11.so
    -- Boost version: 1.39.0
    -- Found the following Boost libraries:
    -- checking for module 'taglib>=1.6'
    -- package 'taglib>=1.6' not found
    CMake Error at /usr/share/cmake/Modules/FindPkgConfig.cmake:270 (message):
    A required package was not found
    Call Stack (most recent call first):
    /usr/share/cmake/Modules/FindPkgConfig.cmake:322 (_pkg_check_modules_internal)
    CMakeLists.txt:50 (pkg_check_modules)


    -- checking for module 'gstreamer-0.10'
    -- found gstreamer-0.10, version 0.10.24
    -- checking for module 'gstreamer-base-0.10'
    -- found gstreamer-base-0.10, version 0.10.24
    -- checking for module 'glib-2.0'
    -- found glib-2.0, version 2.22.4
    -- checking for module 'libxml-2.0'
    -- found libxml-2.0, version 2.7.3
    -- checking for module 'gobject-2.0'
    -- found gobject-2.0, version 2.22.4
    -- checking for module 'libgpod-1.0>=0.7.92'
    -- package 'libgpod-1.0>=0.7.92' not found
    -- checking for module 'gio-2.0'
    -- found gio-2.0, version 2.22.4
    -- checking for module 'libimobiledevice-1.0'
    -- package 'libimobiledevice-1.0' not found
    -- checking for module 'libplist'
    -- package 'libplist' not found
    -- checking for module 'libusbmuxd'
    -- package 'libusbmuxd' not found
    -- checking for module 'libmtp>=1.0'
    -- found libmtp, version 1.0.1
    -- checking for module 'indicate-qt'
    -- package 'indicate-qt' not found
    -- checking for module 'libarchive'
    -- package 'libarchive' not found
    -- Found PythonLibs: /usr/lib64/python2.6/config/libpython2.6.a
    -- Looking for include files CMAKE_HAVE_PTHREAD_H
    -- Looking for include files CMAKE_HAVE_PTHREAD_H - found
    -- Looking for pthread_create in pthreads
    -- Looking for pthread_create in pthreads - not found
    -- Looking for pthread_create in pthread
    -- Looking for pthread_create in pthread - found
    -- Found Threads: TRUE
    -- Performing Test SUPPORTS_OPENMP
    -- Performing Test SUPPORTS_OPENMP - Success
    -- checking for module 'gnutls'
    -- package 'gnutls' not found
    -- Building static qsqlite plugin
    -- Performing Test SUPPORTS_NOBOOL
    -- Performing Test SUPPORTS_NOBOOL - Success

    The following components will be built:
    devices: DeviceKit backend
    devices: MTP support
    devices: GIO backend
    D-Bus support
    Wiimote support
    Visualisations

    The following components WILL NOT be built:
    devices: iPod classic support
    devices: iPod Touch, iPhone, iPad support
    Gnome sound menu integration
    Last.fm support
    (Mac OS X) Sparkle integration
    (unstable) Scripting support: loading archives
    (unstable) Scripting support: Python
    (unstable) Remote control support

    -- Configuring incomplete, errors occurred!
    rsmits@linux-9pjy:~/clementine-0.7.1> ^C
    rsmits@linux-9pjy:~/clementine-0.7.1>

  8. #8
    Join Date
    Nov 2008
    Location
    Ladysmith, BC, Canada
    Posts
    324

    Default Re: Where can I find Clementine or Amarok 1.4 RPM ?

    As a followup, I found file gnutls-2.4.1-26.2.x86_64.rpm and tried to install it, but I already had a newer version installed which cmake didn't recognize.

  9. #9
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,121
    Blog Entries
    15

    Default Re: Where can I find Clementine or Amarok 1.4 RPM ?

    Quote Originally Posted by robertsmits
    I tried to compile but I keep getting errors and it doesn't complete.

    Can you tell what I need to change? Here is the printout from the last
    time:

    rsmits@linux-9pjy:~> cd clementine-0.7.1
    rsmits@linux-9pjy:~/clementine-0.7.1> cmake ../
    -- The C compiler identification is GNU
    -- The CXX compiler identification is GNU
    -- Check for working C compiler: /usr/bin/gcc
    -- Check for working C compiler: /usr/bin/gcc -- works
    -- Detecting C compiler ABI info
    -- Detecting C compiler ABI info - done
    -- Check for working CXX compiler: /usr/bin/c++
    -- Check for working CXX compiler: /usr/bin/c++ -- works
    -- Detecting CXX compiler ABI info
    -- Detecting CXX compiler ABI info - done
    -- Looking for Q_WS_X11
    -- Looking for Q_WS_X11 - found
    -- Looking for Q_WS_WIN
    -- Looking for Q_WS_WIN - not found.
    -- Looking for Q_WS_QWS
    -- Looking for Q_WS_QWS - not found.
    -- Looking for Q_WS_MAC
    -- Looking for Q_WS_MAC - not found.
    -- Found Qt-Version 4.5.3
    -- Found OpenSSL: /usr/lib64/libssl.so
    -- Looking for _POSIX_TIMERS
    -- Looking for _POSIX_TIMERS - found
    -- Looking for XOpenDisplay in
    /usr/lib64/libX11.so;/usr/lib64/libXext.so
    -- Looking for XOpenDisplay in
    /usr/lib64/libX11.so;/usr/lib64/libXext.so - found

    -- Looking for gethostbyname

    -- Looking for gethostbyname - found

    -- Looking for connect

    -- Looking for connect - found

    -- Looking for remove

    -- Looking for remove - found

    -- Looking for shmat

    -- Looking for shmat - found

    -- Looking for IceConnectionNumber in ICE

    -- Looking for IceConnectionNumber in ICE - found

    -- Found X11: /usr/lib64/libX11.so

    -- Boost version: 1.39.0

    -- Found the following Boost libraries:

    -- checking for module 'taglib>=1.6'

    -- package 'taglib>=1.6' not found

    CMake Error at /usr/share/cmake/Modules/FindPkgConfig.cmake:270
    (message):
    A required package was not found

    Call Stack (most recent call first):

    /usr/share/cmake/Modules/FindPkgConfig.cmake:322
    (_pkg_check_modules_internal)
    CMakeLists.txt:50 (pkg_check_modules)



    -- checking for module 'gstreamer-0.10'
    -- found gstreamer-0.10, version 0.10.24
    -- checking for module 'gstreamer-base-0.10'
    -- found gstreamer-base-0.10, version 0.10.24
    -- checking for module 'glib-2.0'
    -- found glib-2.0, version 2.22.4
    -- checking for module 'libxml-2.0'
    -- found libxml-2.0, version 2.7.3
    -- checking for module 'gobject-2.0'
    -- found gobject-2.0, version 2.22.4
    -- checking for module 'libgpod-1.0>=0.7.92'
    -- package 'libgpod-1.0>=0.7.92' not found
    -- checking for module 'gio-2.0'
    -- found gio-2.0, version 2.22.4
    -- checking for module 'libimobiledevice-1.0'
    -- package 'libimobiledevice-1.0' not found
    -- checking for module 'libplist'
    -- package 'libplist' not found
    -- checking for module 'libusbmuxd'
    -- package 'libusbmuxd' not found
    -- checking for module 'libmtp>=1.0'
    -- found libmtp, version 1.0.1
    -- checking for module 'indicate-qt'
    -- package 'indicate-qt' not found
    -- checking for module 'libarchive'
    -- package 'libarchive' not found
    -- Found PythonLibs: /usr/lib64/python2.6/config/libpython2.6.a
    -- Looking for include files CMAKE_HAVE_PTHREAD_H
    -- Looking for include files CMAKE_HAVE_PTHREAD_H - found
    -- Looking for pthread_create in pthreads
    -- Looking for pthread_create in pthreads - not found
    -- Looking for pthread_create in pthread
    -- Looking for pthread_create in pthread - found
    -- Found Threads: TRUE
    -- Performing Test SUPPORTS_OPENMP
    -- Performing Test SUPPORTS_OPENMP - Success
    -- checking for module 'gnutls'
    -- package 'gnutls' not found
    -- Building static qsqlite plugin
    -- Performing Test SUPPORTS_NOBOOL
    -- Performing Test SUPPORTS_NOBOOL - Success

    The following components will be built:
    devices: DeviceKit backend
    devices: MTP support
    devices: GIO backend
    D-Bus support
    Wiimote support
    Visualisations

    The following components WILL NOT be built:
    devices: iPod classic support
    devices: iPod Touch, iPhone, iPad support
    Gnome sound menu integration
    Last.fm support
    (Mac OS X) Sparkle integration
    (unstable) Scripting support: loading archives
    (unstable) Scripting support: Python
    (unstable) Remote control support

    -- Configuring incomplete, errors occurred!
    rsmits@linux-9pjy:~/clementine-0.7.1> ^C
    rsmits@linux-9pjy:~/clementine-0.7.1>

    Hi
    You will need to build a later version of taglib (eg as built for
    11.3), then you will probably fall into dependency hell.......

    Check the configure options, you will probably need to disable things
    until it starts to build;
    Code:
    ../configure --help
    --
    Cheers Malcolm °¿° (Linux Counter #276890)
    openSUSE 11.4 (x86_64) Kernel 2.6.37.6-0.7-desktop
    up 5 days 4:50, 3 users, load average: 0.03, 0.06, 0.11
    GPU GeForce 8600 GTS Silent - Driver Version: 280.13


Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •