Results 1 to 8 of 8

Thread: konqueror and dolphin take more than 3 minutes to open

  1. #1

    Default konqueror and dolphin take more than 3 minutes to open

    Hi.

    I'm using opensuse 11.4 64 bits on an amd 3 kernel. One day it's working fine and the following i't works all fine except konqueror and dolphin. When i try to open them it seem to be frozen (the application, not the system), but in the end they open after 3-4 minutes. Then they work well, but if i close them and open again, or if i open another window I have the same problem. Othe applications (for example firefox) launch quickly.

    any ideas?

    regards

  2. #2
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: konqueror and dolphin take more than 3 minutes to open

    Hi.

    I'm using openSUSE 11.4 64 bits on an AMD 3 Kernel. One day it's working fine and the following i't works all fine except Konqueror and Dolphin. When i try to open them it seem to be frozen (the application, not the system), but in the end they open after 3-4 minutes. Then they work well, but if i close them and open again, or if i open another window I have the same problem. Other applications (for example Firefox) launch quickly.

    any ideas?

    regards
    Is it possible that a partition that you have mapped in your fstab file has a problem? We could take a look at your fstab file & a fdisk command. Why not post the following (using the advance message editor and placing the results in a code field:

    Code:
    su -
    password:
    cat /etc/fstab
    fdisk -l
    Not sure what is meant by "AMD 3 Kernel"? Do you have a AM3 bus on your motherboard or have you loaded Linux kernel version 3.0?

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  3. #3

    Default Re: konqueror and dolphin take more than 3 minutes to open

    Quote Originally Posted by jdmcdaniel3 View Post
    Is it possible that a partition that you have mapped in your fstab file has a problem? We could take a look at your fstab file & a fdisk command. Why not post the following (using the advance message editor and placing the results in a code field:

    Code:
    su -
    password:
    cat /etc/fstab
    fdisk -l
    Here there is the fdisk and fstab. I haven’t changed anything since time ago.

    Code:
    andromeda:/home/fernando # fdisk -l
    
    Disk /dev/sda: 500.1 GB, 500107862016 bytes
    255 heads, 63 sectors/track, 60801 cylinders, 976773168 sectores en total
    Units = sectores of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Identificador del disco: 0x016eead2
    
    Disposit. Inicio    Comienzo      Fin      Bloques  Id  Sistema
    /dev/sda1              63    12594959     6297448+  82  Linux swap / Solaris
    /dev/sda2   *    12594960   222323534   104864287+  83  Linux
    /dev/sda3       222323535   746620874   262148670   83  Linux
    /dev/sda4       746620936   786309119    19844092    5  Extendida
    /dev/sda5       746620938   747247409      313236   83  Linux
    /dev/sda6       747247616   786309119    19530752   83  Linux
    
    
    andromeda:/home/fernando # cat /etc/fstab
    #/dev/disk/by-id/ata-ST3160211AS_6PT0V05Y-part2 /       reiserfs        acl,user_xattr 1 1 
    #/dev/disk/by-id/ata-ST3160211AS_6PT0V05Y-part1 swap    swap    defaults 0 0 
    /dev/disk/by-id/ata-WDC_WD5000AADS-00S9B0_WD-WCAV91599607-part2 /       ext4    acl,user_xattr 1 1 
    /dev/disk/by-id/ata-WDC_WD5000AADS-00S9B0_WD-WCAV91599607-part1 swap    swap    defaults 0 0 
    /dev/disk/by-id/ata-WDC_WD5000AADS-00S9B0_WD-WCAV91599607-part3 /home   ext4    defaults 1 0 
    
    /dev/disk/by-id/ata-ST3500630A_9QG94AT1-part1   /mnt/backup     auto    noauto,defaults,users,exec 
    
    
    proc    /proc   proc    defaults 0 0 
    sysfs   /sys    sysfs   noauto 0 0 
    #usbfs  /proc/bus/usb   usbfs   noauto 0 0 
    
    /dev/fd0        /media/floppy   auto    noauto,user,sync 0 0 
    /dev/sr1        /media/dvd      auto    noauto,ro,user,exec,iocharset=utf8 0 0 
    /dev/sr0        /media/dvdram   auto    noauto,ro,user,exec,iocharset=utf8 0 0 
    /dev/sdc        /media/sdc      auto    noauto,user,exec 0 0 
    #/dev/sda             /media/sdb           auto       noauto,user,exec      0 0  
    #/dev/sda1            /media/sdb1          auto       noauto,user,exec      0 0  
    #/dev/sda2            /media/sdb2          auto       noauto,user,exec      0 0  
    
    devpts  /dev/pts        devpts  mode=0620,gid=5 0 0                                                                                                                                
    #estaban todos los puntos de montaje NFS como este, por defecto, pero los he                                                                                                       
    #modificado todos aumentando el tamaño de la ventana porque mejora mucho la                                                                                                        
    #velocidad de transferencia
    #aldebaran:/home/fernando/documentos    /home/fernando/documentos       nfs auto,defaults 0 0 
    aldebaran:/home/fernando/documentos     /home/fernando/documentos       nfs _netdev,auto,defaults,rsize=32768,wsize=32768,noatime,nodev,vers=3,tcp 0 0 
    aldebaran:/home/maria /home/maria        nfs         _netdev,auto,defaults,rsize=32768,wsize=32768,noatime,nodev,vers=3,tcp 0 0
    aldebaran:/home/fdo   /home/fdo          nfs         _netdev,auto,defaults,rsize=32768,wsize=32768,noatime,nodev,vers=3,tcp 0 0
    aldebaran:/home/comunes   /home/comunes          nfs auto,defaults,rsize=32768,wsize=32768,noatime,nodev,vers=3,tcp,_netdev 0 0
    aldebaran:/home/fernando/webdepartamento   /home/fernando/webdepartamento                nfs auto,defaults,rsize=32768,wsize=32768,noatime,nodev,_netdev,vers=3,tcp 0 0
    none /proc/bus/usb usbfs devgid=113,devmode=664 0 0
    
    #/dev/disk/by-id/ata-ST340810A_3FB1L31T-part1 /home/fernando/vmware ext3       defaults              1 2
    /dev/disk/by-id/usb-Kingston_DataTraveler_2.0_001D92AF7F805B8813111D8E-0:0-part1 /media/llavero vfat defaults,rw,noauto,users
    /dev/disk/by-label/FERNANDO  /media/llavero vfat defaults,rw,noauto,users
    /dev/disk/by-id/usb-Kingston_DT_101_G2_001CC0EC3456F08075E7131B-0:0-part1 /media/software  vfat defaults,rw,noauto,users
    /dev/disk/by-id/usb-USB_Mass_Storage_Device_812520090519-0:0-part1 /media/LECTORMINI vfat defaults,rw,noauto,users
    /dev/disk/by-id/usb-Generic_STORAGE_DEVICE_000000009744-0:0-part1 /media/LECTORGRANDE/1 vfat defaults,rw,noauto,users
    /dev/disk/by-id/usb-Generic_STORAGE_DEVICE_000000009744-0:1-part1 /media/LECTORGRANDE/2 vfat defaults,rw,noauto,users
    /dev/disk/by-id/usb-Generic_STORAGE_DEVICE_000000009744-0:2-part1 /media/LECTORGRANDE/3 vfat defaults,rw,noauto,users
    /dev/disk/by-id/usb-Generic_STORAGE_DEVICE_000000009744-0:3-part1 //media/LECTORGRANDE/4 vfat defaults,rw,noauto,users






    Not sure what is meant by "AMD 3 Kernel"? Do you have a AM3 bus on your motherboard or have you loaded Linux kernel version 3.0?

    Thank You,
    It's a problem of using Spanish construction when writing in English, I meant "a three kernel AMD processor". I mean that the machine is powerful enough not to need such a long time opening any process.


    I'm doing some tests and I've just found that it is a problem with my main user, but not with all of them.
    I've launched konqueror from a console (konsole).
    When I do it with my main user, the result is this
    Code:
    fernando@andromeda:~> konqueror
    konqueror(11667)/kdeui (kdelibs): Attempt to use QAction "opera-browser" with KXMLGUIFactory! 
    konqueror(11667)/kdeui (kdelibs): Attempt to use QAction "wine-extension-html" with KXMLGUIFactory! 
    konqueror(11667)/kdeui (kdelibs): Attempt to use QAction "" with KXMLGUIFactory! 
    QPainter::begin: Widget painting can only begin as a result of a paintEvent
    QPainter::translate: Painter not active
    QPainter::setClipRect: Painter not active
    konqueror(11667)/kdeui (kdelibs): Attempt to use QAction "dolphin" with KXMLGUIFactory! 
    konqueror(11667)/kdeui (kdelibs): Attempt to use QAction "gwenview" with KXMLGUIFactory! 
    konqueror(11667)/kdeui (kdelibs): Attempt to use QAction "" with KXMLGUIFactory! 
    konqueror(11667)/kdecore (K*TimeZone*): KSystemTimeZones: ktimezoned initialize() D-Bus call failed:  "Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken." 
    
    konqueror(11667) KSambaSharePrivate::testparmParamValue: We got some errors while running testparm "Load smb config files from /etc/samba/smb.conf
    Loaded services file OK.
    Invalid combination of parameters for service HP2550L.                     Level II oplocks can only be set if oplocks are also set.
    when I press enter after "konqueror" It's a long time (more or less 2 minutes) until nothing appears, then the three strange lines (about opera, wine ..) appear and it takes a while (maybe 1-2 minutes) until the rest of the lines appear in the console and konqueror starts

    If I start konqueror from a console with other user, I get this
    Code:
    maria@andromeda:~> konqueror
    konqueror(11638)/kdeui (kdelibs): Attempt to use QAction "dolphin" with KXMLGUIFactory! 
    konqueror(11638)/kdeui (kdelibs): Attempt to use QAction "gwenview" with KXMLGUIFactory! 
    konqueror(11638)/kdeui (kdelibs): Attempt to use QAction "" with KXMLGUIFactory! 
    konqueror(11638) KSambaSharePrivate::testparmParamValue: We got some errors while running testparm "Load smb config files from /etc/samba/smb.conf
    Loaded services file OK.
    Invalid combination of parameters for service HP2550L.                     Level II oplocks can only be set if oplocks are also set.

    And it starts quickly.



    thanks

  4. #4
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: konqueror and dolphin take more than 3 minutes to open

    I removed everything that started with a #, meaning a comment:

    Code:
    /dev/disk/by-id/ata-WDC_WD5000AADS-00S9B0_WD-WCAV91599607-part2 /       ext4    acl,user_xattr 1 1 
    /dev/disk/by-id/ata-WDC_WD5000AADS-00S9B0_WD-WCAV91599607-part1 swap    swap    defaults 0 0 
    /dev/disk/by-id/ata-WDC_WD5000AADS-00S9B0_WD-WCAV91599607-part3 /home   ext4    defaults 1 0 
    /dev/disk/by-id/ata-ST3500630A_9QG94AT1-part1   /mnt/backup     auto    noauto,defaults,users,exec 
    
    proc    /proc   proc    defaults 0 0 
    sysfs   /sys    sysfs   noauto 0 0 
    #usbfs  /proc/bus/usb   usbfs   noauto 0 0 
    
    /dev/fd0        /media/floppy   auto    noauto,user,sync 0 0 
    /dev/sr1        /media/dvd      auto    noauto,ro,user,exec,iocharset=utf8 0 0 
    /dev/sr0        /media/dvdram   auto    noauto,ro,user,exec,iocharset=utf8 0 0 
    /dev/sdc        /media/sdc      auto    noauto,user,exec 0 0 
    
    devpts  /dev/pts        devpts  mode=0620,gid=5 0 0                                                                                                                                
    
    aldebaran:/home/fernando/documentos     /home/fernando/documentos       nfs _netdev,auto,defaults,rsize=32768,wsize=32768,noatime,nodev,vers=3,tcp 0 0 
    aldebaran:/home/maria /home/maria        nfs         _netdev,auto,defaults,rsize=32768,wsize=32768,noatime,nodev,vers=3,tcp 0 0
    aldebaran:/home/fdo   /home/fdo          nfs         _netdev,auto,defaults,rsize=32768,wsize=32768,noatime,nodev,vers=3,tcp 0 0
    aldebaran:/home/comunes   /home/comunes          nfs auto,defaults,rsize=32768,wsize=32768,noatime,nodev,vers=3,tcp,_netdev 0 0
    aldebaran:/home/fernando/webdepartamento   /home/fernando/webdepartamento                nfs auto,defaults,rsize=32768,wsize=32768,noatime,nodev,_netdev,vers=3,tcp 0 0
    none /proc/bus/usb usbfs devgid=113,devmode=664 0 0
    
    /dev/disk/by-id/usb-Kingston_DataTraveler_2.0_001D92AF7F805B8813111D8E-0:0-part1 /media/llavero vfat defaults,rw,noauto,users
    /dev/disk/by-label/FERNANDO  /media/llavero vfat defaults,rw,noauto,users
    /dev/disk/by-id/usb-Kingston_DT_101_G2_001CC0EC3456F08075E7131B-0:0-part1 /media/software  vfat defaults,rw,noauto,users
    /dev/disk/by-id/usb-USB_Mass_Storage_Device_812520090519-0:0-part1 /media/LECTORMINI vfat defaults,rw,noauto,users
    /dev/disk/by-id/usb-Generic_STORAGE_DEVICE_000000009744-0:0-part1 /media/LECTORGRANDE/1 vfat defaults,rw,noauto,users
    /dev/disk/by-id/usb-Generic_STORAGE_DEVICE_000000009744-0:1-part1 /media/LECTORGRANDE/2 vfat defaults,rw,noauto,users
    /dev/disk/by-id/usb-Generic_STORAGE_DEVICE_000000009744-0:2-part1 /media/LECTORGRANDE/3 vfat defaults,rw,noauto,users
    /dev/disk/by-id/usb-Generic_STORAGE_DEVICE_000000009744-0:3-part1 //media/LECTORGRANDE/4 vfat defaults,rw,noauto,users
    The items in bold seem to be missing the last field (0 0), the whole things seems disorganized and you seem to have more partitions that brought up by your fdisk command. Network mapping is one thing, but what are the items listed here in bold, where does this come from? I never recommend you mount anything to the media folder from your fstab file and leave it for auto mounting. We need to take your fstab file line by line to see what can/should be removed. Crazy drive mounting can give any file manager a problem on startup though I am not sure about your user test and just what it might suggest.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  5. #5

    Default Re: konqueror and dolphin take more than 3 minutes to open

    Quote Originally Posted by jdmcdaniel3 View Post
    I removed everything that started with a #, meaning a comment:

    Code:
    /dev/disk/by-id/ata-WDC_WD5000AADS-00S9B0_WD-WCAV91599607-part2 /       ext4    acl,user_xattr 1 1 
    /dev/disk/by-id/ata-WDC_WD5000AADS-00S9B0_WD-WCAV91599607-part1 swap    swap    defaults 0 0 
    /dev/disk/by-id/ata-WDC_WD5000AADS-00S9B0_WD-WCAV91599607-part3 /home   ext4    defaults 1 0 
    /dev/disk/by-id/ata-ST3500630A_9QG94AT1-part1   /mnt/backup     auto    noauto,defaults,users,exec 
    
    proc    /proc   proc    defaults 0 0 
    sysfs   /sys    sysfs   noauto 0 0 
    #usbfs  /proc/bus/usb   usbfs   noauto 0 0 
    
    /dev/fd0        /media/floppy   auto    noauto,user,sync 0 0 
    /dev/sr1        /media/dvd      auto    noauto,ro,user,exec,iocharset=utf8 0 0 
    /dev/sr0        /media/dvdram   auto    noauto,ro,user,exec,iocharset=utf8 0 0 
    /dev/sdc        /media/sdc      auto    noauto,user,exec 0 0 
    
    devpts  /dev/pts        devpts  mode=0620,gid=5 0 0                                                                                                                                
    
    aldebaran:/home/fernando/documentos     /home/fernando/documentos       nfs _netdev,auto,defaults,rsize=32768,wsize=32768,noatime,nodev,vers=3,tcp 0 0 
    aldebaran:/home/maria /home/maria        nfs         _netdev,auto,defaults,rsize=32768,wsize=32768,noatime,nodev,vers=3,tcp 0 0
    aldebaran:/home/fdo   /home/fdo          nfs         _netdev,auto,defaults,rsize=32768,wsize=32768,noatime,nodev,vers=3,tcp 0 0
    aldebaran:/home/comunes   /home/comunes          nfs auto,defaults,rsize=32768,wsize=32768,noatime,nodev,vers=3,tcp,_netdev 0 0
    aldebaran:/home/fernando/webdepartamento   /home/fernando/webdepartamento                nfs auto,defaults,rsize=32768,wsize=32768,noatime,nodev,_netdev,vers=3,tcp 0 0
    none /proc/bus/usb usbfs devgid=113,devmode=664 0 0
    
    /dev/disk/by-id/usb-Kingston_DataTraveler_2.0_001D92AF7F805B8813111D8E-0:0-part1 /media/llavero vfat defaults,rw,noauto,users
    /dev/disk/by-label/FERNANDO  /media/llavero vfat defaults,rw,noauto,users
    /dev/disk/by-id/usb-Kingston_DT_101_G2_001CC0EC3456F08075E7131B-0:0-part1 /media/software  vfat defaults,rw,noauto,users
    /dev/disk/by-id/usb-USB_Mass_Storage_Device_812520090519-0:0-part1 /media/LECTORMINI vfat defaults,rw,noauto,users
    /dev/disk/by-id/usb-Generic_STORAGE_DEVICE_000000009744-0:0-part1 /media/LECTORGRANDE/1 vfat defaults,rw,noauto,users
    /dev/disk/by-id/usb-Generic_STORAGE_DEVICE_000000009744-0:1-part1 /media/LECTORGRANDE/2 vfat defaults,rw,noauto,users
    /dev/disk/by-id/usb-Generic_STORAGE_DEVICE_000000009744-0:2-part1 /media/LECTORGRANDE/3 vfat defaults,rw,noauto,users
    /dev/disk/by-id/usb-Generic_STORAGE_DEVICE_000000009744-0:3-part1 //media/LECTORGRANDE/4 vfat defaults,rw,noauto,users
    The items in bold seem to be missing the last field (0 0), the whole things seems disorganized and you seem to have more partitions that brought up by your fdisk command. Network mapping is one thing, but what are the items listed here in bold, where does this come from? I never recommend you mount anything to the media folder from your fstab file and leave it for auto mounting. We need to take your fstab file line by line to see what can/should be removed. Crazy drive mounting can give any file manager a problem on startup though I am not sure about your user test and just what it might suggest.

    Thank You,
    I've more partitions that brought up by fdisk because I've an extraible HD in a rack (it is the /mnt/backup with noauto)
    The items in /media/* are usb disks. It's a trick I'm using because since I upgrade to 11.4 the systems ask me for root password for unmounting usb devices, and I haven't been able to find the solution to that, so if I put the usb devices I use to mount in fstab and I mark them as noauto,users, I solve it (at least It has being working without problems during months).

    I've tried to remove (actually comment) these lines for usb devices from fstab, and the problem seems to stop.
    Then I've tried to change them from /media to /mnt and it seems to work, konqueror launched quickly, but after half an hour using the computer it begun to fail again, but, as before, it has failed only with my main user, not with others users (maybe I've not tried long enough with them)

    When launching dolphin from a console, when it fails It report the following error:
    Code:
    fernando@andromeda:~> dolphin
    dolphin(7938)/kdecore (K*TimeZone*): KSystemTimeZones: ktimezoned initialize() D-Bus call failed:  "Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken." 
    
    fernando@andromeda:~> dolphin(7938) KSambaSharePrivate::testparmParamValue: We got some errors while running testparm "Load smb config files from /etc/samba/smb.conf
    Loaded services file OK.
    Invalid combination of parameters for service HP2550L.                     Level II oplocks can only be set if oplocks are also set.
    and then it opens dolphin (but with 3-4 minutes delay).

    I will continue testing


    thanks

  6. #6

    Default Re: konqueror and dolphin take more than 3 minutes to open

    Quote Originally Posted by fperal View Post
    I will continue testing
    I've continued testing. I've got the same problem with these lines removed from fstab, so it's not fstab the problem.
    The problem does not appear when I open my session but a long time after it (several minutes).

  7. #7

    Default Re: konqueror and dolphin take more than 3 minutes to open

    I've solved the problem.
    It might be a problem produced by an update.
    I had some repositories enabled apart from the OSS:
    Code:
    andromeda:/home/fernando # LANG=C zypper lr    
    #  | Alias             | Name                            | Enabled | Refresh
    ---+-------------------+---------------------------------+---------+--------
     1 | KDE4_core         | KDE4 core                       | No      | Yes    
     2 | KDE4_extra        | KDE4 extra                      | No      | Yes    
     3 | Mozilla           | Mozilla                         | Yes     | Yes    
     4 | Packman           | Packman                         | Yes     | Yes    
     5 | Printing          | Printing                        | Yes     | Yes    
     6 | Videolan          | Videolan                        | Yes     | Yes    
     7 | google-talkplugin | google-talkplugin               | Yes     | Yes    
     8 | nvidia-11.4       | NVIDIA Repository Opensuse 11.4 | Yes     | Yes    
     9 | repo-11.4-non-oss | openSUSE-11.4 Non-OSS           | Yes     | Yes    
    10 | repo-11.4-oss     | openSUSE-11.4 OSS               | Yes     | Yes    
    11 | repo-11.4-update  | openSUSE-11.4 Updates           | Yes     | Yes
    Both KDE4 repos had highest priority to OSS. I think an automatic update might change some library from KDE4 repos and it make the system malfunction.

    I did the followind form fixing it:

    -I disabled KDE4 repos

    -First from Yast, I select "change all system packages" to the OSS repo -> it changed most of the system to the original package configuration (for example it downgraded firefox to 4.0 beta). The problem with konqueror and dolphin was automatically solved. I have to delete some packages because of dependencies problem (for example k3b), I take note of them for reinstaling them after all.

    -Then I select "change system packages" to the update repo -> for having them updated, system continued working well

    -Then I reinstalled the deleted things like k3b some of them from the OSS repo, others, like k3b from packman repo

    -I re-enable KDE4 repos, but with lesss priority than OSS repo (I need them form some packages that are not in OSS repo), I tried to do an zypper dup, but I found that it was going to do a lot of repository change on KDE libraries from OSS to KDE4 repo, so I abort it.

    Then I disabled both KDE4 repos and i tried again, the result seemed much better (just vendor change on programs to mozilla and some of them to packman)
    I did it and now the system Is updated to the last packages and It works fine.


    regards

  8. #8
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: konqueror and dolphin take more than 3 minutes to open

    Yes fperal, mixing version of the core desktop files can be a problem. I am happy to hear you found the issue with your setup and thank you for sharing the solution with us as well.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •