Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: How do I make audacity find/recognize ladspa plugins?

  1. #1

    Default How do I make audacity find/recognize ladspa plugins?

    I'm sure this is a painfully naive question, but I don't suppose it can possibly lower my reputation...

    For Good Reasons, I use a custom build of the audio editor audacity rather than the version in the openSUSE repositories. What I can't seem to figure out is how to get it to find and load the LADSPA signal processing plug-ins. I have the regulation ladspa libraries (1.13-6.2) from the Oss repository installed. The files reside at /usr/lib64/ladspa . audacity is built with ladpsa support enabled, and indeed reports that it is enabled if I look at the Effects tab under preferences. I have even entered the ladspa library path in a "ladspa.conf" file under /etc/ld/so.conf.d, which may or may not help. Regardless, I don't seem to see the ladpsa effects listed when I run audacity.

    What am I missing here?

    tnx

    maab

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    28,846
    Blog Entries
    15

    Default Re: How do I make audacity find/recognize ladspa plugins?

    Quote Originally Posted by maabaum
    I'm sure this is a painfully naive question, but I don't suppose it can
    possibly lower my reputation...

    For Good Reasons, I use a custom build of the audio editor audacity
    rather than the version in the openSUSE repositories. What I can't seem
    to figure out is how to get it to find and load the LADSPA signal
    processing plug-ins. I have the regulation ladspa libraries (1.13-6.2)
    from the Oss repository installed. The files reside at /usr/lib64/ladspa
    audacity is built with ladpsa support enabled, and indeed reports that
    it is enabled if I look at the Effects tab under preferences. I have
    even entered the ladspa library path in a "ladspa.conf" file under
    /etc/ld/so.conf.d, which may or may not help. Regardless, I don't seem
    to see the ladpsa effects listed when I run audacity.

    What am I missing here?

    tnx

    maab

    Hi
    You need to install the packman version(s) and use those....

    --
    Cheers Malcolm °¿° (Linux Counter #276890)
    openSUSE 11.4 (x86_64) Kernel 2.6.37.6-0.7-desktop
    up 1 day 4:33, 3 users, load average: 0.09, 0.07, 0.06
    GPU GeForce 8600 GTS Silent - Driver Version: 280.13


  3. #3

    Default Re: How do I make audacity find/recognize ladspa plugins?

    Quote Originally Posted by malcolmlewis View Post
    You need to install the packman version(s) and use those....
    Except for downgrading the version of ladspa, that doesn't seem to change anything.

    maab

  4. #4
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    28,846
    Blog Entries
    15

    Default Re: How do I make audacity find/recognize ladspa plugins?

    Hi
    If you do a search;
    Code:
    zypper se ladspa
    You will see a plethora to install.....
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  5. #5

    Default Re: How do I make audacity find/recognize ladspa plugins?

    As it turns out, I can get the plug-ins to work if I go in and manually add symbolic links to each and every desired ladspa plug-in in the
    /usr/local/share/audacity/plug-ins
    directory, but this seems awfully clumsy.

    Is there some place in the source configuration process where I should be adding the ladspa library path?

    maabaum

  6. #6

    Default Re: How do I make audacity find/recognize ladspa plugins?

    Is there some place in the source configuration process where I should be adding the ladspa library path?
    Never mind, I realize this is devolving into a discussion about audacity internals, not openSUSE. I'll take it to the audacity forum.

    maabaum

  7. #7
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    28,846
    Blog Entries
    15

    Default Re: How do I make audacity find/recognize ladspa plugins?

    Quote Originally Posted by maabaum

    > Is there some place in the source configuration process where I should
    > be adding the ladspa library path?


    Never mind, I realize this is devolving into a discussion about
    audacity internals, not openSUSE. I'll take it to the audacity forum.

    maabaum
    Hi
    You would need to configure your audacity build with the --prefix=/usr
    so it would install in the normal openSUSE FSH.

    --
    Cheers Malcolm °¿° (Linux Counter #276890)
    openSUSE 11.4 (x86_64) Kernel 2.6.37.6-0.7-desktop
    up 1 day 22:43, 3 users, load average: 0.32, 0.17, 0.16
    GPU GeForce 8600 GTS Silent - Driver Version: 280.13


  8. #8

    Default Re: How do I make audacity find/recognize ladspa plugins?

    From the sources:

    Code:
       pathVar = wxGetenv(wxT("LADSPA_PATH"));
       if (pathVar != wxT(""))
          wxGetApp().AddMultiPathsToPathList(pathVar, pathList);
    
       #ifdef __WXGTK__
       wxGetApp().AddUniquePathToPathList(wxT(INSTALL_PREFIX) wxT("/ladspa"), pathList);
       wxGetApp().AddUniquePathToPathList(wxT("/usr/local/lib/ladspa"), pathList);
       wxGetApp().AddUniquePathToPathList(wxT(LIBDIR) wxT("/ladspa"), pathList);
       #endif
    So you can either set the LADSPA_PATH environment variable or use the configure "--libdir" option to make it search in /usr/lib64/ladspa/ instead of in /usr/lib/ladspa/.

  9. #9
    Join Date
    Jun 2008
    Location
    Sogndal, Noreg
    Posts
    1,103

    Default Re: How do I make audacity find/recognize ladspa plugins?

    Quote Originally Posted by maabaum View Post
    Never mind, I realize this is devolving into a discussion about audacity internals, not openSUSE. I'll take it to the audacity forum.

    maabaum
    Hi,

    I just saw this article on the LAU list, it might be of interest: The Architecture of Open Source Applications: Audacity

    Cheers
    OpenSuSE 13.1, KDE 4.11.5, 64bit
    Gigabyte 990FXA-UD3, AMD FX8350, MSI GeForce GTX 760, RME HDSP9632, 16GB HyperX Kingston DDR3, Samsung 840-Pro SSD 128GB, WD Desktop Black 1TB, Hitachi Deskstar 7K1000 750GB

  10. #10
    Join Date
    Sep 2012
    Location
    Quebec, Canada
    Posts
    29

    Default Re: How do I make audacity find/recognize ladspa plugins?

    I had the same problem. This is how to set the LADSPA_ENVIRONMENT:
    Edit /etc/environment
    and add this line for a 64 bit system for 32 bit adjust the path accordingly

    LADSPA_PATH=/usr/lib64/ladspa

    Do not prefix it with words like (PATH or Set) in fact do not prefix the line with anything.
    Reboot and check that the path is set properly in a terminal, type: listplugins
    The list of the plugins will be listed in the terminal window.

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •