Results 1 to 4 of 4

Thread: Dependency problem for x264 on openSUSE 13.1 (32-bit KDE) & Packman

  1. #1
    Join Date
    Dec 2008
    Location
    Buffalo, MN USA
    Posts
    81

    Question Dependency problem for x264 on openSUSE 13.1 (32-bit KDE) & Packman

    I just finished upgrading an old (dual Xeon) Dell to Win7 and also installed the 32-bit version of openSUSE 13.1 KDE (it's now a dual-boot machine).

    I added the libdvdcss and packman repositories per http://forums.opensuse.org/entry.php...allation-Guide, but ran into a problem installing the x264 package when I did the copy/paste instructions for KDE.

    Code:
    Problem: nothing provides libffms2.so.2 needed by x264-0.142svn20140321-1.1.i586
     Solution 1: do not install x264-0.142svn20140321-1.1.i586
     Solution 2: break x264-0.142svn20140321-1.1.i586 by ignoring some of its dependencies
    
    Choose from above solutions by number or cancel [1/2/c] (c): c
    So I did a search for "libffms" and found libffms2-3 is available from the packman repository (but is not installed).

    Unfortunately it provides libffms2.so.3 and x264 is quite specific in it's requirement of libffms2.so.2.

    I'd appreciate an clue as to how best to proceed.

    Thanks,

    ron

  2. #2

    Default Re: Dependency problem for x264 on openSUSE 13.1 (32-bit KDE) & Packman

    Quote Originally Posted by r_widell View Post
    I'd appreciate an clue as to how best to proceed.
    Be patient.
    ffms2 got upgraded today, it takes a while until all other packages (including x264) are rebuilt against the new version.

    The specific problem in this case is that x264 fails to build at the moment because of a wrong changelog file.

    I will report this to Packman shortly.

  3. #3
    Join Date
    Dec 2008
    Location
    Buffalo, MN USA
    Posts
    81

    Thumbs up Re: Dependency problem for x264 on openSUSE 13.1 (32-bit KDE) & Packman

    Quote Originally Posted by wolfi323 View Post
    Be patient.
    I can do that.

    Quote Originally Posted by wolfi323 View Post
    ffms2 got upgraded today, it takes a while until all other packages (including x264) are rebuilt against the new version.

    The specific problem in this case is that x264 fails to build at the moment because of a wrong changelog file.

    I will report this to Packman shortly.
    As long as I know that it's a known issue that's being worked on, I can be quite patient.

    Thanks,
    ron

  4. #4

    Default Re: Dependency problem for x264 on openSUSE 13.1 (32-bit KDE) & Packman

    Quote Originally Posted by r_widell View Post
    As long as I know that it's a known issue that's being worked on, I can be quite patient.
    FYI, this should be fixed in the meantime.

    I installed an updated x264 today and was able to uninstall libffms2.so.2 afterwards without any dependency issues.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •