Results 1 to 2 of 2

Thread: How do I stop Kwallet from interfering with Network Manager?

  1. #1
    Join Date
    Nov 2008
    Location
    Ladysmith, BC, Canada
    Posts
    324

    Unhappy How do I stop Kwallet from interfering with Network Manager?

    I'm putting a opensuse 11.4 64 bit KDE install on an HP -G62 laptop.

    I also use an NFS network.

    I want to use a wireless network.

    The problem is that network manager keeps insisting on asking kwallet for permission to start up the network. As a consequence boot hangs because the nfs network can't find the files in /etc/fstab because the network can't start because you can't see kwallet until it finishes booting.

    I have options set in networkmanager to store the password in connection secrets in secure storage, and it insists on asking kwallet!

    I don't want to get rid of kwallet because it's very useful otherwise - just not at boot time?

    How do I modify the behaviour shown here?

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    13,161
    Blog Entries
    3

    Default Re: How do I stop Kwallet from interfering with Network Manager?

    If you are using knetworkmanager, then switch to using the plasmoid network manager applet. To switch, go into Yast software manager, search for "networkmanager" and select the plasmoid. It will tell give you a choice to uninstall knetworkmanager.

    You might already have the plasmoid, in which case ignore the above.

    Once you have the plasmoid running, click on the icon in the tray (ordinary left click). Select "manage connections" and then select "other". Then choose the option to save connection secrets in a file (unencrypted).

    You might then need to delete the connection that you have defined, and redefine it.

    Note that if you insist on encrypted secrets, then it is going to use kwallet. Storing in a file is the only alternative. The file is kept readable only by you (and root).

    Since you are using NFS over WiFi, I actually have an entirely different suggestion. Go into Yast device manager and switch your WiFi to use "ifup" method. Then configure with Yast. The connection should startup earlier, even if nobody is logged in. The network key in that case is kept in a file readable only by root.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •