Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Packman Repo OpenSuse 11.1 - Header V4 RSA/SHA1 signature: BAD, key ID

  1. #1

    Post Packman Repo OpenSuse 11.1 - Header V4 RSA/SHA1 signature: BAD, key ID

    This is bascially the same error I am getting from this thread
    - Error on Packman Evergreen Essential "BAD KEY"

    Code:
    misspiggy:/home/cvanderlinden # zypper in ffmpeg
    Loading repository data...
    Warning: Repository 'openSUSE-11.1-Update' appears to outdated. Consider using a different mirror or server.
    Reading installed packages...
    Resolving package dependencies...
    
    The following package is going to be upgraded:
      libtheora0
    
    
    The following NEW packages are going to be installed:
      ffmpeg libavcodec53 libavdevice53 libavfilter2 libavformat53 libavutil51 libmp3lame0
    libopencore-amrnb0 libopencore-amrwb0 liborc-0_4-0 libpostproc51 librtmp0
    libschroedinger-1_0-0 libswscale2 libva1 libvpx0 libx264-115 libxvidcore4
    
    
    The following package is going to change vendor:
      libtheora0
    
    
    Overall download size: 5.1 M. After the operation, additional 15.1 M will be used.
    Continue? [YES/no]: YES
    Retrieving package librtmp0-2.3.99.git20110728-1.pm.1.1.i586 (1/19), 59.0 K (120.0 K unpacked)
    Retrieving: librtmp0-2.3.99.git20110728-1.pm.1.1.i586.rpm [done]
    Installing: librtmp0-2.3.99.git20110728-1.pm.1.1 [error]
    Installation of librtmp0-2.3.99.git20110728-1.pm.1.1 failed:
    (with --nodeps --force) Error: Subprocess failed. Error: RPM failed: error: /var/cache/zypp/packages/packman/Essentials/i586/librtmp0-2.3.99.git20110728-1.pm.1.1.i586.rpm: Header V4 RSA/SHA1 signature: BAD, key ID 1abd1afb
    error: /var/cache/zypp/packages/packman/Essentials/i586/librtmp0-2.3.99.git20110728-1.pm.1.1.i586.rpm cannot be installed
    
    
    Abort, retry, ignore? [A/r/i]:
    How can I fix this?

  2. #2
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: Packman Repo OpenSuse 11.1 - Header V4 RSA/SHA1 signature: BAD,key ID

    On 08/11/2011 07:46 PM, cvanderlinden wrote:

    > How can I fix this?


    openSUSE 11.1 past its end of life in January of this year
    <http://en.opensuse.org/Lifetime> and its normal update and other repo
    were therefore withdrawn from the internet..

    your options are to move up to a supported distro (11.3 or 11.4) or join
    "Evergreen", a community effort to prolong maintenance of openSUSE 11.1
    after its end of life, see here http://tinyurl.com/4aflkpy

    --
    DD
    openSUSE®, the "German Engineered Automobiles" of operating systems!

  3. #3
    Join Date
    Jan 2009
    Location
    Switzerland
    Posts
    1,529

    Default Re: Packman Repo OpenSuse 11.1 - Header V4 RSA/SHA1 signature: BAD,key ID

    @DenverD

    OP is using Evergreen repos. This is evident from the error line.

    @cvanderlinden

    You can not fix this. It is a bug, unresolved so far. Disable the packman Essentials repository. You can use all other repositories listed here:

    openSUSE:Evergreen - openSUSE
    Technology is 'stuff that doesn't work yet.' -- Bran Ferren

  4. #4
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: Packman Repo OpenSuse 11.1 - Header V4 RSA/SHA1 signature: BAD,key ID

    On 08/12/2011 10:46 AM, vodoo wrote:
    > OP is using Evergreen repos. This is evident from the error line.


    i know you are probably right ... but i do not see how you can see that..

    because none of the URLs listed in the OP's post include the string
    "evergreen"...yes, there is one which uses "essentials", but are all
    packman essentials evergreen ??

    like i found both of these:
    http://packman.inode.at/suse/11.1/Essentials/i586/
    http://packman.inode.at/suse/Evergre...sentials/i586/

    are they the same?
    if so, why have two paths to the same stuff??

    or, is packman offering _all_ oss/non-oss as well as both past and
    current updates for 11.1 ??

    wow....so, i guess i did't understand--i thought evergreen was to
    support installs of 11.1 which existed prior to the EOL with security
    updates....but, instead one can do a fresh 11.1 install today, because
    _all_ the repos are online...

    oh wait: only the "essentials" are online..

    nevermind...it is too complicated for me to . . .

    --
    DD
    openSUSE®, the "German Engineered Automobiles" of operating systems!

  5. #5

    Default Re: Packman Repo OpenSuse 11.1 - Header V4 RSA/SHA1 signature: BAD,key ID

    Thanks, guys. I did what DenverD said and it all worked out. If I remember correctly I disabled the Packman repo that was giving me the error and added the new one, and I was able to get all the libraries I could ever dream of

    Thanks for the help.

  6. #6
    Join Date
    Jan 2009
    Location
    Switzerland
    Posts
    1,529

    Default Re: Packman Repo OpenSuse 11.1 - Header V4 RSA/SHA1 signature: BAD,key ID

    @cvanderlinden

    Can we please swap roles and I ask the questions?

    Both links posted by DenverD pointing to Essentials give the same error about the key and one is probably just a symlink to the other. So my question is:

    What is the exact URL to the repository you are using now which works?

    I really think it would be good to finish this thread with an answer giving a real solution, because many more users will hit the same problem.

    Thank you.
    Technology is 'stuff that doesn't work yet.' -- Bran Ferren

  7. #7
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: Packman Repo OpenSuse 11.1 - Header V4 RSA/SHA1 signature: BAD,key ID

    On 08/13/2011 11:06 AM, vodoo wrote:
    > I really think it would be good to finish this thread with an answer
    > giving a real solution


    personally, i was SHOCKED to read that i had been helpful

    --
    DD
    openSUSE®, the "German Engineered Automobile" of operating systems!

  8. #8
    josephkk NNTP User

    Default Re: Packman Repo OpenSuse 11.1 - Header V4 RSA/SHA1 signature: BAD, key ID

    On Sat, 13 Aug 2011 09:06:03 GMT, vodoo <vodoo@no-mx.forums.opensuse.org>
    wrote:

    >
    >@cvanderlinden
    >
    >Can we please swap roles and I ask the questions?
    >
    >Both links posted by DenverD pointing to Essentials give the same error
    >about the key and one is probably just a symlink to the other. So my
    >question is:
    >
    >What is the exact URL to the repository you are using now which works?
    >
    >I really think it would be good to finish this thread with an answer
    >giving a real solution, because many more users will hit the same
    >problem.
    >
    >Thank you.


    @voodoo
    Can't speak for OP, but i had the same problem and found a solution in the
    link you posted. My thread is over in multimedia.

    ?-))

  9. #9
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,574
    Blog Entries
    38

    Default Re: Packman Repo OpenSuse 11.1 - Header V4 RSA/SHA1 signature: BAD, key ID

    For openSUSE-11.1, if one wants not only the evergreen maintained OSS and Non-OSS (via Evergreen update) but also wants the packman evergreen, then one can install the Smart Package manager , which one allows one to disable the signature checks causing the problem with Packman.

  10. #10
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,574
    Blog Entries
    38

    Default Re: Packman Repo OpenSuse 11.1 - Header V4 RSA/SHA1 signature: BAD, key ID

    Quote Originally Posted by oldcpu View Post
    For openSUSE-11.1, if one wants not only the evergreen maintained OSS and Non-OSS (via Evergreen update) but also wants the packman evergreen, then one can install the Smart Package manager , which one allows one to disable the signature checks causing the problem with Packman.
    I should add, after Smart Package manager is downloaded, dependencies sorted, installed, and before (or after) appropriate evergreen maintained OSS and Non-OSS (via Evergreen update) and packman evergreen repositories are setup, one can disable the signature checking in smart by typing:
    Code:
    smart --set rpm-check-signatures=false
    To the best of my knowledge YaST software package management does not have this feature.

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •