If I remember correctly I disabled the Packman repo that was giving me the error and added the new one, and I was able to get all the libraries I could ever dream of
As @OP did say nothing about using Smart Package manager but seemed to have solved all problems miraculously by adding a new repo (where those two mentioned by DenverD still do not work for me) I hoped that he would at least run

Code:
zypper lr
and post the results wrapped in CODE tags (Posting in Code Tags - A Guide).