Results 1 to 7 of 7

Thread: Help needed - libreoffice won't open files

  1. #1

    Default Help needed - libreoffice won't open files

    I've had a problem with libreoffice - it won't open files. That is,
    File/Open doesn't bring up a dialog box. File/New works and so does
    using a filename on the command line when starting libreoffice.

    Now there's good news and bad news. The good news is that with help from
    some libreoffice-users folks, I now know what caused this and I have a
    workaround. The bad news is that it's a bug in Libreoffice and I need
    some help testing other versions, please. So here's the steps to reproduce:

    (1) Login to a Gnome session (KDE may also work, dunno)
    (2) Start libreoffice
    (3) Select Tools/Options/LibreOffice/General
    (4) Observe in that page a checkbox 'Use LibreOffice dialogue boxes'
    (5) Ensure the checkbox is blank (not selected)
    (6) Save settings and check that File/Open pops up a dialog box.
    (7) Quit libreoffice and log out of the session
    (8) Login to an LXDE session
    (9) Start libreoffice
    (10) Select File/Open
    *(11) Check whether a dialog box appears
    (12) If not, select Tools/Options/LibreOffice/General
    *(13) Check whether there is a checkbox 'Use LibreOffice dialogue boxes'

    If your system does NOT open a dialog box in step 11 and does NOT have a
    checkbox in step 13, you are seeing the same bug as me.

    I'm using opensuse 11.3. So I'd appreciate any confirmation or
    contradiction on 11.4 or 12.1 beta if anybody's able.

    Cheers, Dave

    PS The workaround is to login to a Gnome session and select that
    checkbox, then go back to LXDE and it all works.

  2. #2
    Join Date
    Oct 2008
    Location
    Glasgow, Scotland
    Posts
    1,134

    Default Re: Help needed - libreoffice won't open files

    My impression is that if you have installed one of:
    libreoffice-kde
    libreoffice-kde4
    libreoffice-gnome
    . you can use the dialogue boxes from the appropriate running desktop environment. Otherwise you should choose the LibreOffice dialogue boxes. To change to a desktop without LO integration and then choose not to use the LO dialogue boxes seems perverse.

    (openSuSE-11.4 KDE-4.7.0, LibreOffice-3.4.2.3)

  3. #3

    Default Re: Help needed - libreoffice won't open files

    eng-int wrote:
    > My impression is that if you have installed one of:
    > libreoffice-kde
    > libreoffice-kde4
    > libreoffice-gnome
    > . you can use the dialogue boxes from the appropriate running desktop
    > environment. Otherwise you should choose the LibreOffice dialogue
    > boxes. To change to a desktop without LO integration and then choose
    > not to use the LO dialogue boxes seems perverse.


    Hi, thanks for the reply! I thought I was warnocked. You're kind of
    right. The problem is this bit:

    "To change to a desktop without LO integration and then choose not to
    use the LO dialogue boxes"

    BUT ...there's no way to make the choice since the option isn't
    presented! You're stuck with whatever the setting was.

    Catch-22

    Or at least that's how it appears on my system and I'm looking for
    confirmation of the same behaviour on another system to confirm the bug.

  4. #4
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: Help needed - libreoffice won't open files

    On 08/09/2011 03:49 PM, Dave Howorth wrote:
    > I've had a problem with libreoffice - it won't open files. That is,
    > File/Open doesn't bring up a dialog box. File/New works and so does
    > using a filename on the command line when starting libreoffice.


    i just opened Writer, clicked on File > Open and a dialog opened, i
    navigated to a Writer document, selected it, and it opened up..

    then, i closed Writer and proceeded with your path:


    > (1) Login to a Gnome session (KDE may also work, dunno)


    using kde 4.6.0

    > (2) Start libreoffice
    > (3) Select Tools/Options/LibreOffice/General
    > (4) Observe in that page a checkbox 'Use LibreOffice dialogue boxes'


    there is no such box to check..

    there is a "Use LibreOffice dialogs" under "Open/Save dialogs" which is
    default NOT checked...and, reading ahead i leave it that way..

    but, since yours and mine is different, i wonder why (i'm using
    LibreOffice 3.3.1 OOO330m19 (Build:8) my full software is listed in sig)


    > (5) Ensure the checkbox is blank (not selected)
    > (6) Save settings and check that File/Open pops up a dialog box.


    i didn't click "Ok" (which is what i guess you meant by "Save", mine has
    no "Save" to click--is that another difference in our versions??)

    since i changed nothing...instead i clicked "Cancel"


    > (7) Quit libreoffice and log out of the session
    > (8) Login to an LXDE session


    oops! i don't have one of them (and didn't read ahead far enough--OH!
    yes i did, last time i read your post i quit before i started...yawn)..

    sorry i can not help more (but, maybe the problem is Gnome > LXDE using
    the same /home (which is something i try to avoid as i found years ago
    that whenever i let Gnome share a /home with another DE things get screwy!!)

    > PS The workaround is to login to a Gnome session and select that
    > checkbox, then go back to LXDE and it all works.


    which kinda reinforces my point..

    --
    DD Software
    openSUSE®, the "German Engineered Automobiles" of operating systems!

  5. #5

    Default Re: Help needed - libreoffice won't open files

    DenverD wrote:
    >> (1) Login to a Gnome session (KDE may also work, dunno)

    >
    > using kde 4.6.0
    >
    >> (2) Start libreoffice
    >> (3) Select Tools/Options/LibreOffice/General
    >> (4) Observe in that page a checkbox 'Use LibreOffice dialogue boxes'

    >
    > there is no such box to check..
    >
    > there is a "Use LibreOffice dialogs" under "Open/Save dialogs" which is
    > default NOT checked...and, reading ahead i leave it that way..
    >
    > but, since yours and mine is different, i wonder why (i'm using
    > LibreOffice 3.3.1 OOO330m19 (Build:8) my full software is listed in sig)


    Hmm, I wrote that I'm using LibreOffice 3.3 330m19(Build:8) and I think
    I cut and pasted that from a terminal. Strange that the version number
    is different but other, apparently more detailed, stuff is the same.

    I wonder if I have 'dialogue boxes' while you have 'dialogs' because of
    a locale difference. I use en_GB. I see your sig is silent on the
    subject Or possibly your Tools/Options dialog is also influenced by KDE?

    > oops! i don't have one of them (and didn't read ahead far enough--OH!
    > yes i did, last time i read your post i quit before i started...yawn)..


    Awww! I was getting sooo excited. It's really easy to add LXDE to your
    system, honest, just a coupl'a clicks in YaST.

    > sorry i can not help more (but, maybe the problem is Gnome > LXDE using
    > the same /home (which is something i try to avoid as i found years ago
    > that whenever i let Gnome share a /home with another DE things get
    > screwy!!)


    Could be I suppose, though I haven't noticed other issues.

  6. #6
    Join Date
    Oct 2008
    Location
    Glasgow, Scotland
    Posts
    1,134

    Default Re: Help needed - libreoffice won't open files

    @dhj-novell

    It finally sank in - the disappearing checkbox 'Use LibreOffice dialogue boxes'. I am also using en-GB and have 'boxes'

    I have Openbox on this machine. Logging into an Openbox session there is no 'Use LibreOffice dialogue boxes' checkbox. Previously and subsequently in KDE the box is present and remained unchecked. In the Openbox session I clicked on File|Open and the LO dialog box opened, displaying the ~/Documents folder.

    I think that you should probably try upgrading your LO installation. Both 3.3.3.1 and 3.4.2.3 are available for openSuSE-11.3 in the OBS repositories.

    LibreOffice 3.4.2 OOO340m1 (Build:203)

  7. #7
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: Help needed - libreoffice won't open files

    On 08/10/2011 02:41 PM, Dave Howorth wrote:

    > Hmm, I wrote that I'm using LibreOffice 3.3 330m19(Build:8) and I think
    > I cut and pasted that from a terminal. Strange that the version number
    > is different but other, apparently more detailed, stuff is the same.


    hmmmm...i just opened Writer, click to help and see exactly what i wrote
    before, and one more line "tag libreoffice-3.3.1.2"


    > I wonder if I have 'dialogue boxes' while you have 'dialogs' because of
    > a locale difference. I use en_GB.


    that must be the difference....for sure yours has misspelled dialog


    > Awww! I was getting sooo excited. It's really easy to add LXDE to your
    > system, honest, just a coupl'a clicks in YaST.


    ok, here is what i did:
    -added a test user
    -logged out and then in as the new test user
    -added LXDE using YaST
    -logged out and into LXDE as the new test user (hey this kinda snappy
    feeling)
    -opened Writer, went File > Open and the expected dialog window popped
    up...i navigated to ~/Documents and (surprise) it is empty (duh) so i
    type some junk into the open document and save it to ~/Documents/test.odt
    -close Writer
    -open Writer, go File > Open and again the expected dialog opens, nav to
    the just created document, open it...yep its still there...
    -closce writer etc etc now back in comfortable KDE (but, i do intend to
    do some more LXDE....maybe even switch....who knows!)
    -check Writer, yep it still has a dialog when i do File > Open


    --
    DD Software
    openSUSE®, the "German Engineered Automobiles" of operating systems!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •