Results 1 to 5 of 5

Thread: Package updates not installed in openSUSE 11.4 KDE. Why?

  1. #1

    Default Package updates not installed in openSUSE 11.4 KDE. Why?

    Hi,

    I am running openSUSE 11.4 KDE 4.6.5 on my desktop AMD64. Just added R47 repo in order to upgrade KDE 4.6.5 to 4.7. However, after running zypper up I saw lots of packages not being updated.

    Code:
    uname -r
    2.6.37.6-0.7-desktop
    Code:
    zypper lr -d
    Code:
    #  | Alias                            | Name                             | Enabled | Refresh | Priority | Type   | URI                                                                          | Service
    ---+----------------------------------+----------------------------------+---------+---------+----------+--------+------------------------------------------------------------------------------+--------
     1 | 11.4-update                      | 11.4-update                      | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/driver:/wireless/11.4-update       |        
     2 | Updates-for-openSUSE-11.4-11.4-0 | Updates for openSUSE 11.4 11.4-0 | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/11.4/                                    |        
     3 | download.nvidia.com-opensuse     | nVidia Graphics Drivers          | Yes     | Yes     |   99     | rpm-md | ftp://download.nvidia.com/opensuse/11.4/                                     |        
     4 | download.opensuse.org-mozilla    | openSUSE BuildService - Mozilla  | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/mozilla/openSUSE_11.4/             |        
     5 | download.opensuse.org-standard   | Main Repository (Contrib)        | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/openSUSE:/11.4:/Contrib/standard/  |        
     6 | kua                              | kua                              | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/KDE:/UpdatedApps/openSUSE_11.4/    |        
     7 | openSUSE-11.4_11.4-0             | openSUSE-11.4 11.4-0             | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/source/distribution/11.4/repo/oss               |        
     8 | openSUSE_Factory                 | openSUSE_Factory                 | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/KDE:/Release:/47/openSUSE_Factory/ |        
     9 | packman.inode.at-suse            | Packman Repository               | Yes     | Yes     |   99     | rpm-md | http://packman.inode.at/suse/openSUSE_11.4/                                  |        
    10 | repo-non-oss                     | openSUSE-11.4-Non-Oss            | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/11.4/repo/non-oss/                 |        
    11 | repo-oss                         | openSUSE-11.4-Oss                | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/11.4/repo/oss/
    Code:
    zypper up
    Loading repository data...
    Reading installed packages...
    
    The following package updates will NOT be installed:
      MozillaFirefox MozillaFirefox-branding-openSUSE akonadi-runtime akregator amarok ark bluedevil 
      bootsplash-branding-openSUSE choqok cln clucene-core digikam digikam-lang dolphin gfxboot gfxboot-branding-openSUSE ggz 
      ggz-client-libs gstreamer-0_10 gstreamer-0_10-plugin-gnomevfs gstreamer-0_10-plugins-base gstreamer-0_10-plugins-good 
      gstreamer-0_10-plugins-good-lang gwenview iw k3b kaddressbook kaffeine kcalc kcharselect kcm_gtk kcolorchooser 
      kde4-filesystem kde4-kgreeter-plugins kdeartwork4-screensaver kdeartwork4-weatherwallpapers kdebase4 kdebase4-libkonq 
      kdebase4-nsplugin kdebase4-openSUSE kdebase4-runtime kdebase4-runtime-branding-openSUSE kdebase4-runtime-xine 
      kdebase4-session kdebase4-workspace kdebase4-workspace-branding-openSUSE kdebase4-workspace-ksysguardd 
      kdebase4-workspace-liboxygenstyle kdegames4 kdegames4-carddecks-default kdegames4-carddecks-other kdegraphics4 kdelibs4 
      kdelibs4-branding-openSUSE kdelibs4-core kdemultimedia4 kdenetwork4-filesharing kdepasswd kdepim4 kdepim4-runtime 
      kdepim4-wizards kdepimlibs4 kdialog kdm kdm-branding-openSUSE kdnssd keditbookmarks kfind kgamma kget kgpg kio_audiocd 
      kio_iso kio_kamera kio_sysinfo kio_sysinfo-branding-openSUSE kipi-plugins kipi-plugins-acquireimage kmag kmahjongg kmail 
      kmines kmix kmousetool knotes kompare konqueror konqueror-plugins konsole kontact konversation kopete korganizer 
      kpackagekit kpat krdc kreversi krfb kruler kscd ksnapshot ksshaskpass ksudoku ktorrent ktorrent-lang kvkbd kwalletmanager 
      kwebkitpart kwin kwrite lensfun libakonadi4 libakonadiprotocolinternals1 libattica0 libbluedevil1 libepub0 libfreebl3 
      libfreebl3-32bit libggz2 libgstapp-0_10-0 libgstinterfaces-0_10-0 libgstreamer-0_10-0 libgstreamer-0_10-0-32bit libiodbc3 
      libkcddb4 libkcompactdisc4 libkdcraw9 libkde4 libkdecore4 libkdegames4 libkdepim4 libkdepimlibs4 libkexiv2-9 libkipi8 
      libkonq5 libksane0 libksuseinstall1 libktorrent3 libktorrent3-lang liblastfm0 liblensfun0 liblqr-1-0 libmsn0_3 
      libopencv2_2 libphonon4 libpolkit-qt-1-1 libqalculate5 libqimageblitz4 libqoauth1 libsoftokn3 libsoftokn3-32bit 
      libsoprano4 libstrigi0 libtag-extras1 libwavpack1 libxine1 libxine1-gnome-vfs libxine1-pulse linphone marble marble-data 
      mjpegtools mozilla-kde4-integration mozilla-nspr mozilla-nspr-32bit mozilla-nss mozilla-nss-32bit mozilla-nss-certs 
      mozilla-nss-certs-32bit okular oxygen-icon-theme oxygen-icon-theme-scalable phonon phonon-backend-gstreamer-0_10 
      phonon-backend-xine plasma-addons plasma-addons-marble plasma-theme-aya plasmoid-quickaccess polkit-kde-agent-1 
      polkit-kde-kcmmodules-1 python-cups python-kde4 python-kdebase4 python-numpy shared-desktop-ontologies skanlite soprano 
      soprano-backend-redland soprano-backend-virtuoso strigi sweeper synaptiks taglib virtuoso-drivers virtuoso-server 
      wireless-regdb
    Any idea? Thanks for your help!

    Last edited by taytong888; 06-Aug-2011 at 12:15. Reason: add info

  2. #2
    Join Date
    Mar 2009
    Location
    sri mayapur, west bengal, india
    Posts
    958

    Default Re: Package updates not installed in openSUSE 11.4 KDE. Why?

    On Sun, 07 Aug 2011 00:46:03 +0530, taytong888
    <taytong888@no-mx.forums.opensuse.org> wrote:

    >
    > Hi,
    >
    > I am running openSUSE 11.4 KDE 4.6.5 on my desktop AMD64. Just added
    > R47 repo in order to upgrade KDE 4.6.5 to 4.7. However, after running
    > zypper up I saw lots of packages not being updated.
    >
    >
    > Code:
    > --------------------
    > uname -r
    > 2.6.37.6-0.7-desktop
    > --------------------
    >
    >
    >
    > Code:
    > --------------------
    > zypper lr -d
    > --------------------
    >
    >
    >
    > Code:
    > --------------------
    > # | Alias |
    > Name | Enabled | Refresh | Priority | Type
    > |
    > URI
    > | Service
    > ---+----------------------------------+----------------------------------+---------+---------+----------+--------+------------------------------------------------------------------------------+--------
    > 1 | 11.4-update |
    > 11.4-update | Yes | Yes | 99 | rpm-md
    > |
    > http://download.opensuse.org/reposit...ss/11.4-update
    > |
    > 2 | Updates-for-openSUSE-11.4-11.4-0 | Updates for openSUSE 11.4
    > 11.4-0 | Yes | Yes | 99 | rpm-md |
    > http://download.opensuse.org/update/11.4/
    > |
    > 3 | download.nvidia.com-opensuse | nVidia Graphics
    > Drivers | Yes | Yes | 99 | rpm-md |
    > ftp://download.nvidia.com/opensuse/11.4/
    > |
    > 4 | download.opensuse.org-mozilla | openSUSE BuildService -
    > Mozilla | Yes | Yes | 99 | rpm-md |
    > http://download.opensuse.org/reposit...openSUSE_11.4/
    > |
    > 5 | download.opensuse.org-standard | Main Repository
    > (Contrib) | Yes | Yes | 99 | rpm-md |
    > http://download.opensuse.org/reposit...trib/standard/
    > |
    > 6 | kua |
    > kua | Yes | Yes | 99 | rpm-md
    > |
    > http://download.opensuse.org/reposit...openSUSE_11.4/
    > |
    > 7 | openSUSE-11.4_11.4-0 | openSUSE-11.4
    > 11.4-0 | Yes | Yes | 99 | yast2 |
    > http://download.opensuse.org/source/.../11.4/repo/oss
    > |
    > 8 | openSUSE_Factory |
    > openSUSE_Factory | Yes | Yes | 99 | rpm-md
    > |
    > http://download.opensuse.org/reposit...nSUSE_Factory/
    > |
    > 9 | packman.inode.at-suse | Packman
    > Repository | Yes | Yes | 99 | rpm-md |
    > http://packman.inode.at/suse/openSUSE_11.4/
    > |
    > 10 | repo-non-oss |
    > openSUSE-11.4-Non-Oss | Yes | Yes | 99 | yast2
    > |
    > http://download.opensuse.org/distrib.../repo/non-oss/
    > |
    > 11 | repo-oss |
    > openSUSE-11.4-Oss | Yes | Yes | 99 | yast2
    > | http://download.opensuse.org/distrib...11.4/repo/oss/
    > --------------------
    >



    why did you choose the KDE 4.7 repo for openSUSE factory instead of 11.4?
    you should be using this one:

    http://download.opensuse.org/reposit...openSUSE_11.4/

    and then, to switch packages from one repository to a different one, you
    have to use "zypper dup --from <alias or URL of your KDE 4.7 repo>", not
    "zypper up".


    --
    phani.

  3. #3
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: Package updates not installed in openSUSE 11.4 KDE. Why?

    I suggest you remove repo #8
    It's the factory repo. You should use this one
    Index of /repositories/KDE:/Release:/47/openSUSE_11.4

    Then do this
    http://dl.dropbox.com/u/10573557/Swi...e47_switch.png
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  4. #4

    Default Re: Package updates not installed in openSUSE 11.4 KDE. Why?

    @caf4926 & phanisvara,

    Sorry. I copied the repo which turned out to be wrong, from thread "KDE 4.7 is out", Post #34 by eng-int August 3 in the Pre-release/Beta sub-forum. I was in a hurry and the correct repo is difficult to find.
    Anyway, I did delete repo #8 and install the correct one from caf4926. A total of 225 packages are being downloaded.

  5. #5
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: Package updates not installed in openSUSE 11.4 KDE. Why?

    I've started a new .kde4 in 4.7
    It's not necessary, but there have been some changes in the panel setup that I wanted to see applied properly to my desktop. But there is a bug in the process if you do employ a new .kde4 (nothing to worry about). But there are two default icons in the new panel setup (firefox and dolphin). When you use them, they seem to vanish, well they do. But if you click from one virtual desktop and back, they appear again. and remain.
    That brings me to another point. If you start a new .kde4, there is no virtual desktop pager in the panel, well there is, just One, but you can't see it. You need to go to the System Settings > Workspace Behaviour to up it to 2 or 4.
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •