Results 1 to 7 of 7

Thread: Blinking of the screen and Xorg CPU usage.

  1. #1

    Default Blinking of the screen and Xorg CPU usage.

    Hello
    Recently I decided to install my first linux. I choose openSUSE. Installation went smooothly and everything seemed to work just fine. After few days i noticed that sometimes my screen blinks for some time. During this blinking everything is working very slow. Today when blinking started i decided to see CPU usage of specific processes and I noticed that during this strange behaviour Xorg CPU usage is about 40% or more, it seems odd to me because usually it is few %. I am wondering what is the cause of this behaviour and how can I do something about it..

    I am using KDE, my graphics card is Intel GMA 4500.

  2. #2
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: Blinking of the screen and Xorg CPU usage.

    Hello
    Recently I decided to install my first linux. I choose openSUSE. Installation went smooothly and everything seemed to work just fine. After few days i noticed that sometimes my screen blinks for some time. During this blinking everything is working very slow. Today when blinking started i decided to see CPU usage of specific processes and I noticed that during this strange behaviour Xorg CPU usage is about 40% or more, it seems odd to me because usually it is few %. I am wondering what is the cause of this behaviour and how can I do something about it..

    I am using KDE, my graphics card is Intel GMA 4500.
    You might give the kernel load option nomodeset a try and see if it helps. Basically, nomodeset is already part of the Failsafe openSUSE startup (which you can look at on how to add it in if it helps). When you boot your computer and the Grub Operating System selection menu comes up, you can just type in nomodeset and then press the enter key to see if this helps. You can later edit the file /boot/grub/menu.lst as root and add in the command (in KDE do a Alt-F2 and then enter: kdesu kwrite /boot/grub/menu.lst) OR you can run YaST / System / Boot Loader and edit the kernel load line from there. With Intel, doing a kernel update clear up to 3.0 can also be helpful, but try nomodeset first.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  3. #3

    Default Re: Blinking of the screen and Xorg CPU usage.

    Ok, I added nomodeset to parameters, some graphics errors are now missing, I will work some time under those settings and see if everything works fine, only one thing bothers me. Now I can't change my screen resolution, there is only 1024x768, and I should have 13xx something, I wonder if I can change it manually somewhere else (not in system configuration panel) or maybe I can't when using nomodeset.

  4. #4
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: Blinking of the screen and Xorg CPU usage.

    AndnA
    Ok, I added nomodeset to parameters, some graphics errors are now missing, I will work some time under those settings and see if everything works fine, only one thing bothers me. Now I can't change my screen resolution, there is only 1024x768, and I should have 13xx something, I wonder if I can change it manually somewhere else (not in system configuration panel) or maybe I can't when using nomodeset.
    Open a terminal and type

    Code:
    xrandr
    to display your display device name(s) and available display modes.

    Create/edit a minimal xorg.conf with an editor like this for KDE:

    Code:
    kdesu kwrite /etc/X11/xorg.conf
    For Gnome:

    Code:
    gnomesu gedit /etc/X11/xorg.conf
    Create/adjust the monitor section like this for example:

    Code:
    Section "Monitor"
       Identifier "LVDS"
       Option "Preferred Mode" "1280x800"
    EndSection
    You can see I've used my laptop display name LVDS. (You'll need to use the
    display name as per your xrandr output). When done, save the file, and restart
    the X-server. Now your desktop should start up in your preferred display mode.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  5. #5

    Default Re: Blinking of the screen and Xorg CPU usage.

    When i type xrandr i get

    Code:
    xrandr: Failed to get size of gamma for output default
    Screen 0: minimum 1024 x 768, current 1024 x 768, maximum 1024 x 768
    default connected 1024x768+0+0 0mm x 0mm
       1024x768       76.0*
    so the display name of my device is default? If yes, then when I created xorg.conf and put
    Code:
    Section "Monitor"
       Identifier "default"
       Option "PreferredMode" "1366x768"
    EndSection
    I restart xserver but nothing changes, I think there may be some more problems, yes?

  6. #6

    Default Re: Blinking of the screen and Xorg CPU usage.

    More info:
    but when I run w/o nomodeset my xrandr looks like this
    Code:
    Screen 0: minimum 320 x 200, current 1366 x 768, maximum 8192 x 8192
    LVDS1 connected 1366x768+0+0 (normal left inverted right x axis y axis) 344mm x 194mm
       1366x768       60.0*+
       1024x768       60.0  
       800x600        60.3     56.2  
       640x480        59.9  
    VGA1 disconnected (normal left inverted right x axis y axis)
    HDMI1 disconnected (normal left inverted right x axis y axis)
    DP1 disconnected (normal left inverted right x axis y axis)
    HDMI2 disconnected (normal left inverted right x axis y axis)
    DP2 disconnected (normal left inverted right x axis y axis)
    DP3 disconnected (normal left inverted right x axis y axis)
    TV1 disconnected (normal left inverted right x axis y axis)

  7. #7
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: Blinking of the screen and Xorg CPU usage.

    When not using nomodeset, it looks like the video is called LVDS1. I am certain I would attempt to upgrade your kernel to version 3.0 to see if that might be helpful. Here is a link for info on how to do that.

    S.A.K.C. - SUSE Automated Kernel Compiler - Version 2.50 - Blogs - openSUSE Forums

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •