I used the YaST Backup utility on OpenSUSE 11.4 64-bit to create a back up of the system, including selecting the critical system areas in the Expert options. After the archives get created, the utility ends with the following error, and I'm worried as to whether I can trust the archive as created properly and suitable for restoring in case I lose the original system drive (it's being shipped internationally, and I moved the archive to another drive):

Switch will be removed from the Perl core distribution in the next major release. Please install it from CPAN. It is being used at /usr/share/YaST2/modules/YaPI/HTTPD.pm, line 299.
Can't locate SaX.pm in @INC (@INC contains: /y2update/modules /root/.yast2/modules /usr/share/YaST2/modules /usr/lib/perl5/site_perl/5.12.3/x86_64-linux-thread-multi /usr/lib/perl5/site_perl/5.12.3 /usr/lib/perl5/vendor_perl/5.12.3/x86_64-linux-thread-multi /usr/lib/perl5/vendor_perl/5.12.3 /usr/lib/perl5/5.12.3/x86_64-linux-thread-multi /usr/lib/perl5/5.12.3 .) at /usr/share/YaST2/modules/XLib.pm line 18.
BEGIN failed--compilation aborted at /usr/share/YaST2/modules/XLib.pm line 18.
Compilation failed in require.
BEGIN failed--compilation aborted (#1)
(F) You said to do (or require, or use) a file that couldn't be
found. Perl looks for the file in all the locations mentioned in @INC,
unless the file name included the full path to the file. Perhaps you
need to set the PERL5LIB or PERL5OPT environment variable to say where
the extra library is, or maybe the script needs to add the library name
to @INC. Or maybe you just misspelled the name of the file. See
perlfunc/require and lib.

Uncaught exception from user code:
Can't locate SaX.pm in @INC (@INC contains: /y2update/modules /root/.yast2/modules /usr/share/YaST2/modules /usr/lib/perl5/site_perl/5.12.3/x86_64-linux-thread-multi /usr/lib/perl5/site_perl/5.12.3 /usr/lib/perl5/vendor_perl/5.12.3/x86_64-linux-thread-multi /usr/lib/perl5/vendor_perl/5.12.3 /usr/lib/perl5/5.12.3/x86_64-linux-thread-multi /usr/lib/perl5/5.12.3 .) at /usr/share/YaST2/modules/XLib.pm line 18.
BEGIN failed--compilation aborted at /usr/share/YaST2/modules/XLib.pm line 18.
Compilation failed in require.
BEGIN failed--compilation aborted.
at -e line 0
y2base: perl.c:542: perl_destruct: Assertion `(my_perl->Iscopestack_ix) == 1' failed.
YaST got signal 6 at YCP file /usr/share/YaST2/clients/x11_auto.ycp:27
/sbin/yast2: line 423: 10811 Aborted $ybindir/y2base $module "$@" "$SELECTED_GUI" $Y2_GEOMETRY $Y2UI_ARGS
Gtk-Message: Failed to load module "gnomesegvhandler"