Results 1 to 9 of 9

Thread: Problem: XFCE

  1. #1
    Join Date
    Jul 2011
    Location
    India
    Posts
    81

    Default Problem: XFCE

    Hi,
    Today i installed xfce and i like it better than gnome except the few problems it creates:
    1. the panel is auto hiding... how to fix it?
    2. laptop trackpad click not working... only button click is working..
    3. The title bar for all windows is gone!

    Please help me fix these problems. thanks

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    13,330
    Blog Entries
    3

    Default Re: Problem: XFCE

    Quote Originally Posted by thinkanish View Post
    Today i installed xfce and i like it better than gnome except the few problems it creates:
    What version of opensuse are you using.

    Quote Originally Posted by thinkanish View Post
    1. the panel is auto hiding... how to fix it?
    That seems strange. I have it autohiding myself. But the default was for it to not be autohiding. Perhaps you have config settings sitting around from an earlier version.

    If you right click on the panel, there should be a setting for this, though I seem to recall that it wasn't completely obvious.

    Quote Originally Posted by thinkanish View Post
    2. laptop trackpad click not working... only button click is working..
    I don't recall seeing an XFCE setting for that. Maybe you will find something useful in this thread:
    HP Touchpad tapping not persistent ...

    Quote Originally Posted by thinkanish View Post
    3. The title bar for all windows is gone!
    Try creating a new user, and see if the same thing happens for a new user. It shouldn't. You probably have some old xfce settings that are confusing it.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  3. #3

    Default Re: Problem: XFCE

    Quote Originally Posted by thinkanish View Post
    1. the panel is auto hiding... how to fix it?
    Code:
     xfconf-query -c xfwm4 -p /general/use_compositing -t bool -s false
    * Don't know why, but enabing/disabling compositing turns the panel autohiding on/off.

  4. #4
    Join Date
    May 2011
    Location
    Lublin, Poland
    Posts
    224

    Default Re: Problem: XFCE

    Panel is auto-hiding with compositing enabled?
    Solution is simple
    Delete it

    And make new one. This one won't autohide.
    Only default panel is bugged.

    Windows titlebar is gone - are you using compiz? Compiz won't work on Xfce. There is a problem with decorator.
    Desktop: Intel Q8300@3,3Ghz, 4GB RAM, Foxconn P35A, Sapphire HD5670, OpenSUSE x64
    Server: Via C3@1.4Ghz, 768MB RAM, 8GB Microdrive + OpenSuSE x86
    and other boxes running Windoze

  5. #5

    Default Re: Problem: XFCE

    Quote Originally Posted by sobrus View Post
    Panel is auto-hiding with compositing enabled?
    Solution is simple
    Delete it

    And make new one. This one won't autohide.
    Only default panel is bugged.
    That's right. The default panel is buggy. (!)
    Deleting this panel and creating another one solves the problem indeed - more exactly creating another panel, then deleting the original one, since you cannot delete a panel if it's the only one.

  6. #6
    Join Date
    May 2011
    Location
    Lublin, Poland
    Posts
    224

    Default Re: Problem: XFCE

    Ok, I managed to run compiz on xfce.
    Although i'm not 100% sure if it always works

    The trick is that you don't run it using "compiz --replace" and then "gtk-window-manager --replace".
    Just

    compiz-manager

    Using compiz --replace launches compiz in "improper" mode, and decorations won't work.

    Also, compiz uses metacity themes, so you will probably need it (and compiz-gnome package too).
    To change theme without gnome use gconf editor (apps/metacity/theme)

    Now I don't miss gnome2 anymore
    Desktop: Intel Q8300@3,3Ghz, 4GB RAM, Foxconn P35A, Sapphire HD5670, OpenSUSE x64
    Server: Via C3@1.4Ghz, 768MB RAM, 8GB Microdrive + OpenSuSE x86
    and other boxes running Windoze

  7. #7
    Join Date
    May 2011
    Location
    Lublin, Poland
    Posts
    224

    Default Re: Problem: XFCE

    update:
    you need to use both "compiz-manager" and then "gtk-window-decorator --replace"
    otherwise it won't work
    Desktop: Intel Q8300@3,3Ghz, 4GB RAM, Foxconn P35A, Sapphire HD5670, OpenSUSE x64
    Server: Via C3@1.4Ghz, 768MB RAM, 8GB Microdrive + OpenSuSE x86
    and other boxes running Windoze

  8. #8
    Join Date
    Jul 2011
    Location
    India
    Posts
    81

    Default Re: Problem: XFCE

    Hi mates, thanks for your suggestion, I am using opensuse 11.4(default with gnome)
    I deleted the panel and created a new one in XFCE! it worked. Thankyou sobrus
    Whats the big deal about something called "AT SPI REGISTRY"? Every time I reboot/logoff/shutdown, it needs to be manually closed (not responding).
    I wanna get rid of this.
    And in gnome, it doesnt detect my fingerprint sensor

  9. #9
    Join Date
    May 2011
    Location
    Lublin, Poland
    Posts
    224

    Default Re: Problem: XFCE

    It seems like AT-SPI is something for impaired people.
    I've removed it (along with bunch of other bloating stuff like gnome-do etc) and system still works. I see no difference.
    Desktop: Intel Q8300@3,3Ghz, 4GB RAM, Foxconn P35A, Sapphire HD5670, OpenSUSE x64
    Server: Via C3@1.4Ghz, 768MB RAM, 8GB Microdrive + OpenSuSE x86
    and other boxes running Windoze

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •