Results 1 to 7 of 7

Thread: Problem Running Virtual Box in opensuse 11.4

  1. #1
    Join Date
    Jul 2010
    Location
    Lucknow, India
    Posts
    46

    Angry Problem Running Virtual Box in opensuse 11.4

    Hi guys.

    I don't know about other I am facing many problems since I shifted to Opensuse 11.4 from 11.3 like crashing of KDE, Application automatically hiding and now VirtualBox stopped working.
    At first tried the VBOX provided with the DVD, but it didn't work. Then I installed VirtualBox 4.0.4 that I have downloaded for Opensuse 11.3. It worked but now I have downloaded version 4.1 and installed and now none of the virtual box is running. I am getting the following msg on the terminal when I run the command "VirtualBox":


    Code:
    gaurav@linux-r9ur:~/Desktop> VirtualBox 
    VirtualBox: supR3HardenedMainGetTrustedMain: dlopen("/usr/lib/virtualbox/VirtualBox.so",) failed: /usr/lib/libQtOpenGL.so.4: undefined symbol: _ZN14QPaintEngineEx11drawEllipseERK5QRect
    does anybody know about this problem and any solution to solve this because I don't want to reInstall Opensuse 11.4 for the 4th time in the passed 2 days.
    These problems making me feel that this version of opensuse is the most unstable version against the claim of the opensuse team that is is most stable version ever.
    I think 11.3 is best version that I have ever used.

    Thanks in advance for your help.

  2. #2
    Join Date
    Dec 2008
    Location
    Sydney, Australia
    Posts
    1,021

    Default Re: Problem Running Virtual Box in opensuse 11.4

    If Virtualbox 4.0.4 works, why not go back to that for now and concentrate on sorting out whatever other problems you're having with openSUSE 11.4 first? Virtualbox 4.1 is a major new version which will be followed by various bug-fixing maintenance releases within weeks, and unless there's some new feature you absolutely need you're better off sticking with what works for now (I'm still on 4.0.4 myself and waiting till 4.1.1 before I try upgrading).
    Günter

    Desk: Tumbleweed, KDE 5, AMD Ryzen 5 3400G, 16Gb, 120Gb SSD, 2 SATA.
    Lap: Thinkpad T430, Tumbleweed, Intel i5, 8Gb, SSD.

  3. #3
    Join Date
    Jul 2010
    Location
    Lucknow, India
    Posts
    46

    Default Re: Problem Running Virtual Box in opensuse 11.4

    Quote Originally Posted by gminnerup View Post
    If Virtualbox 4.0.4 works, why not go back to that for now and concentrate on sorting out whatever other problems you're having with openSUSE 11.4 first? Virtualbox 4.1 is a major new version which will be followed by various bug-fixing maintenance releases within weeks, and unless there's some new feature you absolutely need you're better off sticking with what works for now (I'm still on 4.0.4 myself and waiting till 4.1.1 before I try upgrading).
    Now when I installed v4.1 of VirtualBox, I tried to remove it and installed v4.0.4 , It is showing the same msg on the console.
    I want to ask you that whenever I install the OS the I alo install some RPMs (mainly codecs and download mangers) that I have downloaded stored locally for opensuse 11.3, does these packages may be the root for these problems?

  4. #4
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: Problem Running Virtual Box in opensuse 11.4

    I run 11.4 on two machines with VB 4.1 without any problems (installed from
    the VB repository for openSUSE 11.4).
    From your error message I conclude that you have an incompatibility between
    your qt version and your VB. What qt version and from which repository do
    you run. Which KDE version? And since a openGL library is involved which
    graphics driver is in use?

    --
    PC: oS 11.4 64 bit | Intel Core i7-2600@3.40GHz | KDE 4.6.0 | GeForce GT 420
    | 16GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.6.5 | nVidia
    ION | 3GB Ram

  5. #5
    Join Date
    Jul 2010
    Location
    Lucknow, India
    Posts
    46

    Default Re: Problem Running Virtual Box in opensuse 11.4

    Quote Originally Posted by martin_helm View Post
    I run 11.4 on two machines with VB 4.1 without any problems (installed from
    the VB repository for openSUSE 11.4).
    From your error message I conclude that you have an incompatibility between
    your qt version and your VB. What qt version and from which repository do
    you run. Which KDE version? And since a openGL library is involved which
    graphics driver is in use?
    The qt version is 4.7.1-7.1. I am using the default Qt as is provided in the Opensuse 11.4 DVD. Now I am using the Gnome desktop instead of KDE after the KDE crashed and I reinstalled the System with only Gnome. KDE version was the default as provided with the DVD.
    My Graphics driver as shown in YasT2->Hardware Information is
    "Intel Mobile GME965/GLE960 Integrated Graphics Controller."

    I am having another strange problem in Opensuse 11.4.
    I use a 3G usb modem to connect to the internet. I connect it to the internet using a ModemSuite application built for Ubuntu and is provided to me by The Customer Care of the my device. When I run this application in the ROOT user account, it works fine, but when I use it in a non privilegged account from the SUPERUSER terminal, after the click of Connect button the application window disappears and the internet connects. Now there is no safer way for me to disconnect. Even if the closing of the terminal from which I started the application does not help. For disconnection I have to either Unplug the device or to restart the application.

    This problem is not present in ROOT account of Opensuse 1.4 and any account in Opensuse 11.3..

    Any solution?

  6. #6
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: Problem Running Virtual Box in opensuse 11.4

    gauravsinghfzd wrote:
    >
    > The qt version is 4.7.1-7.1. I am using the default Qt as is provided
    > in the Opensuse 11.4 DVD. Now I am using the Gnome desktop instead of
    > KDE after the KDE crashed and I reinstalled the System with only Gnome.


    Does that mean that VB works now with the gnome only system for you or does
    it still not work?

    > KDE version was the default as provided with the DVD.
    > My Graphics driver as shown in YasT2->Hardware Information is
    > "Intel Mobile GME965/GLE960 Integrated Graphics Controller."
    >


    Your instability in KDE seems somehow related to graphics problems but
    without having it any longer I am afraid we never find out. If gnome works
    for you without problems and you are satisfied using it just stick with it.
    If you still want KDE you should probably open a thread dedicated to that
    problem.

    > I am having another strange problem in Opensuse 11.4.
    > I use a 3G usb modem to connect to the internet. I connect it to the
    > internet using a ModemSuite application built for Ubuntu and is provided
    > to me by The Customer Care of the my device. When I run this application
    > in the ROOT user account, it works fine, but when I use it in a non
    > privilegged account from the SUPERUSER terminal, after the click of
    > Connect button the application window disappears and the internet
    > connects. Now there is no safer way for me to disconnect. Even if the
    > closing of the terminal from which I started the application does not
    > help. For disconnection I have to either Unplug the device or to restart
    > the application.
    >
    > This problem is not present in ROOT account of Opensuse 1.4 and any
    > account in Opensuse 11.3..
    >


    Honestly if I were you I would open a new thread for this separate problem
    with a good name for it since not many people which can help with that will
    look into a thread named "Problem Running Virtual Box in opensuse 11.4".

    --
    PC: oS 11.4 64 bit | Intel Core i7-2600@3.40GHz | KDE 4.6.0 | GeForce GT 420
    | 16GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.6.5 | nVidia
    ION | 3GB Ram

  7. #7
    Join Date
    Jul 2010
    Location
    Lucknow, India
    Posts
    46

    Default Re: Problem Running Virtual Box in opensuse 11.4

    Thanks Martin for having interest in looking into my problem.

    But for me Opensuse 11.4 stinks. I was frustrated by all those problems and 7 format and reinstall of My PC in just 2 days.
    Guess what I got a new one, Eclipse (JAVA-SE & EE) keeps crashing.

    So With all due respect for the 11.4 developers, I switched back to Opensuse 11.3 and is working smooth like butter. Everything except for the KDE that I haven't checked And Doesn't prefer over Gnome.

    Thanks and Bye to all. and also to Opensuse 11.4

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •