Page 1 of 3 123 LastLast
Results 1 to 10 of 24

Thread: KDE 4.7 and KMail

  1. #1
    Join Date
    Dec 2008
    Location
    Braunschweig (Germany)
    Posts
    272

    Default KDE 4.7 and KMail

    Hi,

    today I tried to install KDE 4.7 from the repositories. After a reboot KMail2 wanted to convert my emails..., resulting in no emails, no calendar, no addresses . The conversion didn't work.
    I reinstalled KDE 4.6.5 (stable 4.6 repository) and the emails... were available , but my Kontact appeared in a mixture of german and english (also KMail2 in KDE4.7 was a mixture of german and english).

    Does somebody know, how to get german only menue (without some english relics)?

    Thanks

    Michael

  2. #2
    Join Date
    Dec 2008
    Location
    Braunschweig (Germany)
    Posts
    272

    Default Re: KDE 4.7 and KMail

    Hi,

    I was able to get the complete german translation back .
    You have to replace the kde4-l10n-de, kde4-l10n-de-data and kde4-l10n-de-doc from the upstream release 4.6.5 with the version shipped with Opensuse (4.6.0).

    Michael

  3. #3
    Join Date
    Mar 2010
    Location
    Southern Europe
    Posts
    352

    Default Re: KDE 4.7 and KMail

    Quote Originally Posted by michaelhust View Post
    Hi,

    today I tried to install KDE 4.7 from the repositories. After a reboot KMail2 wanted to convert my emails..., resulting in no emails, no calendar, no addresses . The conversion didn't work.
    This doesn't sound very encouraging... Does everybody have the same experience with Kmail 2?

  4. #4
    Join Date
    Mar 2009
    Location
    sri mayapur, west bengal, india
    Posts
    958

    Default Re: KDE 4.7 and KMail

    On Fri, 29 Jul 2011 00:56:03 +0530, wrbbt
    <wrbbt@no-mx.forums.opensuse.org> wrote:

    >
    > michaelhust;2369166 Wrote:
    >> Hi,
    >>
    >> today I tried to install KDE 4.7 from the repositories. After a reboot
    >> KMail2 wanted to convert my emails..., resulting in no emails, no
    >> calendar, no addresses . The conversion didn't work.

    >
    > This doesn't sound very encouraging... Does everybody have the same
    > experience with Kmail 2?
    >


    not the same, but similar. i can see most of my existing mail & addresses,
    but IMAP doesn't work most of the time. i don't have time right now to get
    into the details and switched to evolution temporarily. something's wrong
    with kmail and/or akonadi & co. used to work fine under KUSC; now it
    doesn't.


    --
    phani.

  5. #5

    Default Re: KDE 4.7 and KMail

    Quote Originally Posted by wrbbt View Post
    This doesn't sound very encouraging... Does everybody have the same experience with Kmail 2?
    Well, in the beginning my old mail folders did not show up. I used "akonadiconsole" to check my settings and "synchronized" them. All folders and mails are there now, nothing lost.

    Kaddressbook did not show my addresses but I created a traditional addressbook from .kde4/share/apps/kabc/std.vcf and copied the addresses into the akonadi-addressbook. Everything is OK now, KMail 2 picks the addresses and sends also groups - which was a problem before.

    I also entered manually the path for .kde4/share/apps/korganizer/std.ics. OK!

    Maybe everything is easier/faster with a new installation - my /home/ has followed me many years and I bet together with some crazy settings. But it did not take long time to fix it.

  6. #6
    Join Date
    Mar 2009
    Location
    sri mayapur, west bengal, india
    Posts
    958

    Default Re: KDE 4.7 and KMail

    On Fri, 29 Jul 2011 01:08:05 +0530, phanisvara <listmail@phanisvara.com>
    wrote:

    > On Fri, 29 Jul 2011 00:56:03 +0530, wrbbt
    > <wrbbt@no-mx.forums.opensuse.org> wrote:
    >
    >>
    >> michaelhust;2369166 Wrote:
    >>> Hi,
    >>>
    >>> today I tried to install KDE 4.7 from the repositories. After a reboot
    >>> KMail2 wanted to convert my emails..., resulting in no emails, no
    >>> calendar, no addresses . The conversion didn't work.

    >>
    >> This doesn't sound very encouraging... Does everybody have the same
    >> experience with Kmail 2?
    >>

    >
    > not the same, but similar. i can see most of my existing mail &
    > addresses, but IMAP doesn't work most of the time. i don't have time
    > right now to get into the details and switched to evolution temporarily.
    > something's wrong with kmail and/or akonadi & co. used to work fine
    > under KUSC; now it doesn't.
    >


    seems some type of KDE-fairy visited me tonight. (booting and) logging
    into KDE i first received a minor shock because the display was mirrored
    horizontally: the toolbar where it belonged, but everything else standing
    on it's head. i remembered that there were X11 and mesa updates yesterday
    night, so recompiled the nvidia driver, which brought sanity back to the
    screen.

    next thing i noticed was akonadi/kwallet asking for my IMAP passwords on
    login, and lo and behold, now kmail2 connects to all resources, shows all
    mail & addresses, and everything seems to work great, even mysqld doesn't
    ursurp half a CPU anymore.

    --
    phani.

  7. #7
    Join Date
    Dec 2008
    Location
    Braunschweig (Germany)
    Posts
    272

    Default Re: KDE 4.7 and KMail

    Hi,

    perhaps it depends on the kind of email account: IMAP (data on server) or POP3 (data local).

    I had the problems with the POP3 account, where the migration assistant have to/should convert my emails into the acconadi database.
    On the other hand, phanisvara had an IMAP account and no problems.

    Michael

  8. #8
    Join Date
    Mar 2009
    Location
    sri mayapur, west bengal, india
    Posts
    958

    Default Re: KDE 4.7 and KMail

    On Fri, 29 Jul 2011 12:16:03 +0530, michaelhust
    <michaelhust@no-mx.forums.opensuse.org> wrote:

    >
    > Hi,
    >
    > perhaps it depends on the kind of email account: IMAP (data on server)
    > or POP3 (data local).
    >
    > I had the problems with the POP3 account, where the migration assistant
    > have to/should convert my emails into the acconadi database.
    > On the other hand, phanisvara had an IMAP account and no problems.
    >


    i must also add that i had gone through the migration much earlier. i
    switched several times between 4.x and 4.7, and all my emails are on IMAP
    servers. the only thing kmail has to take care of are it's own indexes,
    not the actual mails.

    --
    phani.

  9. #9
    Join Date
    Mar 2010
    Location
    Southern Europe
    Posts
    352

    Default Re: KDE 4.7 and KMail

    Quote Originally Posted by virstad View Post
    Well, in the beginning my old mail folders did not show up. I used "akonadiconsole" to check my settings and "synchronized" them. All folders and mails are there now, nothing lost.

    Kaddressbook did not show my addresses but I created a traditional addressbook from .kde4/share/apps/kabc/std.vcf and copied the addresses into the akonadi-addressbook. Everything is OK now, KMail 2 picks the addresses and sends also groups - which was a problem before.

    I also entered manually the path for .kde4/share/apps/korganizer/std.ics. OK!

    Maybe everything is easier/faster with a new installation - my /home/ has followed me many years and I bet together with some crazy settings. But it did not take long time to fix it.
    Thanks for sharing your experience. What you say is useful to me.
    I'm still thinking about going to kde 4.7 or waiting a bit more. Did you notice other problems apart from kmail?

  10. #10

    Default Re: KDE 4.7 and KMail

    Quote Originally Posted by wrbbt View Post
    Thanks for sharing your experience. What you say is useful to me.
    I'm still thinking about going to kde 4.7 or waiting a bit more. Did you notice other problems apart from kmail?
    Well, I could not edit the entries in KOrganizer. Took some minutes to figure out that I must choose the calendar in Settings/Sidebar/Show Calendar Manager, the box there was unchecked.

    A minor problem - I can only add new folders to existing folders in Kmail. I found the possibility to add folders to the root-folder in "akonadiconsole" under "Browser/Tab". I'll wait a while and check what others write about this issue to be on the safe side.

    Another minor problem, sometimes I get duplicates of a mail. Maybe a bug or the result from my old settings. Others have this experience too.

    Annoying is the fact that I must enter the password for KWallet but maybe I am too lazy, I must only do it after a new boot of the machine. :-)

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •