Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: Compiz and Xfce on OpenSuSE 11.4

  1. #1
    Join Date
    May 2011
    Location
    Lublin, Poland
    Posts
    224

    Default Compiz and Xfce on OpenSuSE 11.4

    Hi!

    Is there any simple way to run Compiz under Xfce on OpenSuSE 11.4?

    Compiz runs fine, but there are no window decorations. It's well known problem with running Compiz on anything other than Gnome since Emerald was dropped.
    I've re-installed metacity and compiz-gnome, and tried to run

    gtk-window-magager --replace

    from terminal window, but borders won't show anyway. Metacity runs fine, so it's not a problem with themes.

    I've also installed CCSM and told compiz it to use gtk-window-decorator, but still that's a no go.
    I've tried Emerald from older repositories, but it crashes, and I cannot find older complete installation of compiz anywhere (Compiz 0.8.6 repo disappeared).

    On Gnome2 compiz runs flawlessy, but since it's discontinued I've switched to Xfce. And I would like to use hardware accelerated compositing on it (it's faster and more eye-candy than built-in xfwm4 compositing).
    Desktop: Intel Q8300@3,3Ghz, 4GB RAM, Foxconn P35A, Sapphire HD5670, OpenSUSE x64
    Server: Via C3@1.4Ghz, 768MB RAM, 8GB Microdrive + OpenSuSE x86
    and other boxes running Windoze

  2. #2

    Default Re: Compiz and Xfce on OpenSuSE 11.4

    Except for the pacman command - which is specific to ArchLinux - I think you can follow the method described on Arch Wiki: https://wiki.archlinux.org/index.php/Compiz#XFCE

  3. #3
    Join Date
    May 2011
    Location
    Lublin, Poland
    Posts
    224

    Default Re: Compiz and Xfce on OpenSuSE 11.4

    Ok, I've managed to get it running.
    The proper way is "compiz-manager" with "gtk-window-decorator --replace" custom command line set in Compiz decorator plugin.
    Alternatively, you can launch gtk-window-decorator separately, just use "compiz-manager" instead of "compiz --replace".
    Desktop: Intel Q8300@3,3Ghz, 4GB RAM, Foxconn P35A, Sapphire HD5670, OpenSUSE x64
    Server: Via C3@1.4Ghz, 768MB RAM, 8GB Microdrive + OpenSuSE x86
    and other boxes running Windoze

  4. #4
    Join Date
    Oct 2008
    Location
    Mojave desert
    Posts
    326

    Default Re: Compiz and Xfce on OpenSuSE 11.4

    Thanks. This worked for me, although gtk window decorator is missing buttons in upper right corner (min/max/close), even if I tell gnome tweak tool to show them, so I had to switch to kde windeco (and oxygen-gtk theme to pull in the matching color scheme). I've never used xfce before, but I'll give it a try since late model kde and gnome won't play nice with compiz. -GEF

    FYI, in case anyone else is as new as me, what sobrus means when he says the proper way is "compiz-manager" is that you must add that to the autostart program list in xfce settings, and before you restart, open compiz settings (ccsm) and in the window deorator section, add the line "kde4-window-decorator --replace" (or "gtk-window-decorator --replace") in the "command" field.

  5. #5
    Join Date
    Oct 2008
    Location
    Mojave desert
    Posts
    326

    Default Re: Compiz and Xfce on OpenSuSE 11.4

    Hmm, that autostart entry worked on KDE 4.7, too. My default applications still listed kwin as the window manager, but it was actually compiz. However, boot was terribly slow and the system was unstable, so I edited ~/.config/autostart/compiz-manager.desktop with the additional line:

    OnlyShowIn=xfce

    Incidentally, sobrus, the compiz wallpaper doesn't work for me; instead of getting the four wallpapers I list in compiz, one for each workspace, I get the same wallpaper on every workspace, and it's the one specified in xfce settings. Have you gotten wallpaper to work?

    GEF

  6. #6

    Default Re: Compiz and Xfce on OpenSuSE 11.4

    Quote Originally Posted by gfagan View Post
    Hmm, that autostart entry worked on KDE 4.7, too. My default applications still listed kwin as the window manager, but it was actually compiz. However, boot was terribly slow and the system was unstable, so I edited ~/.config/autostart/compiz-manager.desktop with the additional line:

    OnlyShowIn=xfce
    Hmm, it is normally case sensitive and should end with a semicolon:

    Code:
    OnlyShowIn=XFCE;

  7. #7
    Join Date
    Oct 2008
    Location
    Mojave desert
    Posts
    326

    Default Re: Compiz and Xfce on OpenSuSE 11.4

    Thanks, please_try_again, I'll edit it again, but it seems to be working as-is. I've always seen xfce written in lower case, unlike KDE and GNOME, so I tried that first.

    On another note, I added unsupported plugins and compiz wallpaper works. (I added unsupported to get snow, had the notion of a snowy landscape for wallpaper with more snow falling on it, alas snow does not show up in ccsm.) -GEF

  8. #8

    Default Re: Compiz and Xfce on OpenSuSE 11.4

    Quote Originally Posted by gfagan View Post
    Thanks, please_try_again, I'll edit it again, but it seems to be working as-is. I've always seen xfce written in lower case, unlike KDE and GNOME, so I tried that first.
    Look here:
    Code:
    grep XFCE  /etc/xdg/autostart/*.desktop
    These are the system-wide autostart files. If you want to modify one of them for a specific user, just copy it to the user ~/.config/autostart directory and edit it to suite your needs. But you would achieve (more or less) the same result by using the "Startup and Sessions" utility - which might have a different name under the different desktop environments. While using all of them (specially KDE, Gnome and XFCE), it is sometimes useful to edit them manually to avoid non fatal errors producing unnecessary warnings, because each de startup settings tool rewrites these files its own way, everytime when you enable/disable a programm in autostart (from the GUI user interface).

    You should not use ~/.config/autostart for KDE programs, because programs here get started "before" the session and therefore will be started again at a later point when the session is restored. Autostart programs in KDE should be placed in ~/.kde4/Autostart and contain the following line, so they won't be both autostarted *AND* autorestored:

    Code:
    X-KDE-autostart-phase=2
    I know, this info is out of topic here, but I thought I'll mention it, because it's an annoying problem when you don't know how to fix it. This instruction seems to be ignored in files placed in ~/.config/autostart. Not sure it makes sense. IMHO, it's a bug in KDE. I haven't tried with too many files though.

  9. #9
    Join Date
    May 2011
    Location
    Lublin, Poland
    Posts
    224

    Default Re: Compiz and Xfce on OpenSuSE 11.4

    Quote Originally Posted by gfagan View Post
    Have you gotten wallpaper to work?
    No, it's not working for me either. I just didn't notice, as I use only one wallpaper.
    I think it is caused by lack of compiz integration with xfdesktop, but maybe I'm wrong.

    Quote Originally Posted by gfagan
    FYI, in case anyone else is as new as me, what sobrus means when he says the proper way is "compiz-manager" is that you must add that to the autostart program list in xfce settings, and before you restart, open compiz settings (ccsm) and in the window deorator section, add the line "kde4-window-decorator --replace" (or "gtk-window-decorator --replace") in the "command" field.
    Yes, that's what I meant . But even if you try to launch compiz in command line, you need to use compiz-manager instead of compiz.
    Aleternatively, you can probably add two items in autostart - one for compiz-manager, and one for decorator --replace.
    Desktop: Intel Q8300@3,3Ghz, 4GB RAM, Foxconn P35A, Sapphire HD5670, OpenSUSE x64
    Server: Via C3@1.4Ghz, 768MB RAM, 8GB Microdrive + OpenSuSE x86
    and other boxes running Windoze

  10. #10
    Join Date
    Oct 2008
    Location
    Mojave desert
    Posts
    326

    Default Re: Compiz and Xfce on OpenSuSE 11.4

    Compiz wiki says kill xfdesktop to enable wallpapers, but it doesn't say how: Sure I can kill the process in terminal but it comes right back so I only see my compiz wallpaper for seconds, or I can comment out the line "xfdesktop&" in xinitrc but that just slows down boot, get a black screen for a minute or two and then the xfdesktop wallpaper comes up. -GEF

    PS: Thanks for the autostart tip above.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •