Results 1 to 7 of 7

Thread: Mysql ate my computer!

  1. #1

    Default Mysql ate my computer!

    For the past day or so, mysqld has been hogging one of my two CPUs. On
    System Monitor, I tried "kill" and then "forcibly kill" when that button
    appeared on the menu but all that happened was a new mysqld popped up to
    take its place. I've since found that killing Akonadi first and then the
    forcible kill did the job so the problem seems to be solved.

    What bothers me, is what was it trying to do? I don't use the application
    - as far as I know - so I'm a bit puzzled. I wondered whether Thunderbird
    might use it so closed that down and rebooted but mysqld was still there.

    I suppose now I've got rid of that one - for now - I'll get knotify4
    grabbing a cpu again. At least knotify4 is easy to kill - but then xorg
    usually takes over and I have to end the session.


    --
    Graham Davis, Bracknell, Berks.
    openSUSE 11.4; KDE 4.6.5; AMD Phenom II X2 550 Processor;
    Video: nVidia GeForce 210; Sound: ATI SBx00 Azalia (Intel HDA);
    Wireless: BCM4306

  2. #2
    Juri NNTP User

    Default Re: Mysql ate my computer!

    Am 27.07.2011 02:54, schrieb Cloddy:
    > For the past day or so, mysqld has been hogging one of my two CPUs. On
    > System Monitor, I tried "kill" and then "forcibly kill" when that button
    > appeared on the menu but all that happened was a new mysqld popped up to
    > take its place. I've since found that killing Akonadi first and then the
    > forcible kill did the job so the problem seems to be solved.
    >
    > What bothers me, is what was it trying to do? I don't use the application
    > - as far as I know - so I'm a bit puzzled. I wondered whether Thunderbird
    > might use it so closed that down and rebooted but mysqld was still there.
    >
    > I suppose now I've got rid of that one - for now - I'll get knotify4
    > grabbing a cpu again. At least knotify4 is easy to kill - but then xorg
    > usually takes over and I have to end the session.
    >
    >

    Hello Cloddy,
    I use xampp and have no problem with mysql.
    All data are save on lamp.
    Bye

  3. #3
    Join Date
    Jan 2009
    Location
    Switzerland
    Posts
    1,529

    Default Re: Mysql ate my computer!

    Use akonadiconsole to see what happens. Check the mysql error logs too (those for the mysql server started by akonadi).
    Technology is 'stuff that doesn't work yet.' -- Bran Ferren

  4. #4
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Mysql ate my computer!

    On 2011-07-27 08:54, Cloddy wrote:
    > For the past day or so, mysqld has been hogging one of my two CPUs. On
    > System Monitor, I tried "kill" and then "forcibly kill" when that button
    > appeared on the menu but all that happened was a new mysqld popped up to
    > take its place. I've since found that killing Akonadi first and then the
    > forcible kill did the job so the problem seems to be solved.


    It is akonadi which needs mysql. It is part of kde.

    http://en.wikipedia.org/wiki/Akonadi

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.4 x86_64 "Celadon" at Telcontar)

  5. #5

    Default Re: Mysql ate my computer!

    On Wed, 27 Jul 2011 10:13:06 +0000, Carlos E. R. wrote:

    > It is akonadi which needs mysql. It is part of kde.
    >
    > http://en.wikipedia.org/wiki/Akonadi



    I'm not using KDE-PIM but I may need to do some clearing out of .kde to
    make that clear to Akonadi; thought I'd done it but I see I have missed a
    few bits and bobs - or they got regenerated. May need to start with a
    new .kde - again.



    --
    Graham Davis, Bracknell, Berks.
    openSUSE 11.4; KDE 4.6.5; AMD Phenom II X2 550 Processor;
    Video: nVidia GeForce 210; Sound: ATI SBx00 Azalia (Intel HDA);
    Wireless: BCM4306

  6. #6

    Default Re: Mysql ate my computer!

    Quote Originally Posted by Cloddy View Post
    I'm not using KDE-PIM but I may need to do some clearing out of .kde to
    make that clear to Akonadi; thought I'd done it but I see I have missed a
    few bits and bobs - or they got regenerated. May need to start with a
    new .kde - again.
    It won't be .kde (the kde3 one), but .kde4 (err, the kde 4 one).

  7. #7
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,623
    Blog Entries
    3

    Default Re: Mysql ate my computer!

    It seems impossible to configure KDE to not start akonadi.

    Make sure that you have turned off Desktop Search (Nepomuk/Strigi).

    If that does not sufficiently tame akonadi, there's a configuration file at $HOME/.config/akonadiserverrc where you can configure akonadi to not start the server (i.e. to not start mysql). Akonadi itself will shutdown after that, so it will only briefly run on login. Just make the obvious change to the "StartServer=" setting.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •