Results 1 to 3 of 3

Thread: Cannot Install Anything using Zypper or YaST

  1. #1
    Join Date
    May 2011
    Location
    Derbyshire, United Kingdom
    Posts
    56

    Default Cannot Install Anything using Zypper or YaST

    Hi all,

    I don't know why this is happening, however, all of a sudden I am unable to install any packages (from OpenSUSE repos of course) using either Zypper from the CLI or YaST2. Every time I try and install anything, or perfom a zypper dup, I am greeted with the below error message.

    Code:
    error: error(-30987) getting "" records from Requireversion index
    error: db3 error(-30987) from dbcursor->c_get: DB_PAGE_NOTFOUND: Requested page not found
    error: error(-30987) getting "" records from Requireversion index
    error: db3 error(-30987) from dbcursor->c_get: DB_PAGE_NOTFOUND: Requested page not found
    error: error(-30987) getting "" records from Requireversion index
    error: db3 error(-30987) from dbcursor->c_get: DB_PAGE_NOTFOUND: Requested page not found
    error: error(-30987) getting "" records from Requireversion index
    error: db3 error(-30987) from dbcursor->c_get: DB_PAGE_NOTFOUND: Requested page not found
    error: error(-30987) getting "" records from Requireversion index
    error: db3 error(-30987) from dbcursor->c_get: DB_PAGE_NOTFOUND: Requested page not found
    error: error(-30987) getting "" records from Requireversion index
    error: db3 error(-30987) from dbcursor->c_get: DB_PAGE_NOTFOUND: Requested page not found
    error: error(-30987) getting "" records from Requireversion index
    error: db3 error(-30987) from dbcursor->c_get: DB_PAGE_NOTFOUND: Requested page not found
    error: error(-30987) getting "" records from Requireversion index
    I'm no stranger to OpenSUSE's package manager, however I have yet to come across this error before, any help will be of course, greatly appreciated.

    Tom
    Desktop: OpenSUSE 11.4 | Dell Optiplex GX620 | 3GB RAM | Pentium D 820 2.8 Ghz | 40GB Internal, 250GB External | nVidia GeForce G210

    Netbook: OpenSUSE 11.4 | HP Mini 5101 1366x768 model | Intel Atom N280 | 2GB RAM | 250GB Internal | Intel GMA950

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: Cannot Install Anything using Zypper or YaST

    Try this

    Open a terminal and do

    Code:
    su -
    rpmdb --rebuilddb
    It takes a little time

    Then try again
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: Cannot Install Anything using Zypper or YaST

    sounds like (i think) the rpm data base is corrupted, try this at a
    command line

    Code:
    su -
    rpmdb --rebuilddb
    don't forget the - after su[space] and then give your root password when
    asked...

    give it plenty of time to complete..

    may not work (post again) but i doubt it can cause trouble..

    --
    DD
    Caveat-Hardware-Software
    openSUSE®, the "German Engineered Automobiles" of operating systems!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •