Page 1 of 3 123 LastLast
Results 1 to 10 of 24

Thread: Vote for this bug: Bug 705279 - Fix the LibreOffice

  1. #1

    Default Vote for this bug: Bug 705279 - Fix the LibreOffice


  2. #2

    Default Re: Vote for this bug: Bug 705279 - Fix the LibreOffice

    Hello genixinfo,

    Quote Originally Posted by genixinfo
    I'm afraid I don't quite understand what the bug is.
    When pasting something as "plain text" it shouldn't contain any formatting.
    Where did I put my coffee cup?
    dir -R /home/* | grep "coffee cup"

  3. #3

    Default Re: Vote for this bug: Bug 705279 - Fix the LibreOffice

    Edward_Iii,


    Summary of the bug:




    See how it works:

    1 - Open LibreOffice Writer.

    2 - Copy text with formatting.

    3 - Then, remove the formatting with this function: Edit -> Paste Special ->
    Plain Text.



    Now does not work:

    1 - Open LibreOffice Writer.

    2 - Then, type a word.

    3 - Put the word in bold.

    4 - Then remove the bold, with this function: Edit -> Paste Special -> Plain
    Text.





    Got it?

  4. #4

    Default Re: Vote for this bug: Bug 705279 - Fix the LibreOffice

    Hello genixinfo,

    Quote Originally Posted by genixinfo
    Got it?
    Not quite.

    Quote Originally Posted by genixinfo
    See how it works:

    1 - Open LibreOffice Writer.

    2 - Copy text with formatting.

    3 - Then, remove the formatting with this function: Edit -> Paste Special ->
    Plain Text.
    This works fine as expected.
    I start LibreOffice, copy some formatted text and paste it as "plain text" in the document.
    It will show up as "plain text".

    Quote Originally Posted by genixinfo
    Now does not work:

    1 - Open LibreOffice Writer.

    2 - Then, type a word.

    3 - Put the word in bold.

    4 - Then remove the bold, with this function: Edit -> Paste Special -> Plain
    Text.
    I don't quite understand the last step.
    Do I need to copy the bold text and paste it using the "Paste Special" menu?
    Where did I put my coffee cup?
    dir -R /home/* | grep "coffee cup"

  5. #5
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: Vote for this bug: Bug 705279 - Fix the LibreOffice

    On 07/22/2011 04:26 PM, genixinfo wrote:

    > Got it?


    yes, it works exactly as expected..

    if you want to paste in a bold word do not select "plain text" (here it
    is "Unformatted text" meaning no text decorations or plain text) if you
    want to paste with bold, italiacs, HUGE, underlined or whatever, then
    select (here) Edit -> Paste Special -> Formatted Text [RTF]

    or much easier, to past in bold etc just use Edit -> Paste or
    Shift+Insert or Ctrl+v, that is to say if you want to paste in exactly
    what you copied, just do what is normal..

    only if you do NOT want to carry into the LO doc the font decorations,
    then you use Edit -> Paste Special -> Plain Text which is supposed to,
    and does strip out every thing but the _plain_ text..

    why not ask here if you have discovered a bug and save the dev's the
    time needed to mark it resolved and invalid ?

    --
    DD
    Caveat-Hardware-Software
    openSUSE®, the "German Engineered Automobiles" of operating systems!

  6. #6
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: Vote for this bug: Bug 705279 - Fix the LibreOffice

    On 07/22/2011 04:53 PM, DenverD wrote:
    > why not ask here if you have discovered a bug and save the dev's the
    > time needed to mark it resolved and invalid ?


    i should have said (and sorry i didn't): i wish more folks were willing
    to take the time to file bug reports because those are VERY necessary
    and important to keep making openSUSE and Linux better and better..

    so, keep doing that...but, be aware that Linux does not always do things
    exactly the same way as they might be done in MS-Windows or
    Apple/Mac....and, it is not automatically a bug if things work
    differently than you might expect if you are a seasoned user in another
    operating system, or even just a different distribution of Linux...so,
    be sure and ask around here before you post the bug...

    maybe, like this one, it is not a bug just a misunderstanding...

    --
    DD
    Caveat-Hardware-Software
    openSUSE®, the "German Engineered Automobiles" of operating systems!

  7. #7
    Join Date
    Aug 2008
    Location
    Seattle, WA
    Posts
    1,376

    Default Re: Vote for this bug: Bug 705279 - Fix the LibreOffice

    genixinfo, unlike Ubuntu, bugs (which this isn't) aren't prioritized by "votes." Security/critical patches are handled first, and the rest are handled on a case-by-case basis. Please do report bugs if you find them, but as DD suggests, it might save some trouble if you post here first to see if there's an easy solution.

  8. #8

    Default Re: Vote for this bug: Bug 705279 - Fix the LibreOffice

    I believe, be a bug LibreOffice for Linux. For in LibreOffice for Windows, this bug does not exist, the function described above, operate normally.

  9. #9
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: Vote for this bug: Bug 705279 - Fix the LibreOffice

    On 07/23/2011 04:36 PM, genixinfo wrote:
    >
    > I believe, be a bug LibreOffice for Linux. For in LibreOffice for
    > Windows, this bug does not exist, the function described above, operate
    > normally.


    Linux does not always mimic Windows....and, when it does not, it is a
    design decision, not a bug.

    another why to say that: if i use LibreOffice in Windows and see it not
    past "plain text" when i ask it to, then i will say that that is a
    bug...it is sure not 'normal' for me.

    do you think Microsoft will change theirs to do it right, like Linux?

    --
    DD
    Caveat-Hardware-Software
    openSUSE®, the "German Engineered Automobiles" of operating systems!

  10. #10
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,371

    Default Re: Vote for this bug: Bug 705279 - Fix the LibreOffice

    Dear @genixinfo,

    Please when you try to describe a problem (being it a bug or not) keep to the rules how do define a problem:
    1) describe what you do;
    2) describe what happened;
    3) describe what you though that should happen.
    Never assume that anybody reading it has any assumption about the things that should happen. Thus never say anything like "works as expected", because others do NOT know what you expect, nor do you know what others expect.

    Make all those descriptions as extensive as possible. And show what happens, either by copy/paste of the computer session you do, or by screen dumps put somewhere and post links to them. Never assume even one moment that others are going to do what you did and then see exact the same thing happening as what you saw. Omitting the slightest piece of information may create big misunderstandings between you and the other people who try to help you.

    Never assume that what you do is understood by others as the "logical" or "natural" thing to do in the same circumstances. Others may achieve the same reults in a complete different way then you. Thus, I say it again, explain, explain and illustrate.

    I hope you understand that this is to help you and others to create good cooperation between all of us.

    Regards,
    Henk van Velden

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •