Results 1 to 10 of 10

Thread: LXDE helper applications

  1. #1

    Default LXDE helper applications

    I'm running LXDE on opensuse 11.3 and am getting irritated because whenever I click on the URL of an image it starts Eye of Gnome instead of Firefox to display it. This happens whether the URL is displayed in Firefox or Evolution.

    How do I change it so it uses Firefox? Pretty please.

  2. #2
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: LXDE helper applications

    On 07/21/2011 12:16 PM, djh-novell wrote:
    >
    > How do I change it so it uses Firefox? Pretty please.


    sorrry if unhelpful (i recognize your experience and don't anticipate
    you haven't done all of this already....but, still maybe i offer
    something which lights a different path(?):

    just guessing, but shouldn't the way firefox handles what goes to which
    application be inside firefox, and not the DE?

    maybe try telling ff here: Edit > Preferences > Applications > JPEG
    image (or whatever)..

    mine are currently set to "Always ask" (but, strangely it never does ask).

    WAIT, doesn't the web site get first say in what happens if you left
    click? like if it has a URL associated to a full size pix?

    and, then if no url firefox would default to the above preference list...

    and, if it found nothing there it would pass the click to the DE for
    action....so, you either need to tell ff what to do, or find that LXDE
    guru (not me) who knows where it is hidden . . .

    --
    DD
    Caveat-Hardware-Software
    openSUSE®, the "German Engineered Automobiles" of operating systems!

  3. #3

    Default Re: LXDE helper applications

    DenverD trod carefully around the eggs without breaking any and said:
    > just guessing, but shouldn't the way firefox handles what goes to which
    > application be inside firefox, and not the DE?


    Well, if it was just Firefox displaying this behaviour, I might have
    thought so. But it isn't. And the Firefox applications preferences
    appears to contain nothing to explain the behaviour (yes, I should have
    mentioned that I'd checked that

    Cheers, Dave

  4. #4

    Default Re: LXDE helper applications

    Quote Originally Posted by djh-novell View Post
    Well, if it was just Firefox displaying this behaviour, I might have
    thought so. But it isn't. And the Firefox applications preferences
    appears to contain nothing to explain the behaviour (yes, I should have
    mentioned that I'd checked that

    Cheers, Dave
    Maybe your mime database is damaged (?). Try to rebuild it with
    Code:
    update-mime-database -V
    Anything weird in /usr/share/mime/packages/Overrides.xml ?

  5. #5
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: LXDE helper applications

    On 07/21/2011 01:53 PM, Dave Howorth wrote:
    > DenverD trod carefully around the eggs without breaking any and said:


    sorry...hmmmm...i've never installed/used LXDE...i think oldcpu does (or
    has, rather extensively)..

    wow...i just 15 minutes trying to find online docs...you be on your on
    now, pal!

    hmmmm...the file you seek must be in ~/.lxde/[something] good luck!

    scramble some eggs!!

    --
    DD
    Caveat-Hardware-Software
    openSUSE®, the "German Engineered Automobiles" of operating systems!

  6. #6

    Default Re: LXDE helper applications

    Quote Originally Posted by DenverD View Post
    hmmmm...the file you seek must be in ~/.lxde/[something] good luck!
    Not even.

    Code:
     find . -type d -name "lx*" -o -name "libfm" -o -name "openbox"
    ./.config/openbox
    ./.config/lxpanel
    ./.config/lxde
    ./.config/lxterminal
    ./.config/libfm
    ./.local/share/openbox
    The program to set default webbrowser and mailer in LXDE should be libfm-pref-apps but is not in 11.4 (and probably never was in 11.3). It is in factory and in Fedora (that's how I know it). It creates the file ~/.config/libfm/pref-apps.conf, which looks like that on my system (these are my own .desktop files):

    Code:
    [Preferred Applications]
    CustomWebBrowsers=X_mozilla-firefox.desktop;
    CustomMailClients=X_redhat-sylpheed.desktop;
    But that doesn't answer your question and won't solve your problem. Btw I can NOT confirm this issue under LXDE/11.4 and - as far as I remember - LXDE/11.3. Does it happen *only* in LXDE ... or you don't have way to know because you have only LXDE installed on this machine?

  7. #7
    Taki NNTP User

    Default Re: LXDE helper applications

    On 07/21/2011 06:56 PM, please try again wrote:
    [...] Btw
    > I can NOT confirm this issue under LXDE/11.4 and - as far as I remember
    > - LXDE/11.3. Does it happen *only* in LXDE ... or you don't have way to
    > know because you have only LXDE installed on this machine?
    >
    >


    I don't have this issue, either, 11.4 with LXDE (from the X11:lxde
    repo). I have KDE/awesome/fluxbox/etc. installed.

    I did not have "eog" - Eye of GNOME - on my system. I installed it,
    logged out, and logged in. Still no issue.

    I did have a similar experience when I installed "RedNotebook". The
    application came on when "GVim" should have. Somehow, it insinuated
    itself at the top of the lists of applications for "File Associations".

    I had a peek: "Personal Settings" > "File Associations" > 'text'. I had
    to manually de-list "RedNotebook". (Now there's "Beaver", whatever that
    is. At least, it's at the bottom of the lists.)

  8. #8
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,489
    Blog Entries
    37

    Default Re: LXDE helper applications

    I need to rush off to work this morning and no time to look at this. But I also have never seen this on 4 different LXDE installs that I have. BUT I also have never visited 'eog - Eye of Gnome'.

    One nice thing about LXDE is the packager for LXDE is reachable occasionally on IRC chat freenode #opensuse-lxde and if one is familiar with the SUSEhelp bot one can even send a brief few line PM via the bot to the packager via the bot. LXDE is openSUSE community driven, and it is not Novell nor SuSE-GmbH driven (although SuSE-GmbH have agreed to include this in the openSUSE distribution for the community - ie an EXCELLENT example of what the openSUSE community can do with SuSE-GmbH).

    Keep this thread alive as a reminder, and I'll try to look into this either on my own or with the packagers help.

  9. #9

    Default Re: LXDE helper applications

    oldcpu wrote:
    > Keep this thread alive as a reminder, and I'll try to look into this
    > either on my own or with the packagers help.


    Thanks for the help everybody. The problem is on my home machine so I'll
    try the various suggestions over the weekend and let you all know where
    things stand on Monday.

    Cheers, Dave

  10. #10

    Default Re: LXDE helper applications

    Dave Howorth wrote:
    > oldcpu wrote:
    >> Keep this thread alive as a reminder, and I'll try to look into this
    >> either on my own or with the packagers help.

    >
    > Thanks for the help everybody. The problem is on my home machine so I'll
    > try the various suggestions over the weekend and let you all know where
    > things stand on Monday.


    Just to let everybody know that this problem has gone away.
    Unfortunately I changed a few things (Firefox preferences etc) so I'm
    not entirely sure why it went away, but at least it's cured.

    Thanks for the support.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •