Results 1 to 5 of 5

Thread: Hamachi/KDE - 3 unrelated yet noobish questions.

  1. #1

    Default Hamachi/KDE - 3 unrelated yet noobish questions.

    Hello everyone, a friend introduced me to OpenSUSE not even a week ago and I'm already needing a bit of help >.<.

    While I'm still mostly a noob I managed to set it up without any problem and used guides and google to finish setting up things like network, shared folders and printers and stuff like that but there are a couple of things I can't seem to do/change and was hoping to see if any of you guys could help me.

    First 2 problems are KDE related. I can't seen to find the option to mute all system sounds, specially that annoying "welcome" chime when a user logs in and I also can't find the way to make it so it doesn't autostart all the programs that were running when the machine was turned off.

    Then the other one (the important one) is about Hamachi.
    1) Every time I boot I have to manyally run it doing -> sudo /sbin/tuncfg - hamachi start - hamachi login - hamachi go-online [network] <-. Is there a way to have the system do that automatically at boot time?.

    2) I have a couple of networks I created through LogMeIn website and what I do on my Ubuntu machine is to do hamachi attach [email address here] and I add that client to my networks. The version I downloaded from the repositories it's 0.9.9.9.something but apparently doesn't have the "attach" command. I tried to join one of my networks using "hamachi join [network id in the following format XXX-XXX-XXX] [network password]" and I get an error message saying something like "Can't join network [255]". Am I doing something wrong or is there a newer version available that would fix that?.



    Told you they were newby questions! .
    Thanks! .

  2. #2
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: Hamachi/KDE - 3 unrelated yet noobish questions.

    So you need to go through the KDE Menu / Personnel Settings and look at your many options there:

    1. Menu / Personnel Settings / Common Appearance and Behavior Group / Application and System Notifications / Manage Notifications / Event Source / KDE Workspace (for starters)
    2. Menu / Personnel Settings / System Administration Group / Startup and Shutdown / Session Management / On Logon
    3. You can create a script file like this:

    Code:
    #!/bin/bash
    
    #: Title       : hstart
    #: Date Created: Wed Jul 20 19:41:58 CDT 2011
    #: Last Edit   : Wed Jul 20 19:41:58 CDT 2011
    #: Author      : laucien
    #: Version     : 1.00
    #: Description : 
    #: Options     : 
    
    sudo /sbin/tuncfg - 
    hamachi start - 
    hamachi login - 
    hamachi go-online [network] 
    
    exit 0
    
    # End Of Script
    Copy the text of the script into a text editor and copy it to your /home/username/bin folder (~/bin) as the file called hstart. Then, you need to mark it executable with the command:

    Code:
    chmod +x ~/bin/hstart
    To test, restart your PC, open up a terminal session and type the command:

    Code:
    hstart
    You then must enter your password and the rest works for you. Now, how to start it at startup time? Well, you can copy the script to the following folder in a terminal session folder:

    Code:
    cp ~/bin/hstart ~/.kde4/Autostart/
    The program would then be ran every time you log into KDE, but you must still enter the password:

    You could modify the script as follows, including a password, but this is not recommended by many to do so, but I offer it as another choice:

    Code:
    #!/bin/bash
    
    #: Title       : hstart
    #: Date Created: Wed Jul 20 19:41:58 CDT 2011
    #: Last Edit   : Wed Jul 20 19:41:58 CDT 2011
    #: Author      : James D. McDaniel
    #: Version     : 1.00
    #: Description : 
    #: Options     : 
    
    PASS="123456"    # Real Password Here ! Warning, this is readable by anyone looking at this file!
    
    echo $PASS | sudo -S /sbin/tuncfg -
    hamachi start -
    hamachi login -
    hamachi go-online [network] 
    
    exit 0
    
    # End Of Script
    I am not sure how to answer your last question, but lets go for three out of four. Make sure to modify the final bash script to include the exact commands to use.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  3. #3

    Default Re: Hamachi/KDE - 3 unrelated yet noobish questions.

    Ohh that worked great for everything thanks! . Don't worry about the last part, I can work around that easy enough.

    Only problem I encountered is that as soon as I place the script on ~/.kde4/Autostart and reboot the system would ask me for my username/password then start loading KDE only to go back to the log in screen and ask me for my username/password over and over again. I logged in with another user, removed the script and it booted fine again.

  4. #4
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: Hamachi/KDE - 3 unrelated yet noobish questions.

    Ohh that worked great for everything thanks! . Don't worry about the last part, I can work around that easy enough.

    Only problem I encountered is that as soon as I place the script on ~/.kde4/Autostart and reboot the system would ask me for my username/password then start loading KDE only to go back to the log in screen and ask me for my username/password over and over again. I logged in with another user, removed the script and it booted fine again.
    Not sure why that would occur, but I do not use hamachi. If, you remove the script and running it at the terminal prompt works OK from ~/bin/hstart, then you could add the command sleep 60 just before the sudo command and make it wait for a minute as the other startup tasks may not yet be complete. If running from terminal anytime is a problem, not sure if the command sequence you provided is correct and as exactly entered by you manually to make it load properly so recheck the command list in the script to be correct.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  5. #5

    Default Re: Hamachi/KDE - 3 unrelated yet noobish questions.

    No the script works great as you wrote it and it only fails when I place it into the /Autostart folder. No idea why. I'll try the timer thingy tomorrow to see if that fixes it.

    Thanks for the help! .

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •