Results 1 to 3 of 3

Thread: YaST2 System Services (Runlevel) hangs at 28%

  1. #1

    Default YaST2 System Services (Runlevel) hangs at 28%

    Hi, greetings from Argentina!

    Im having troubles with YaST2 Runlevel editor.
    When I open it hangs at 28%...

    I read this post
    YaST2 runlevel editor hangs at "28%" on "ag_initscripts" in openSuSE 11.3...

    and effectively, if a kill the ag_initscripts process the editor starts.

    But I cant find out why this is happening.

    Im a bit of a newbie to Linux, so please be patient...


  2. #2
    Join Date
    Jun 2008

    Default Re: YaST2 System Services (Runlevel) hangs at 28%

    I have read through the other thread. The only thing I can do is trying to explain a bit more extensive what the analasys is there.

    YaST runlevel is about all the start/stop scripts that are to be run on attaining a certain runlevel. To find out the present situation to be shown to you and to start from when you want to make changes, YaST runs all those scripts with the status parameter. Now the idea is that one of those start/stop scripts is not behaving correct and hangs (what would be a bug in that srcipt of course). What they tried in the other thread is finding out which of the many scripts it is. They tried one method which did not work. And then the thread dies.

    IMHO there are only few options here:
    . It is a script that is not often installed on openSUSE systems, because only very few people have the problem (the other one and you). Thus it could help when you sit down for a while and think about an extra piece of software where you installed a package. It mus be a package that runs start/stop scripts (most often running a deamon). You then could try to run it's start/stop script with the status parameter to check what happens.
    . it is a normal script, used by almost everybody, but it does do strange this on a particular (hardware?) configuration. Very difficult to find I guess.

    HTH. And please come back when you want more help or information about this. You say you are a newbie, but it is difficult to assess your knowledge level from here.
    Henk van Velden

  3. #3

    Default Re: YaST2 System Services (Runlevel) hangs at 28%

    Try to run the following command in a terminal and watch for errors:
    su -c '/sbin/insserv -vn'

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts